Jump to content
You need to play a total of 20 battles to post in this section.
GMCM_Longboard

Registering for test server

15 comments in this topic

Recommended Posts

Members
4 posts
3,005 battles

Am I missing something obvious? 

 

from this page http://pt.worldofwarships.ru/ I click on join now button to create my new Test account as directed to. However I am unable to complete the form because when I fill it out using the same email as my main I get the message "The email address has already been used for registration". Yet it says "You must register your Public Test account with the same email address as your live account to collect your rewards. No exceptions."

 

I am given the option to log in or change password. If I log in then I no longer get the join in button but account management.

 

 

Share this post


Link to post
Share on other sites
3,999
[V_KNG]
Beta Testers
13,205 posts

Am I missing something obvious? 

 

from this page http://pt.worldofwarships.ru/ I click on join now button to create my new Test account as directed to. However I am unable to complete the form because when I fill it out using the same email as my main I get the message "The email address has already been used for registration". Yet it says "You must register your Public Test account with the same email address as your live account to collect your rewards. No exceptions."

 

I am given the option to log in or change password. If I log in then I no longer get the join in button but account management.

 

 

 

Uhmm... i think if you can login on the test server... you uh, just need the PT software on your machine. I'm probably wrong though... only been through a couple of PTs myself... seem to recall it working along those lines. 

Share this post


Link to post
Share on other sites
6,113
[FOXEH]
Banned
14,364 posts
23,321 battles

doesn't that .ru mean you are trying to access the Russian server?

could that possibly be causing the issue?

(I am not being a  smart [edited], I honestly don't know but that was the first thing that jumped out at me. Sorry if it wasn't helpful.)

Share this post


Link to post
Share on other sites
Members
2,857 posts
9,224 battles

Yea make sure your on the NA server. Somehow when I downloaded the PTS before this one I got on the one where all the writing was Cyrillic. I had done 2 test sites before that and had no problems. Luckily for me on the one I had problems with my buddy is into WoWS also, a computer spaz and so happens to sit in the office right next to mine at work figured the problem out.

Share this post


Link to post
Share on other sites
0
[DRKGT]
Members
5 posts
2,082 battles

The only thing I can think of is I was on the Test server a week maybe 2 weeks ago and the account I made then is still active. However they stated  they were going to wipe everything. I have no idea.

Share this post


Link to post
Share on other sites
661
[13TH]
Members
4,899 posts
9,120 battles

I had the same Email problem with registering for public test ..my hotmail email the same one I use at Wows was not excepted finally tried my gmail .. that worked go figure .. I get no rewards for playing test though

Share this post


Link to post
Share on other sites
0
[DRKGT]
Members
5 posts
2,082 battles

I just checked my e-mail addresses spam box and found my rewards from the last test server sitting there waiting to be claimed so I just did. I think this account should be good.

Share this post


Link to post
Share on other sites
0
[-LL-]
Members
2 posts

i went thru the steps to create a new account for the PTS but never received the confirmation email, i'm using the same gmail email address as i do in game.

Share this post


Link to post
Share on other sites
Members
1 post
4,909 battles

When I try  to c create an account on the test server I get a message that says email address has already been used. I am trying to create it with same email as I used for my NA account, I contacted US tech support and they could only help with US problems. I need your helothey said I

Share this post


Link to post
Share on other sites
115
[AWP]
Members
89 posts
9,585 battles

i went thru the steps to create a new account for the PTS but never received the confirmation email, i'm using the same gmail email address as i do in game.

I have also not received my confirmation email. Same email as live NA server

Share this post


Link to post
Share on other sites
34
[TWE]
Members
206 posts
14,649 battles

I had the same problem as well. Simply gave up on it. Not worth my time to bother and figure it out. Who runs thing thing anyway - total jerks?

Share this post


Link to post
Share on other sites
Members
13 posts
540 battles

 

On 9/21/2016 at 3:32 AM, GMCM_Longboard said:

Am I missing something obvious? 

 

from this page http://pt.worldofwarships.ru/ I click on join now button to create my new Test account as directed to. However I am unable to complete the form because when I fill it out using the same email as my main I get the message "The email address has already been used for registration". Yet it says "You must register your Public Test account with the same email address as your live account to collect your rewards. No exceptions."

 

I am given the option to log in or change password. If I log in then I no longer get the join in button but account management.

 

 

this page isn't working (for me atleast)
image.thumb.png.509768fd23c1a7658f8bab2a8d1dbbb9.png

Edited by blast_876

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×