Jump to content
You need to play a total of 20 battles to post in this section.
cfedler

Torpedo Launch Fail?

11 comments in this topic

Recommended Posts

89
[PIR8S]
Members
103 posts
7,272 battles

So i don't know if this is new or i'm just being a complete Derp, but recently, i have found myself seconds away from death, i click to launch torps, i even Hear the Pssshhh Of the launch, but after the explosion of my death, there are no torps in the Water. It seems like it's taking a literal second to launch torps even after it's made the sound of them launching and it's starting to frustrate me. So Am I just Hardcore Derping, or is there actually something wrong

Share this post


Link to post
Share on other sites
Members
824 posts
4,173 battles

By the looks of it ship launched torpedo's have a two part system, the first part is the sound and animation of the torpedo's dropping into the water then after the animation is done playing the engine spawns the armed torpedo's right in the water which can possibly explain why if you die right in between the two parts you get the launching and sound animations but no actual torpedo's afterwards because it was interrupted before it could get to part two of the system. And with that being a very small window it was easy to miss or overlooked because the odd's of it happening at that point is very low.

Edited by Magic_Fighting_Tuna

Share this post


Link to post
Share on other sites
89
[PIR8S]
Members
103 posts
7,272 battles

Well that's happened multiples times to me in the past few Days. So if that's what's happening, WG needs to find a Fix for it because it's ruining my "If I go down, i'm taking you with me" mojo :P

 

Share this post


Link to post
Share on other sites
Members
824 posts
4,173 battles

Well that's happened multiples times to me in the past few Days. So if that's what's happening, WG needs to find a Fix for it because it's ruining my "If I go down, i'm taking you with me" mojo :P

 

Support Ticket time...

Share this post


Link to post
Share on other sites
Members
3,064 posts
1,925 battles

Well that's happened multiples times to me in the past few Days. So if that's what's happening, WG needs to find a Fix for it because it's ruining my "If I go down, i'm taking you with me" mojo :P

 

Same here.

Share this post


Link to post
Share on other sites
1,386
[SYN]
Members
3,775 posts
25,422 battles

Don't leave it till the last second to launch.

Share this post


Link to post
Share on other sites
Members
1,116 posts
10,974 battles

I've launched torps and been killed after launch and have seen them striking and killing a ship.  Did it tonite sinking a Haruna with an Aoba.  I watched the torp track as I was sinking.

Share this post


Link to post
Share on other sites
1,386
[SYN]
Members
3,775 posts
25,422 battles

I've launched torps and been killed after launch and have seen them striking and killing a ship.  Did it tonite sinking a Haruna with an Aoba.  I watched the torp track as I was sinking.

 

The new free cam is fantastic for tracking your torps!

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×