Jump to content
You need to play a total of 20 battles to post in this section.
Sealane

Critical error - updates won't install, game won't run

32 comments in this topic

Recommended Posts

Members
5 posts
2,137 battles

So the game automatically started downloading an update, then it seemed to get to 100% and gave an error message that there was: " critical error - unable to install updates - the application cannot continue - for details see log file".

 No idea what the problem is or where the log file is. The game will not run without the updates installed and I can't get them installed.  Any suggestions?

 

Thanks 

Sealane

Share this post


Link to post
Share on other sites
Members
348 posts
591 battles

File logs are available within the game folder by following this path:

C:\Games\World_of_Warships\logs

Go ahead and post that error log so we can see what's up. An alternative is to simply delete the whole game off of your computer and reinstall, but maybe something else can be done first.

Share this post


Link to post
Share on other sites
Members
3 posts

I have the same problem.

 

 

Critical error.
Unable to extract updates.
The application cannot continue.
For detains, see log file.

 

 

But it does not tell me where to find this log file, and when I look in the folder "fettsheir" pointed to, it is empty?

Share this post


Link to post
Share on other sites
Members
5 posts
2,137 battles

Fettsheir, Same here, the only file in there is called "cleaner" and has cleaner startt/stop times the same day I lost the game access. There  is also something called cleaner.log.bak which is a .bak file whatever that is ... won't open.

Edited by Sealane

Share this post


Link to post
Share on other sites
346
[STURM]
Alpha Tester
2,216 posts
19,883 battles

well, there are a couple of log files, one is wowslauncher.log, in the WoWS root folder, and another is located in the profiles folder, it's called python.log

Share this post


Link to post
Share on other sites
0
[B_O_W]
Members
10 posts
10,918 battles

i have windows 10 and im receiving a critical download error as well and say for details see file log but like everyone else its not showing anything

Share this post


Link to post
Share on other sites
644
[APOC]
Members
1,979 posts
6,423 battles

I am having the same issue. I have uninstalled and reinstalled the game 4 times now, each time making sure to delete all traces of any left behind. The only change I have on my system is that I deleted the Windows 10 backup folder for the upgrade. I run Windows 7, so it involved uninstalling two updates and deleting a folder roughly 8.7 GB in size. I have uninstalled and deleted Aslain's which was my only mod pack.

 

Each time I finish downloading the update (6025.5 MB) it goes to critical error. It says to check logs which are completely empty. I have allowed firewall access, used an integrity check on the client and it still wont go through with the update. Any ideas on a fix?

 

EDIT: Finally figured out what was going on, and the only conclusion I can come to is that it had to do with deleting that large file for the free W10 update. Anyways, the fix was simple:

1. Go to WoWSLauncher: Right click and hit properties

2. Go to Compatibility: Run as Windows 7 (or w/e version you are on) and run as admin. I have also found that this fix helps with Windows 10 bugs.

 

The installation took much longer but it is confirmed working. Hope this helps anyone else out there.

Edited by GG_Bootcamp

Share this post


Link to post
Share on other sites
2,608
[O_O]
[O_O]
Members
5,934 posts
25,261 battles

I am having the same issue as Grubnar. I am running windows 7. I uninstalled the client and reinstalled as admin. The log file is large - even these excerpts are a chunk of text. I don't see how to attach the log either. I submitted a ticket with the log files attached. If I get a successful response I will post.


 

The errors seem to be:

>>>

05/11/2015 21:15:21    kill safe: rename: file="C:\Games\World_of_Warships\Updates\BuildAgent\work\WoWsBuild\_light_patch\wows_51.128307_51.128306_client_na.patch", what="rename file", msg=""C:\Games\World_of_Warships\Updates\BuildAgent\work\WoWsBuild\_light_patch\wows_51.128307_51.128306_client_na.patch" to "C:\Games\World_of_Warships\Updates\BuildAgent\work\WoWsBuild\_light_patch\wows_51.128307_51.128306_client_na.patch.0ea20fdb.killme"
system error: (0x3)"The system cannot find the path specified."" ... retrying in 1 sec (retry 5 of 5)

 

>>>> and

05/11/2015 21:15:22  ERROR: rename file: "C:\Games\World_of_Warships\Updates\BuildAgent\work\WoWsBuild\_light_patch\wows_51.128307_51.128306_client_na.patch" to "C:\Games\World_of_Warships\Updates\BuildAgent\work\WoWsBuild\_light_patch\wows_51.128307_51.128306_client_na.patch.0ea20fdb.killme"
system error: (0x3)"The system cannot find the path specified."
05/11/2015 21:15:22    torrent file complete. file: "wows_51.128307_51.128306_client.patch"
05/11/2015 21:25:42    kill safe: rename: file="C:\Games\World_of_Warships\Updates\BuildAgent\work\WoWsBuild\_light_patch\wows_51.128305_client_na.patch", what="rename file", msg=""C:\Games\World_of_Warships\Updates\BuildAgent\work\WoWsBuild\_light_patch\wows_51.128305_client_na.patch" to "C:\Games\World_of_Warships\Updates\BuildAgent\work\WoWsBuild\_light_patch\wows_51.128305_client_na.patch.71e48db6.killme"
system error: (0x3)"The system cannot find the path specified."" ... retrying in 1 sec (retry 1 of 5)

>>>> and

05/11/2015 21:25:47  ERROR: rename file: "C:\Games\World_of_Warships\Updates\BuildAgent\work\WoWsBuild\_light_patch\wows_51.128305_client_na.patch" to "C:\Games\World_of_Warships\Updates\BuildAgent\work\WoWsBuild\_light_patch\wows_51.128305_client_na.patch.71e48db6.killme"
system error: (0x3)"The system cannot find the path specified."
05/11/2015 21:25:47    kill safe: rename: file="C:\Games\World_of_Warships\Updates\BuildAgent\work\WoWsBuild\_light_patch\wows_51.128306_51.128305_client_na.patch", what="rename file", msg=""C:\Games\World_of_Warships\Updates\BuildAgent\work\WoWsBuild\_light_patch\wows_51.128306_51.128305_client_na.patch" to "C:\Games\World_of_Warships\Updates\BuildAgent\work\WoWsBuild\_light_patch\wows_51.128306_51.128305_client_na.patch.3ce23de5.killme"
system error: (0x3)"The system cannot find the path specified."" ... retrying in 1 sec (retry 1 of 5)

>>>> and

05/11/2015 21:25:52  ERROR: rename file: "C:\Games\World_of_Warships\Updates\BuildAgent\work\WoWsBuild\_light_patch\wows_51.128306_51.128305_client_na.patch" to "C:\Games\World_of_Warships\Updates\BuildAgent\work\WoWsBuild\_light_patch\wows_51.128306_51.128305_client_na.patch.3ce23de5.killme"
system error: (0x3)"The system cannot find the path specified."
05/11/2015 21:25:52    torrent file complete. file: "wows_51.128305_client.patch"
05/11/2015 21:25:52    torrent file complete. file: "wows_51.128306_51.128305_client.patch"
05/11/2015 21:26:08    torrent file complete. file: "wows_51.128424_51.128308_client.patch"
05/11/2015 21:31:37    kill safe: rename: file="C:\Games\World_of_Warships\Updates\BuildAgent\work\WoWsBuild\_light_patch\wows_51.128308_51.128307_client_na.patch", what="rename file", msg=""C:\Games\World_of_Warships\Updates\BuildAgent\work\WoWsBuild\_light_patch\wows_51.128308_51.128307_client_na.patch" to "C:\Games\World_of_Warships\Updates\BuildAgent\work\WoWsBuild\_light_patch\wows_51.128308_51.128307_client_na.patch.fb7bf147.killme"
system error: (0x3)"The system cannot find the path specified."" ... retrying in 1 sec (retry 1 of 5)

>>>> and

05/11/2015 21:31:42  ERROR: rename file: "C:\Games\World_of_Warships\Updates\BuildAgent\work\WoWsBuild\_light_patch\wows_51.128308_51.128307_client_na.patch" to "C:\Games\World_of_Warships\Updates\BuildAgent\work\WoWsBuild\_light_patch\wows_51.128308_51.128307_client_na.patch.fb7bf147.killme"
system error: (0x3)"The system cannot find the path specified."
05/11/2015 21:31:42    torrent file complete. file: "wows_51.128308_51.128307_client.patch"
05/11/2015 21:31:43    Getting patch files via http...
05/11/2015 21:31:43    Unpacking patches...
05/11/2015 21:31:43  ERROR: patch extraction. failed reading file: C:\Games\World_of_Warships\Updates\wows_51.128305_client.patch , err: 2
05/11/2015 21:31:43  ERROR: open patch file. name: "wows_51.128305_client.patch", what: open patch error, wsg: name="C:\Games\World_of_Warships\Updates\wows_51.128305_client.patch"

 

Share this post


Link to post
Share on other sites
Members
1 post
2,350 battles

I've got the same problem that the launcher can't extract update contents after downloading 100%. And I've got the same error log as Khafni. I'm trying GG_Bootcamp's method. If anyone solves the problem, please post it out. Thank you!

Share this post


Link to post
Share on other sites
2,608
[O_O]
[O_O]
Members
5,934 posts
25,261 battles

I had success. Following GG_Bootcamp's advice I set the properties to Win7 Compatibility mode - even though running Win7. Also previously, I installed the game to a custom location. This time I accepted the default location. Not sure which "change" helped the most. The error log had several "file not found" so I figured the installer was not set to accept a custom location and was looking for the files in the default location. That is an installer issue.  Good luck. Accept the defaults.

Share this post


Link to post
Share on other sites
Members
4 posts

I am still having issues (Fresh Windows 10 install), after attempting to follow GG_Bootcamp's advice regarding compatibility mode. I have opened a ticket, so I'll update this once I get a reply.

Share this post


Link to post
Share on other sites
Members
4 posts

Update: I was able to extract, install, and play the game.

 

First, I followed these steps to disable torrents (I am home, I did not need to, but figured I'd try).

 

1.  Go into your WoWS folder and open your WoWSlauncher.cfg file with notepad (remember to backup the config file)

2. There you will see the following:

 

<launcher_transport>3</launcher_transport>

 

3. Change the value "3" to the value "2" so that it looks as follows:

 

<launcher_transport>2</launcher_transport>

 

Then, I opened the launcher (not under admin, or compatibility, just opened it) and ran the update.

 

Note: The update took ~20 minutes to download since Torrenting really increases your speed, just an FYI.

 

The update then extracted normally, and installed.

Share this post


Link to post
Share on other sites
Members
2 posts
105 battles

Same problem. It does this almost every patch. The last few times it went away on it's own but now the download just stop when trying a second time.

Share this post


Link to post
Share on other sites
Beta Testers
77 posts
12,542 battles

Thanks Signatus, it worked for me...

Don't know why changing the number fixed it.

 

Update: I was able to extract, install, and play the game.

 

First, I followed these steps to disable torrents (I am home, I did not need to, but figured I'd try).

 

1.  Go into your WoWS folder and open your WoWSlauncher.cfg file with notepad (remember to backup the config file)

2. There you will see the following:

 

<launcher_transport>3</launcher_transport>

 

3. Change the value "3" to the value "2" so that it looks as follows:

 

<launcher_transport>2</launcher_transport>

 

Then, I opened the launcher (not under admin, or compatibility, just opened it) and ran the update.

 

Note: The update took ~20 minutes to download since Torrenting really increases your speed, just an FYI.

 

The update then extracted normally, and installed.

 

 

Share this post


Link to post
Share on other sites
Members
165 posts
895 battles
 Did a uninstall via win7 control panel/ programs and features.  Checked to make sure folder (C:\Games\World_of_Warships) was gone, rebooted, opened IE and downloaded the installer.  It took well over 30 minutes to download and install.  And now I'm back playing....

Share this post


Link to post
Share on other sites
Members
162 posts
11,080 battles

Something simple that has worked for me was to click off the error message and hit the download arrow. (between the download bar and the grayed out "Play" button.)  That usually either does an auto start of the reload,  (if it is in the early stages of the download,) continues from where it left off, (if in the later download percentages) or changes the window to the current version message and lets the "Play' button work. Of course I'm using the codeweavers wrapper on a Mac, so I may have some advantages over having to find and delete files as is the norm in Windows.

Edited by dall89115
  • Cool 1

Share this post


Link to post
Share on other sites
Members
1 post
706 battles

World of Warships will not load or play following the 0.5.1 update - game was working brilliantly prior to the update.

All virus checks are current and my machine is clean, running Windows 7.

 

 

 

 

 

I have now uninstalled the game 3 times, swept any remnants clean, reinstalled to the default location, no luck.

After each install (lengthy wait) I click on play and get this warning window:

 

C:\Games\World_of_Warships\worldofwarships.exe
"Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access them."

When I close that window a 2nd window pops up and says:

World of Warships
Critical Error.
Error Launching Game.
The application cannot continue.
For details, see log file.

 

When I look in the log file as it instructs, I see nothing - it's blank.

 

When I look at the Settings button on the Launch Screen, I see this:

User Settings -> Updates:
Incoming connection port = 6881
I have clicked on the button to successfully added game and launcher to Windows Firewall exceptions - hit "Apply" ... still the error messages stated above.

HELP !!  I filed a ticket immediately after the update and have yet to get a response from anyone, so I thought I'd bring my problem to all of you.

I want to play. Updates that break my gaming fun are not worth the update.


 


 

Edited by VexFalkonen

Share this post


Link to post
Share on other sites
Members
16 posts

This is my problem,,here is my copied "ticket" I have started but getting tired of waiting 3 days for a response. NOTE,,I uninstalled then reinstalled this and still get this same message after I click PLAY,,

Took me over 12 hours to download World of Warships and finally tonight was ready to try it. When I click on my desktop Icon and page opens I click "PLAY" and about 30 seconds later I get this message.
Critical Error Occurred
Application C/Games/world_of_warships/worldofwarships.exe crashed 12/10/2015 at 18:45:05 Messga: The BigWorld Client has encountered an unhandled exception and must close(exception-access-violation:OxC0000005@0X010FED1B) (Read@0x0000000c)

System Info:
Virtual Memory 431372kb/2097024kb (21%)
Working set (process physical memory) 143232kb/2097024kb (6%)
Commit Change (working set +process page file usage 280404kb/2097024kb (13%)
Global Physical Memory 1563768kb/3143600kb (49%)
Global Commitable Memory (physical and page file) 2081160kb/6285472kb (34%)

The reply I got from tech support was

 

Thank you for contacting Support and we will be happy to assist!    

Please send us your WOWsLauncher.cfgpython.log and WOWsLauncher.log files (sometimes just text files called 'python' and 'WOWSLauncher') from the root folder in which World of Warships is installed on your computer (the default location isC:\Games\World_Of_Warships).The python log is located inC:\Games\World_of_Warships\profile.If you receive an error when trying to attach the python log, please compress it to a zip file and then attach it.

----------

In addition, please compile and send us a DxDiag report file so we may get a clear picture of your computer's characteristics.

Please follow the associated steps below:
- On your Windows task bar, click Start (Windows icon usually in the lower left corner of the screen).
- Select and press "Run" (if you do not see "Run", hold down the "Windows" button on your keyboard and press "R"). A "Run" window should pop up.
- In the "Run" window, type "dxdiag" and click "OK". A "DirectX Diagnostic Tool" window should pop up. Wait for it to finish gathering your info before saving.
- In the appeared window choose "Save all information".
- After you've saved the file, please attach it to your reply.


Once we receive these reports and review your client information, we will be able to troubleshoot these errors.          
 

My problem is when requested to send the specified info there was nothing in the "profile folder so I could not find the python log. I'm running Windows 7. Getting frustrated waiting 3 days for each reply back from tech support on this issue.

Edited by Randall_Lauterbach

Share this post


Link to post
Share on other sites
0
[OINA]
Members
2 posts
903 battles

Ugh i'm still having the issue. I've tried both solutions from GG_Bootcamp and Signatus, but it still won't update. I even did both at once, still nothing. I'll be checking this daily, so please do not hesitate to give me any advice. I'll edit this (hopefully) when the problem is fixed.

Share this post


Link to post
Share on other sites
0
[-VT-]
Members
1 post
5,945 battles

I really have no idea whats going on with this, but I tried several of what was suggested below, but I am still having trouble.

The log has these two lines:

01/05/2016 21:13:33  ERROR:    patch extraction. failed archive extraction. (0x80070017) Data error (cyclic redundancy check). occurred during extraction "" from "C:\Games\World_of_Warships\Updates\wows_0.5.5.0.163638_0.5.5.0.163637_sdcontent_na.wgpkg" to "C:\Games\World_of_Warships\UpdatesData\sdcontent\wows_0.5.5.0.163638_0.5.5.0.163637_sdcontent_na.wgpkg\"
01/05/2016 21:13:33  ERROR:    patch extraction. name: "wows_0.5.5.0.163638_0.5.5.0.163637_sdcontent_na.wgpkg", what: extract file error: Data error (cyclic redundancy check)., msg: name="C:\Games\World_of_Warships\Updates\wows_0.5.5.0.163638_0.5.5.0.163637_sdcontent_na.wgpkg" file="" to="C:\Games\World_of_Warships\UpdatesData\sdcontent\wows_0.5.5.0.163638_0.5.5.0.163637_sdcontent_na.wgpkg\"

So, if anyone can give me any suggestions I would appreciated, if not, can someone tell me how to contact customer service or complain to Wargaming about this?

-Thanks, I like this game and would like to play again.

Share this post


Link to post
Share on other sites
Beta Testers
2 posts
1,695 battles

im gettin and error now as well with todays update

11/05/2016 12:17:26  WARNING:    Failed to move file C:\Games\World_of_Warships\UpdatesData\sdcontent\wows_0.5.5.1.166724_0.5.5.0.165453_sdcontent_na.wgpkg\res_packages\basecontent_0001.pkg to C:\Games\World_of_Warships\res_packages\basecontent_0001.pkg, attempting to copy
11/05/2016 12:17:49          apply bin-diffs. process file: name="basecontent_0002.pkg.0.5.5.1.166724.5FC0F2A1.rdiff"
11/05/2016 12:17:49          apply bin-diffs. file="C:\Games\World_of_Warships\UpdatesData\sdcontent\wows_0.5.5.1.166724_0.5.5.0.165453_sdcontent_na.wgpkg\res_packages\basecontent_0002.pkg.0.5.5.1.166724.5FC0F2A1.rdiff", error="213" ... retrying in 1 sec (retry 1 of 5)
11/05/2016 12:17:50          apply bin-diffs. file="C:\Games\World_of_Warships\UpdatesData\sdcontent\wows_0.5.5.1.166724_0.5.5.0.165453_sdcontent_na.wgpkg\res_packages\basecontent_0002.pkg.0.5.5.1.166724.5FC0F2A1.rdiff", error="213" ... retrying in 1 sec (retry 2 of 5)
11/05/2016 12:17:51          apply bin-diffs. file="C:\Games\World_of_Warships\UpdatesData\sdcontent\wows_0.5.5.1.166724_0.5.5.0.165453_sdcontent_na.wgpkg\res_packages\basecontent_0002.pkg.0.5.5.1.166724.5FC0F2A1.rdiff", error="213" ... retrying in 1 sec (retry 3 of 5)
11/05/2016 12:17:52          apply bin-diffs. file="C:\Games\World_of_Warships\UpdatesData\sdcontent\wows_0.5.5.1.166724_0.5.5.0.165453_sdcontent_na.wgpkg\res_packages\basecontent_0002.pkg.0.5.5.1.166724.5FC0F2A1.rdiff", error="213" ... retrying in 1 sec (retry 4 of 5)
11/05/2016 12:17:53          apply bin-diffs. file="C:\Games\World_of_Warships\UpdatesData\sdcontent\wows_0.5.5.1.166724_0.5.5.0.165453_sdcontent_na.wgpkg\res_packages\basecontent_0002.pkg.0.5.5.1.166724.5FC0F2A1.rdiff", error="213" ... retrying in 1 sec (retry 5 of 5)
11/05/2016 12:17:54  ERROR:    apply bin-diffs. what: Error opening source file ( C:\Games\World_of_Warships\res_packages\basecontent_0002.pkg ) : Permission denied
. msg: name="C:\Games\World_of_Warships\UpdatesData\sdcontent\wows_0.5.5.1.166724_0.5.5.0.165453_sdcontent_na.wgpkg\res_packages\basecontent_0002.pkg.0.5.5.1.166724.5FC0F2A1.rdiff"

 

Share this post


Link to post
Share on other sites
Members
5 posts
3,014 battles

I can not load the game I am having the same issues I have tried  everything an still no luck does anyone now can you get this game on ps4

Share this post


Link to post
Share on other sites
Members
1 post
1,571 battles

i've been trying to update warships but it keeps saying cant update. update error re download ect. ive un instailled the game 4 times and same thing i dont know what to do. my brother has the same computer as me and it updated just fine. PS i did not change or edit anything in the files either. anyone had this problem before?

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×