Jump to content
You need to play a total of 20 battles to post in this section.
Nato101

engine_config.xml - [FPS / LOADING / STUTTERING FIX]

171 comments in this topic

Recommended Posts

Alpha Tester
1,734 posts
2,514 battles

EDIT: Various people acrosss wildly differing platroms have reported back the following:

  • No effect
  • Helps stuttering
  • Increases FPS
  • Helps loading times
  • Combination of the above


ORIGINAL: Short experiment. Only played two rounds. The game seems to be less jerky and I appear to be getting a solid FPS with less dropoffs.

 

What I'd changed was:

<cacheEffects>false</cacheEffects> to <cacheEffects>true</cacheEffects>

<streamCacheSizeKB>2048</streamCacheSizeKB> to <streamCacheSizeKB>8192</streamCacheSizeKB>

 

The engine_config.xml file resides in the 'res' folder.

If you are going to change these settings, exit the game first if it's already running, back up your original file, make the changes, and give it a try.

There is also a mouse invert thing in there for those who are after that, but I havent tested it.

 

EDIT 2: Some people with weak systems have reported that lowering the <maxFrameRate></maxFrameRate> increases the fluidity of the game as it gives more room for the CPU to do things other than generate frames.

Edited by Nato101
  • Cool 35

Share this post


Link to post
Share on other sites
Beta Testers
382 posts
3,135 battles

thanks will try - am running on anemic laptop atm while on vacation. I MISS MY TOWER.

Share this post


Link to post
Share on other sites
Alpha Tester
1,734 posts
2,514 battles

Where does this need to be put?

 

Short experiment. Only played two rounds. The game seems to be less jerky and I appear to be getting a solid FPS with less dropoffs.

 

What I'd changed was:

<cacheEffects>false</cacheEffects> to <cacheEffects>true</cacheEffects>

<streamCacheSizeKB>2048</streamCacheSizeKB> to <streamCacheSizeKB>8192</streamCacheSizeKB>

 

The engine_config.xml file resides in the 'res' folder.

 

If you are going to change these settings, exit the game first if it's already running, back up your original file, make the changes, and give it a try.

 

There is also a mouse invert thing in there for those who are after that, but I havent tested it.

 

  • Cool 4

Share this post


Link to post
Share on other sites
Beta Testers
436 posts
2,014 battles

He is not ADDING any lines of code is is just changing some values in that line of code

Share this post


Link to post
Share on other sites
1,440
[ARMDG]
Members
3,243 posts
1,579 battles

 

Where in the engine_config_xml? Or can I just insert the lines anywhere?

 

You need to find the existing line and change "false" to "true", as well as adjusting the numerical value.

Share this post


Link to post
Share on other sites
189
Members
888 posts
761 battles

I've made this change. I must say so far it helps. +1 OP

Edited by JRos83

Share this post


Link to post
Share on other sites
Alpha Tester
1,734 posts
2,514 battles

I've made this change. I must say so far it helps. +1 OP

 

What kind of setup do you have, just out of curiosity?

 

For everyone's info, I run a 3930K, 32G RAM, RAID 0 SSD, GTX 670 @ 2560x1440

 

I also haven't tried any other cache value. It's only at 8 megs with that setting. Maybe more would help. Maybe it wouldn't make a difference. Needs more testing I guess.

Share this post


Link to post
Share on other sites
1,440
[ARMDG]
Members
3,243 posts
1,579 battles

Might play around later with trying to get a mass pre-load on everything in the game.  It would require quite a bit of work from the system, but should give near-instant map loads.

Share this post


Link to post
Share on other sites
189
Members
888 posts
761 battles

 

What kind of setup do you have, just out of curiosity?

 

For everyone's info, I run a 3930K, 32G RAM, RAID 0 SSD, GTX 670 @ 2560x1440

 

I also haven't tried any other cache value. It's only at 8 megs with that setting. Maybe more would help. Maybe it wouldn't make a difference. Needs more testing I guess.

 

My PC is state of the art 2010 lol. But it still runs everything.

 

i7 920 2.67 quad core duo, 6gigs RAM. GTX580. lol.

 

It still holds up, amazingly.

 

At mostly max graphics, your little trick has increased my frames from fluctuating between 20 and 70 to an almost steady 75/76.

Edited by JRos83

Share this post


Link to post
Share on other sites
Alpha Tester
1,734 posts
2,514 battles

Might play around later with trying to get a mass pre-load on everything in the game.  It would require quite a bit of work from the system, but should give near-instant map loads.

 

You can load everything into RAM already. But it doesn't have the effects that you would assume. http://forum.worldofwarships.com/index.php?/topic/36092-running-wows-from-ram/

Share this post


Link to post
Share on other sites
Alpha Tester
1,734 posts
2,514 battles

 

My PC is state of the art 2010 lol. But it till runs everything.

 

i7 920 2.67 quad core duo, 6gigs RAM. GTX580. lol.

 

It still holds up, amazingly.

 

At mostly max graphics, your little trick has increased my frames from fluctuating between 20 and 70 to an almost steady 75/76.

 

Well, if it makes a difference on older machines also, that's defnitiely a really good thing.

 

Mine also sits on a solid 58 most of the time.

 

Need more people to try this.

Share this post


Link to post
Share on other sites
Beta Testers
382 posts
3,135 battles

FYI on my laptop I used 4096 instead for the cache size. Due to the amount of ram I have.

It definitely improved my fps.  THANKS!


 

When I get home will try 8192 on the tower gaming pc.

Share this post


Link to post
Share on other sites
Alpha Tester
1,734 posts
2,514 battles

FYI on my laptop I used 4096 instead for the cache size. Due to the amount of ram I have.

It definitely improved my fps.  THANKS!

 

 

When I get home will try 8192 on the tower gaming pc.

 

Good to hear. If this is geniuinely improving things for people, I wonder why these settings are not applied in the regular client.

 

Maybe WG keep it up their sleeve so that they can claim that they've 'optimised' the game at some later date/patch/launch.

  • Cool 3

Share this post


Link to post
Share on other sites
Members
16 posts

My big issue is the start of the game lag and this actually kinda helped it mellow out, the comp I'm on is an old school P4 quad Pre I cores but every thing else is up to par  720 Gtx 4X8 Gig ram (retirement Computer's Mobo is dead) I notice my FP before was 40-60s this time kept it up a bit 55-70 (giant TV) where'd the number come from cause I feel like I could tweak mine  if it wasn't random.

Edited by Sir_KISA

Share this post


Link to post
Share on other sites
725
[NEUTR]
Members
2,207 posts
10,005 battles

Increase cache size on machines without sufficient RAM might literally crash and burn the said computer.

  • Meh 1

Share this post


Link to post
Share on other sites
189
Members
888 posts
761 battles

:( My machine is now an "older machine." 

When I put this thing together in late 2009, it was a BEAST.

 

Memories.... :(

  • Funny 1

Share this post


Link to post
Share on other sites
Alpha Tester
1,734 posts
2,514 battles

My big issue is the start of the game lag and this actually kinda helped it mellow out, the comp I'm on is an old school P4 quad Pre I cores but every thing else is up to par  720 Gtx 4X8 Gig ram (retirement Computer's Mobo is dead) I notice my FP before was 40-60s this time kept it up a bit 55-70 (giant TV) where'd the number come from cause I feel like I could tweak mine  if it wasn't random.

 

<cacheEffects></cacheEffects> is set to false by default. The decrtiption even reads that having it off may cause drops in framerate. Which is why I enabled it.

 

And the <streamCacheSizeKB></streamCacheSizeKB> default value is 2048 (2 megabytes). It's actually the animation cache. So I quadrupled it as I know that this game is geared towards running on older machines.

  • Cool 1

Share this post


Link to post
Share on other sites
Alpha Tester
1,734 posts
2,514 battles

Increase cache size on machines without sufficient RAM might literally crash and burn the said computer.

 

The game uses around one gig of RAM.

 

Those values are also in kilobytes, meaning that an increase from 2048 to 8192 is an increase of only 6 megs.

  • Cool 2

Share this post


Link to post
Share on other sites
35
[-CHH-]
Members
89 posts
3,990 battles

Well, the mouse inversion setting seems to be disabled; I tried it, because I have some friends who refuse to play until mouse inversion is returned to the game.

Share this post


Link to post
Share on other sites
189
Members
888 posts
761 battles

Well, the mouse inversion setting seems to be disabled; I tried it, because I have some friends who refuse to play until mouse inversion is returned to the game.

 

Your friends are a little bit weird. That's enough to keep them away?
  • Cool 2

Share this post


Link to post
Share on other sites
Members
22 posts
5 battles

I don't really understand why people want mouse inversion lol. For a flight sim I can understand but a game about ships? O.o

 

Thanks for this I'll try it out later.

Edited by Deathmaw

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×