Jump to content
Sign in to follow this  
You need to play a total of 20 battles to post in this section.
KABEP3A

Can not start shooting with Left Mouse click

12 comments in this topic

Recommended Posts

0
[SNOBS]
Members
7 posts
18,902 battles

Kind of frustrating.

My mouse works as ususal (at least in WoT).

In this game, I can not shoot anything because Left mouse' click does not do the job.

I did not change any controls except for movement (go ahead and back, etc.)?

Did I miss anything? Like forgot to buy the shells? How to repait this?

Share this post


Link to post
Share on other sites
3,280
Alpha Tester
11,714 posts
24,171 battles

In either order try

1. Reinstall your mouse driver if this is a non Microsoft mouse that can cause issues.

2. Delete your preferences file start the client and set your options up again.

Share this post


Link to post
Share on other sites
Beta Testers
648 posts
15,736 battles

Does this happen to you all the time?

This happens to me only when I'm lagging badly, or worse, the login screen soon follows.

Share this post


Link to post
Share on other sites
3,280
Alpha Tester
11,714 posts
24,171 battles

It happened when I had to much cat hair and gunk in my old mouse, and it got tired of being cleaned out.  Otherwise never.

Share this post


Link to post
Share on other sites
Beta Testers
2,440 posts
8,653 battles

Just to get the basics out of the way...

 

Are you waiting for the aiming indicator to turn green? You can only fire when your guns are pointed at your reticule, or if you lock them with Ctrl-X or Shift-X (although the second two aren't recommended for actually aiming at things).

 

Do you have slow turrets? Try to stop turning as there might be a chance that they're quickly alternating between turning to your reticle and ready to fire.

Share this post


Link to post
Share on other sites
0
[SNOBS]
Members
7 posts
18,902 battles

Just to get the basics out of the way...

 

Are you waiting for the aiming indicator to turn green? You can only fire when your guns are pointed at your reticule, or if you lock them with Ctrl-X or Shift-X (although the second two aren't recommended for actually aiming at things).

 

Do you have slow turrets? Try to stop turning as there might be a chance that they're quickly alternating between turning to your reticle and ready to fire.

 

I also thought that my guns are not aimed properly. However, the reticule looks green (to me).

This inability to fire happens all the time.

Overall, it would be nice to have a type of demo or control calibration page in this game where every player can verify if his controls work and what they actually are.

Share this post


Link to post
Share on other sites
3,280
Alpha Tester
11,714 posts
24,171 battles

 

I also thought that my guns are not aimed properly. However, the reticule looks green (to me).

This inability to fire happens all the time.

Overall, it would be nice to have a type of demo or control calibration page in this game where every player can verify if his controls work and what they actually are.

 

Certain ships have an extremely fine line between turning and turret turning and although your green your not.  Sparky is right, make sure your not turning when you fire.  For one it throws off the FCS, and you'll go high or low because of your ship list.

Share this post


Link to post
Share on other sites
0
[SNOBS]
Members
7 posts
18,902 battles

 

 

Here are some images. In all of them, left-click mouse did not do anthing.

Do you see anything wrong with my client or settings?

 

 

Share this post


Link to post
Share on other sites
3,280
Alpha Tester
11,714 posts
24,171 battles

Did you delete your preferences file?  Is this a Microsoft mouse?

Share this post


Link to post
Share on other sites
0
[SNOBS]
Members
7 posts
18,902 battles

Yes, my mouse is IntelliMouse from Microsoft.

 

No, I did not delete the file. Where it is located?

Share this post


Link to post
Share on other sites
3,280
Alpha Tester
11,714 posts
24,171 battles

Windows explorer that file ikon lower left there.  computer/local disk C usually/Games/Worldofwarships/Preferences file 2/3 way down just right click and delete it then redo your options after you start the client. It just get's remade automatically.  Game should be off when you do this.

Edited by Moksie

Share this post


Link to post
Share on other sites
0
[SNOBS]
Members
7 posts
18,902 battles

I deleted the file and started the game again. I did not change any controls and YES!!! I can fire with the left-click mouse now.

I am wondering if firing will be screw up again after I change the the movement controls.

I will report if that will be the issue.

Thank you very much anyway!!!!

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×