Jump to content
You need to play a total of 20 battles to post in this section.
Tergiverse

Game Game Crashes to Fullscreen Error Message Without Starting

2 comments in this topic

Recommended Posts

0
[SISKO]
Members
2 posts

Hello Everyone,

This is my first time posting to this forum, unfortunately it isn't under more agreeable circumstances. Any help figuring this problem out I would be grateful to the community.

FYI: This is a problem encountered while playing the game on a Linux OS (POP OS) using Steam and Proton. I am aware that Wargaming does not support Linux.

I took a break from WoWS at the beginning of August and didn't try to play it again until several days ago. I use the Steam client to launch the game and upon selecting the game several seconds go by and then while still on the desktop I am faced with an error message that pops up and of course I cannot start the game because of it. The error message seems to have to do with the fact that the game cannot detect fullscreen display modes. The main message of the error is as follows:

Interface::enumerateDevices: No fullscreen display modes were detected!

I am attaching a screenshot of the error message for review.

The only thing I can think of that possibly broke the game was that there has been a number of updates to it while I was gone from it and they somehow screwed up the inner workings of how it ran smoothly on my system.

The game worked fine before I took a break from playing it earlier in the month and it always started normally. Wargaming support itself has been less then helpful informing me of the same thing I cited in my original ticket to them in that they do not support Linux which I was already aware of, at that they pretty much said good luck and see-ya. I can understand their reasoning in the first half of their response to my problem yes confirmed they do not support Linux but their second half is quite shallow in that they didn't even recommend alternative sites or sources for me to find a solution to the issue that they themselves may have caused through their game updates instead they just kicked me out of any further discussion revolving around it.

Anyone with Linux experience know what this is? Has someone else on another operating system run into this as well? Again I would be greatly appreciative to anyone that can point me in the direction of a solution.

20220824220630.png

Share this post


Link to post
Share on other sites
0
[SISKO]
Members
2 posts

Update:

Looks like I found a solution to this problem on my own. Still to post this problem and then a solution I think is good for those in the future that find themselves in the same boat as I was. Hopefully an internet search for keywords or browsing this forum will bring them here. I still believe the updates that Wargaming released had something to do with screwing up my version. Their lack of a Linux supported-version of WoWs and their other products is a direct reason why players like me run into so many problems using work-around methods to play their games. Think about it as if you are Wargaming, there are people out there that want to play your product and some may even be willing to pay you large amounts of money in terms of subscriptions and purchases and you will not support their operating systems. On the assumption that Wargaming doesn't want another revenue stream well who am I to question that.

Solution:

This solution may not work with your computer or OS but its worth a shot. The problem I have found with my computer in running WoWS through Steam is not the game itself but the Proton compatibility program Steam uses to trick WoWS into running on Linux under the false premise that its actually Windows OS. On the assumption that you are getting that "Interface::enumerateDevices: No fullscreen display modes were detected!" error message like the screenshot in my previous post  the Proton version you are running is heading into problems with how it runs the program when activated. Before this happened I had my Proton settings set to the experimental version and never had a problem. After my break from the game and the month of several updates well... Taking a shot in the dark I selected another version of Proton which in this case was the most up-to-date version released so far, Proton 7. I ran WoWS afterward and will you look at that the game started normally and I was able to play it again just fine.

Here's what I did:

1. Start Steam and login.

2. Scroll down to World of Warships in your game list and right click on it.

3. Select Properties and then within the pop-up box on the left pane select the compatibility tab.

4. Make sure the  "Force the use of a specific Steam compatibility tool" box is checked.

5. Then on the scroll down tab below select a different Proton version then the one that is already selected. I advise for you to go with the one that is the most recently updated version if its not already selected.

6. Exit out of the pop-up box.

7. Click play on World of Warships and wait for Proton to update itself.

8. After the update is done the game should start like used to before the problem, and you can then jump right into battle.

Again this may not work for you based on your computer specifics but I really hope it does so you have less aggravation and more fun playing the game.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×