Jump to content
You need to play a total of 20 battles to post in this section.
murder_0ne

NA server down?

24 comments in this topic

Recommended Posts

598
[F4E-2]
Members
390 posts
7,681 battles

I can't seem to log in and the game just gets stuck on the log in page. Anyone else having issues? I checked my game install for integrity etc. Everything else seems fine.

Share this post


Link to post
Share on other sites
1,139
[USCC]
Members
3,586 posts
16,649 battles

Just logged on, working fine for me.

Share this post


Link to post
Share on other sites
1,416
[UNHLY]
Members
5,347 posts
14,868 battles

Happened to me earlier today, but after closing and reopening the client twice, it loaded pretty quickly on the third time. 

Share this post


Link to post
Share on other sites
7
[WICKD]
Members
19 posts
4,860 battles
1 hour ago, murder_0ne said:

I can't seem to log in and the game just gets stuck on the log in page. Anyone else having issues? I checked my game install for integrity etc. Everything else seems fine.

Yes tried twice in last half hour ,same thing stuck trying to log in. 

Share this post


Link to post
Share on other sites
3
[POW]
Members
4 posts
4,711 battles

I've tried several times over the last couple of hours, but it's stuck each time at the loading screen. Glad it's not just me...

Share this post


Link to post
Share on other sites
773
[-AFK-]
Members
1,379 posts
16,702 battles
2 hours ago, nrusson said:

I've tried several times over the last couple of hours, but it's stuck each time at the loading screen. Glad it's not just me...

I have the fix, I just had the same issue, 

Press CTRL + ALT + DEL, 
Bring up task manager, 
Just by doing that the game 'unsticks'
I had this issue a few patches back. 

This method has worked for me just now. 

  • Cool 2

Share this post


Link to post
Share on other sites
7
[99TH]
Members
11 posts
2,088 battles

Same problem here for the last 4 hours that I know of... "Logging in..." sits there indefinitely until I kill the task. Looks like I dont get to play today. :sad:

Share this post


Link to post
Share on other sites
773
[-AFK-]
Members
1,379 posts
16,702 battles
3 minutes ago, SeeGee911 said:

Same problem here for the last 4 hours that I know of... "Logging in..." sits there indefinitely until I kill the task. Looks like I dont get to play today. :sad:

Just bringing up task manager unlocked the game for me

Share this post


Link to post
Share on other sites
1,025
[SAINT]
[SAINT]
Members
1,716 posts
19,637 battles

I've had the same problem with getting hung up on the log in screen. When I click to exit out of the program it then logs me in but I lose my mouse cursor. I also restarted everything and it still has the same issue. I even tried to log in through the modstation with the same result. I'm having no issues with any of my other online games. 

I'll try the task manager approach. 

Share this post


Link to post
Share on other sites
290
[SRM]
Members
405 posts
20,491 battles

I have started using the " Check and Repair " each morning before I sign in  It is located under game settings on "wargaming center" 

Share this post


Link to post
Share on other sites
3
[POW]
Members
4 posts
4,711 battles
11 hours ago, Depraved_Miscreant said:

I have the fix, I just had the same issue, 

Press CTRL + ALT + DEL, 
Bring up task manager, 
Just by doing that the game 'unsticks'
I had this issue a few patches back. 

This method has worked for me just now. 

I had task manager up at the time, but I'll try it tonight. Thanks for the advice.

Share this post


Link to post
Share on other sites
Members
27 posts
15 hours ago, Depraved_Miscreant said:

I have the fix, I just had the same issue, 

Press CTRL + ALT + DEL, 
Bring up task manager, 
Just by doing that the game 'unsticks'
I had this issue a few patches back. 

This method has worked for me just now. 

this worked to resolve it for me

  • Cool 1

Share this post


Link to post
Share on other sites
3
[POW]
Members
4 posts
4,711 battles
21 hours ago, Depraved_Miscreant said:

I have the fix, I just had the same issue, 

Press CTRL + ALT + DEL, 
Bring up task manager, 
Just by doing that the game 'unsticks'
I had this issue a few patches back. 

This method has worked for me just now. 

This worked for me tonight. Thanks for posting it.

  • Cool 1

Share this post


Link to post
Share on other sites
41
[PRMUS]
Members
88 posts
9,106 battles

Still unable to get in? Is there not enough people having the issue to where it will be discussed? Might have to open a ticket.

Share this post


Link to post
Share on other sites
8,097
[WORX]
Members
14,297 posts
20,867 battles
4 minutes ago, Hull__Balsey said:

Still unable to get in? Is there not enough people having the issue to where it will be discussed? Might have to open a ticket.

If you're stuck... Try to exit with task manager option...

I got in by bypassing the opening movie cinematic.

Share this post


Link to post
Share on other sites
Members
453 posts
7,567 battles

What I have found works is to click on the Red X in the upper right corner, it should ask you if you want to exit the game.  Answer "No" and it should complete the log-in process.

  • Cool 2

Share this post


Link to post
Share on other sites
8
[RNG]
Members
48 posts
16,986 battles
On 7/20/2021 at 1:21 AM, Depraved_Miscreant said:

I have the fix, I just had the same issue, 

Press CTRL + ALT + DEL, 
Bring up task manager, 
Just by doing that the game 'unsticks'
I had this issue a few patches back. 

This method has worked for me just now. 

Holy crap this actually works!

  • Cool 1

Share this post


Link to post
Share on other sites
773
[-AFK-]
Members
1,379 posts
16,702 battles
7 hours ago, Hull__Balsey said:

That's what I have to do to kill it so i can try again. I even repaired the install.

don't end the task, just bring up task manager and give it an extra minute, this is what I am doing as well as others then the game decides to load. 

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×