Jump to content
Sign in to follow this  
You need to play a total of 20 battles to post in this section.
lallave

Installation problems

3 comments in this topic

Recommended Posts

Members
119 posts
8,434 battles

Hi everyone I am falling back on the forum for advice since player support  is totally incompetent. I think it is just a robot that sends out stock solutions. When it feels like it. 

 

Here is my situation. I have a new Dell Inspiron  laptop. It has a Ryzen 7 processor and Radeon Graphics. 512 GB hard drive, 8 Ram plus I have 100 mbps internet with a 15ms ping. Since I installed WOW, it has been nothing but problems. Frozen screens, blank screens during a battle. The armory is all screwed up. Can't see the signals just the box.  No time or distance data for my aiming crosshairs, can't use priority targeting for my secondary armaments,  no HP bar to see what my damage is and so on. I have uninstalled and reinstalled 2x with the same result.

Plus I can't even run check and repair because it locks up when checking integrity. Or I get updates not available. FYI WG is unblocked in the firewall. My old laptop is a Dell 3000 Inspiron with a i5 processor and 256 hard drive which I installed myself because the OEM was too small. WOW works like a charm. 

 Has anyone else out there experienced similar? I am beginning to think the Ryzen 7 and the Radeon Graphics card architecture is incompatible with WOW. All the research I did on Cnet and others indicated that the R7 was a better processor than the Intel i7. I had a similar experience when I first installed WOW on an i3 Dell desktop. 

Share this post


Link to post
Share on other sites
3,860
[SALVO]
Members
3,898 posts
7,848 battles

Despite the Laptop being new. Have you tried updating all your drivers once? 

Do other games run fine ? 

Edited by eviltane

Share this post


Link to post
Share on other sites
11,355
[SALVO]
Members
16,503 posts
10,225 battles

Looks like a video drivers thing, try updating your video drivers. 

Also, 512 GB is not a lot. Are you sure you keep enough free disk space to operate? WoWS alone takes like 80GB.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×