Jump to content
Sign in to follow this  
You need to play a total of 20 battles to post in this section.
GaoMachine

Torpedo aiming / launch bug?

31 comments in this topic

Recommended Posts

Members
12 posts
32,873 battles

Played a few day after patch, I noticed that my torpedo hit the beach more often than usual.

I tested in training room and found that , launch torpedo while turning will cause the direction not as my decision.

I played WOWS many years , I know that there is some launch  lag while maneuvering.
But this time is not consistent as I played before.

Attached screen shot show one of my test  , I aimed on open water but hit on beach.
Just test it yourself if you doubt about that

shot-21.06.18_20.44.07-0481.jpg

shot-21.06.18_20.44.32-0424.jpg

shot-21.06.18_20.44.36-0811.jpg

Edited by GaoMachine
  • Cool 2
  • Thanks 1

Share this post


Link to post
Share on other sites
7,514
[HINON]
Members
14,340 posts

Since the torpedoes now launch one at a time prior to all at once, this makes sense.

  • Meh 2

Share this post


Link to post
Share on other sites
307
[SRM]
Members
427 posts
20,938 battles
2 hours ago, RipNuN2 said:

Since the torpedoes now launch one at a time prior to all at once, this makes sense.

Just curious  when was this announced ? I have noticed the same issue I just thought it was me :) 

Share this post


Link to post
Share on other sites
7,514
[HINON]
Members
14,340 posts
48 minutes ago, jr_token said:

Just curious  when was this announced ? I have noticed the same issue I just thought it was me :) 

It's been a couple years at least.

  • Meh 3

Share this post


Link to post
Share on other sites
602
[Y0L0W]
Members
700 posts
22,636 battles
20 hours ago, RipNuN2 said:

It's been a couple years at least.

Hmm. This is only since the patch. Before the patch the torps would at least go along the aimed path. Now there’s a significant deviation from where they’re aimed to where they go. 

Share this post


Link to post
Share on other sites
Members
1,781 posts

Thank you, thought I was losing my mind on this. Definitely noticed volleys clipping islands that should definitely have cleared them when I launched them. Glad it is not just me.

Share this post


Link to post
Share on other sites
307
[SRM]
Members
427 posts
20,938 battles
On 6/18/2021 at 1:56 PM, RipNuN2 said:

It's been a couple years at least.

This something new  I'll send in a replay to support next time I see it 

Share this post


Link to post
Share on other sites
7,514
[HINON]
Members
14,340 posts
4 hours ago, jr_token said:

This something new  I'll send in a replay to support next time I see it 

Interesting. If I have time I'll try to duplicate it in the training room.

  • Cool 1

Share this post


Link to post
Share on other sites
0
[P2W]
Beta Testers
3 posts
2,619 battles

It looks like any turning or movement of the ship drags the tubes around.

Share this post


Link to post
Share on other sites
406
[LSNB]
Members
1,747 posts
6,954 battles
On 6/18/2021 at 7:46 AM, RipNuN2 said:

Since the torpedoes now launch one at a time prior to all at once, this makes sense.

Even so, I've never had a problem with this, which seems to be a more recent issue. I've had this issue in my recent Somers game and Flamu in his recent "Curving Torpedoes" video. So far it looks like excessive ship steering is the cause behind torpedoes deviating off-course; I've found that all ships were turning in all instances I've seen.

1752204076_WorldofWarships6_22_20211_53_33PM.thumb.png.ae214dfd4b7ad223b5ab776cd8093849.png

1866157208_WorldofWarships6_22_20211_53_46PM.thumb.png.9f0d1b3b41398cab9956e536ea7bf9d0.png

147053775_WorldofWarships6_22_20211_54_25PM.thumb.png.ba5717d5cae91f33d56b72c44586a8be.png

1823118372_WorldofWarships6_22_20211_54_57PM.thumb.png.1a48a518f57ab6a4849a5de1762af065.png

Share this post


Link to post
Share on other sites
Members
229 posts
23,213 battles

I had this issue for a long time but it was only when i launched torps fast and turned the camera immediately.

But since this patch torps just dont go where you aim, ship movement doesnt matter.

Share this post


Link to post
Share on other sites
1
[DOG]
Members
3 posts
15,355 battles

Doesnt matter if you are moving.

Me Sitting still aiming at Petro sitting still behind island. All torps hit island before Petro.

My aim wasnt even close too island.

It happens on a regular basis.

After latest patch

  • Cool 1

Share this post


Link to post
Share on other sites
22
[ARR0W]
Beta Testers
113 posts
4,996 battles

Adding my +1 to this issue. Definitely had metal tubes o'death deviate toward a land mass and while I may have been moving I don't think I was turning and as a CBT (for time reference), I can't recall this ever happening before. Ruined a launch for sure and it was since the last patch.

Share this post


Link to post
Share on other sites
Members
64 posts
25,647 battles

This aint cool, tonight in clan battles I was lucky to land 1% of torps thrown, even if you account for Hydro, no way, several times I had torps locked on a non moving target i was at a full stop and nothing was close, Starting to wonder if this is some crazy new update that we are not being inform of?

 

Share this post


Link to post
Share on other sites
Members
64 posts
25,647 battles

Just went into a training room, below are the results, so, there is a clear drift with torpedos, when you drop them from a turn,  if you are turning left when you drop torps, your torps will swing left, in every instance a target was stationary and a full rack of 5 should have landed but they swing so far only 2 of the five land,  if you turn right they swing right. Now and this is an important point of concern, the greater your torpedo range the wider the drift becomes, and at 14K range we was only landing one of the five torpedos,, If you are traveling in a straight line, the torpedos track as normal. So we all know we also tested it with cruisers, just to be sure that it wasn't only dd's that are being affected, and can confirm the same results, this is happens to all classes, dd, and cruisers alike, did not test any BB's I am thinking that at a bb max torp range and their slow turn rate it likely wont affect it enough to notice.  Hope this helps, 

 

  • Cool 1

Share this post


Link to post
Share on other sites
162
[OVRPN]
[OVRPN]
Beta Testers
329 posts
20,393 battles
On 6/18/2021 at 8:09 AM, GaoMachine said:

Played a few day after patch, I noticed that my torpedo hit the beach more often than usual.

I tested in training room and found that , launch torpedo while turning will cause the direction not as my decision.

I played WOWS many years , I know that there is some launch  lag while maneuvering.
But this time is not consistent as I played before.

Attached screen shot show one of my test  , I aimed on open water but hit on beach.
Just test it yourself if you doubt about that

shot-21.06.18_20.44.07-0481.jpg

shot-21.06.18_20.44.32-0424.jpg

shot-21.06.18_20.44.36-0811.jpg

Another bug that WeeGee won't acknowledge

Share this post


Link to post
Share on other sites
11
[D33P6]
Members
14 posts
6,269 battles
On 6/23/2021 at 12:40 AM, The_Incomparable_Giacomo said:

This is a serious bug that has appeared with the latest patch. 

I'm a DD main and my torps are just not going where they are aimed reliably. Just had a ranked game with 4 volleys hitting islands. 

WOW FIX THIS NOW!!!!!

  • Cool 2

Share this post


Link to post
Share on other sites
50
[NFJF]
Members
53 posts
8,426 battles

Shouldn't they at the very least acknowledge the issue? This is huge, and it's not something hard to reproduce. It happens literally every time

Share this post


Link to post
Share on other sites
1,438
[DRFTR]
Beta Testers
4,973 posts

could this be a case where the ship is out turning the launcher?  I am thinking while the game may have not always worked this way....   this "bug" is not a bug at all, and makes more sense...    just like any other ship maybe able to outturn it's gun traverse rate...

The only way for all torps to hit the island in this case is if they all launched at the same time while pointed in the same direction and that wouldn't be possible in the scenarios shown above...

 

how many degrees per second is the ship turning, how much time between torps launching...  now if torps tubes locked like guns did ... maybe... though again, turn rate vs tube traverse still comes into play.

 

  • Meh 1

Share this post


Link to post
Share on other sites
194
[KOBK]
Members
536 posts
6,245 battles

Yeah, looks like turning while launching torpedos affect their direction. I start to suffer this after the last patch.

Maybe is one of those new wg ninja nerfs?

Share this post


Link to post
Share on other sites
Members
1,781 posts
7 hours ago, SKurj said:

could this be a case where the ship is out turning the launcher?  I am thinking while the game may have not always worked this way....   this "bug" is not a bug at all, and makes more sense...    just like any other ship maybe able to outturn it's gun traverse rate...

No, not really.

  • If that were the case (such as with turrets) then the pointer (green wedge) should not be on target, similar to how the gun turret pointers are not on target when you outturn them
  • Gun turrets don't react to ping in the manner described here

Fundamentally, the issue is the synchronization between server and client. Some part of the shooting/aiming is done on the client while a different part is done on the server side. With zero latency that is not an issue, however with latency you get weird effects like this one.

The next bit is more a "feel" rather than fact thing, but I suspect that a lot of the weird dispersion some people seem to get (I know a few players do the lock-off lock-on thing for "good Luck" a lot) is the desync between the client that appears to be lock on (and camera is following the ship) while the server is not yet in lock-on mode and just gets the cursor information, kinda like blind firing.

My suspicion is they changed something in the net code and handling of target lock on etc. in preparation for subs and this messed it up.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×