Jump to content
Sign in to follow this  
You need to play a total of 20 battles to post in this section.
grcorrie

not receiving twitch drops in game

7 comments in this topic

Recommended Posts

Members
6 posts
7,076 battles

My twitch account is connected to WOWs account, I am on line, I see the drops being finished and click on them to claim them, I restart the game client, but I am still not seeing the containers or missions in the on line game client. Any help would be greatly appreciated

Share this post


Link to post
Share on other sites
437
[-A-8-]
Members
690 posts
27,977 battles

They don't seem to instantaneous as before. I usually find they are there after an hour or the next day (still need to log out and in). 

Share this post


Link to post
Share on other sites
3,338
Members
2,768 posts
3 hours ago, wildgooseman said:

They don't seem to instantaneous as before. I usually find they are there after an hour or the next day (still need to log out and in). 

Been 6 days since I was supposed to get:

  • Two 125 German Tokens drops.
  • Two Twictch containers.
  • One (or maybe two) missions.

Still nothing...

Share this post


Link to post
Share on other sites
437
[-A-8-]
Members
690 posts
27,977 battles
26 minutes ago, theLaalaa said:

Been 6 days since I was supposed to get:

  • Two 125 German Tokens drops.
  • Two Twictch containers.
  • One (or maybe two) missions.

Still nothing...

Ah. Maybe a ticket to support is in order.

I'm tempted to say unlink then relink your account but would do via support in case it cancelled the drops you're waiting on.

Share this post


Link to post
Share on other sites
3,338
Members
2,768 posts
28 minutes ago, wildgooseman said:

Ah. Maybe a ticket to support is in order.

I'm tempted to say unlink then relink your account but would do via support in case it cancelled the drops you're waiting on.

Yeah, you may be right...

...now if I could just muster enough motivation to initiate that ticket....

Share this post


Link to post
Share on other sites
3,598
[PVE]
Members
10,597 posts
32,116 battles
1 hour ago, theLaalaa said:

...now if I could just muster enough motivation to initiate that ticket....

Shouldn't take much more muster than it took to start this thread...

Just skip the WGCheck report as I don't think it's necessary (not a connection problem or in game mechanics not working)...

Alot of people have had the same issue but I haven't seen any threads about the problem still occuring after contacting support so guessing they got the procedure for getting it handled down pretty good once you contact them.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×