Jump to content
Sign in to follow this  
You need to play a total of 20 battles to post in this section.
Ispyarock

DD torp not fire on first mouse click

4 comments in this topic

Recommended Posts

2
[AUTOX]
Members
11 posts
8,626 battles

When there is 3+ ships battling in close combat, a lot of times clicking the mouse once for firing torps will not fire off the torps, even sometimes clicking it second time does not trigger the torps. It is very frustrating during close quarter combat if you missed the moment to attack, you will get sink.

Share this post


Link to post
Share on other sites
2,824
[PVE]
Members
8,822 posts
25,144 battles
5 minutes ago, Ispyarock said:

When there is 3+ ships battling in close combat, a lot of times clicking the mouse once for firing torps will not fire off the torps, even sometimes clicking it second time does not trigger the torps. It is very frustrating during close quarter combat if you missed the moment to attack, you will get sink.

 

Happened a lot in the Big Hunt battles also.

Haven't had any problems in random personally but had it happen a lot in that game mode.

Share this post


Link to post
Share on other sites
4,107
[WPORT]
Members
11,000 posts
15,489 battles

Has happened to me a number of times, today.

Click = torps not launching.

Have to click again or sometimes get sunk because ordnance malfunctioned and opposing ship has time to fire upon my ship.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×