Jump to content
Sign in to follow this  
You need to play a total of 20 battles to post in this section.
SasserWorm

Loggin In......

7 comments in this topic

Recommended Posts

5
[VCW-E]
Members
7 posts
15,728 battles

It's been loggin in for a few hours..... I'm on a fast connection. Any ideas?

Share this post


Link to post
Share on other sites
956
[SPERG]
In AlfaTesters, In AlfaTesters
2,519 posts
13,562 battles

Reboot your PC, power cycle modem

Share this post


Link to post
Share on other sites
346
[WOLFA]
Beta Testers, In AlfaTesters
1,335 posts

yeah if not connect min or two alt-f4 try again

Share this post


Link to post
Share on other sites
3,614
[SALVO]
Members
3,658 posts
7,507 battles
9 minutes ago, SasserWorm said:

It's been loggin in for a few hours..... I'm on a fast connection. Any ideas?

Should be going to the game support part of the forum: https://forum.worldofwarships.com/forum/266-game-support-and-bug-reporting/

Lots of people have / had the same issue. It seems resetting all the game settings through the launcher helped some people. 

Share this post


Link to post
Share on other sites
7,970
[WORX]
Members
14,123 posts
20,570 battles
21 minutes ago, SasserWorm said:

It's been loggin in for a few hours..... I'm on a fast connection. Any ideas?

It sounds like You have a connection issue... I recommend.. (since I didn't have any issues last night)...

  1. Restart your PC along with your Modem and Router (if you have one and your ISP allow it) for 5 min *Without the power *...
  2. Do a check and repair in WGC after you boot right up...
  3. Load a game and check for performance issues or improvements..

This process solves the issue you described about %90 of respondents with your issue.

Share this post


Link to post
Share on other sites
10,159
[PSP]
[PSP]
Members
15,480 posts
1 hour ago, DudeWhereIsMyTank said:

Wow sounds like 1990s.

I haven't use modem since 2001. I guess I am lucky

If you are use ADSL/VDSL or cable internet you still use a modem. Does you local ISP provide internet service only via WiFi or a fiber-optic to Wifi access point at your home?

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×