Jump to content
Sign in to follow this  
You need to play a total of 20 battles to post in this section.
Hyperion728

Twitch drops not appearing

26 comments in this topic

Recommended Posts

119
[KIA]
Members
237 posts
24,377 battles

Italian Tokens mission 1 missing.  I was playing heavily at the time and thought I missed it appearing in my list because it's one of those random missions that periodically pops up, but is so easy to complete I sometimes only notice when the reward is issued.

So I thought this was a fluke until I noticed that my Twitch Mission 1 didn't drop either.  I repeatedly checked my connection between WG and Twitch, made sure I was logged into both, yadda yadda; everything checks out.

I was very deliberate in Italian Tokens 2 and Twitch Mission 2; they have not dropped, nor has the associated container.  My accounts are still linked, I repeatedly logged into and out of both systems, still nothing.

In a nut shell I'm missing twitch everything from the 10.1 drop onward, I can provide screenshots as necessary.  So what now?  Thanks ahead.

Share this post


Link to post
Share on other sites
Members
968 posts
220 battles

@Hyperion728

 

You need to collect Twitch drops from the Twitch drop down menu.  It changed in that stuff is no longer delivered directly to the port.

 

e.g.  

  1. Click on user portrait (in Twitch)
  2. select drops
  3. image.png.0956a08ad37db0f285a1feaa1635ac15.png
  4. and collect
Edited by Laser_Beam
  • Cool 1

Share this post


Link to post
Share on other sites
119
[KIA]
Members
237 posts
24,377 battles
10 minutes ago, Laser_Beam said:

@Hyperion728

 

You need to collect Twitch drops from the Twitch drop down menu.  It changed in that stuff is no longer delivered directly to the port.

 

e.g.  

  1. Click on user portrait (in Twitch)
  2. select drops
  3. image.png.0956a08ad37db0f285a1feaa1635ac15.png
  4. and collect

I did all that already.  Both containers and all the missions are lined up across the bottom as claimed.  There's a hyperlink to connect them to wows, which when followed leads me to where it tells my I'm already linked (and have been for quite some time).

Share this post


Link to post
Share on other sites
1,871
[UNHLY]
Wiki Editor
6,059 posts
16,428 battles
4 minutes ago, Hyperion728 said:

I did all that already.  Both containers and all the missions are lined up across the bottom as claimed.  There's a hyperlink to connect them to wows, which when followed leads me to where it tells my I'm already linked (and have been for quite some time).

There have been a number of reports on the forums and reddit of people claiming their drops but not having them show up. If you unlink and relink your account and then reload the game they should show up. 

  • Cool 2

Share this post


Link to post
Share on other sites
2,868
[WDS]
[WDS]
Members
5,022 posts
14,491 battles

Yea I did the drop down to but I never got the 2nd mission . I did get the second container but the one with a mission I never got ..

Share this post


Link to post
Share on other sites
119
[KIA]
Members
237 posts
24,377 battles
12 hours ago, MidnightPhoenix07 said:

There have been a number of reports on the forums and reddit of people claiming their drops but not having them show up. If you unlink and relink your account and then reload the game they should show up. 

Yup, unlinking and relinking worked; I got everything at once.  Thanks a bunch!

Share this post


Link to post
Share on other sites
1
[OGV]
Beta Testers
32 posts
7,229 battles

Linked, unlinked, reloaded, nothing shows up.

 

I think this is the second time this has happened.

  • Cool 1

Share this post


Link to post
Share on other sites
6,922
[PVE]
[PVE]
Members
11,172 posts
28,863 battles

I signed up for Twitch Drops back when World of Tanks first started the program. I have gotten every single monthly drop for Tanks & Ships since then and tons of the watcher crate/mission drops with no problems. Something has changed with Twitch I think. I am getting my mission drops for watching but this most recent watcher crate shows in Twitch that I claimed it, but never was credited to my account. This is the first time this has ever happened  but again, believe it is a problem with Twitch itself. I recently have had problems earning my bonus points for watching streamers as I click on the green box to collect the bonus but it immediately goes to red. I am betting this is related to missing watcher drops. IMHO the problem is with Twitch and not with Wargaming. If you are having problems collecting drops, you may want to contact Twitch customer support and see what is going on. 

Share this post


Link to post
Share on other sites
78
[PAK]
Members
191 posts
40,892 battles

This worked for my bug. We need a thread for this bug so people see it easier.

Share this post


Link to post
Share on other sites
13
[HI-CS]
[HI-CS]
Members
55 posts
9,054 battles

Same problem, missing one Twitch container. Reported to user support. They replied:
>> I'd like to note that due to the technical issues you have not received Twitch-container. We are aware of this issue and looking into to solve it.

Share this post


Link to post
Share on other sites
78
[PAK]
Members
191 posts
40,892 battles

Did you unlink and relink your Twitch account on WG website?

 

Share this post


Link to post
Share on other sites
61
[PVE]
[PVE]
Members
74 posts
32,413 battles

I didn't get my container, linked and relinked, still no container. Didn't have this problem till they changed it from getting the container while still logged in game. Retrograde progression.

 

Share this post


Link to post
Share on other sites
13
[HI-CS]
[HI-CS]
Members
55 posts
9,054 battles
5 hours ago, Diison said:

Did you unlink and relink your Twitch account on WG website?

 

My accounts are linked. I got 2 Twitch missions one hour later.
Still missing my container. Maybe WG should fix that first?

tw1a.jpg

Share this post


Link to post
Share on other sites
0
[-G0D-]
Members
5 posts
2,402 battles

havent recieved my twitch cont on the 1st of may i recieved the mission but not my cont plz help where do i have to go to claim it

Share this post


Link to post
Share on other sites
13
[HI-CS]
[HI-CS]
Members
55 posts
9,054 battles

The problem still persists. Did anyone received Twitch container on May 6?
Surprisingly missions are not affected by this bug.

tw2ab.jpg

Share this post


Link to post
Share on other sites
1,432
[CO-OP]
Members
3,306 posts
34,269 battles

Tried unlinking and relinking still no container, in fact I think I'm missing two from this month.

Share this post


Link to post
Share on other sites
61
[PVE]
[PVE]
Members
74 posts
32,413 battles

2nd week, now no mission or container. I don't have time for this, cancelling twitch completely, waste of my time.

 

Share this post


Link to post
Share on other sites
196
[OVRPN]
[OVRPN]
Beta Testers
402 posts
21,747 battles

Can confirm. I have 1 Twitch container claimed 2 days ago and a KotS mission from 20 minutes ago that have not appeared in game. Both claimed per Twitch Drops page.

 

KotS mission finally showed. Still no sign of Twitch container for 2 days ago.

Share this post


Link to post
Share on other sites
196
[OVRPN]
[OVRPN]
Beta Testers
402 posts
21,747 battles

3  days after originally showing it claimed, the container drop reset Sunday and showed unclaimed again. Claimed it again and 24 hours later nothing has shown up.

Share this post


Link to post
Share on other sites
1,852
[CO-OP]
Members
5,103 posts
37,737 battles
36 minutes ago, ZeroGiven said:

3  days after originally showing it claimed, the container drop reset Sunday and showed unclaimed again. Claimed it again and 24 hours later nothing has shown up.

File a ticket with player support.  You'll need to show screenshots of the claimed prizes  They will probably tell you to re-link your Twitch account.  If that doesn't work, they will manually give you the containers.

Share this post


Link to post
Share on other sites
196
[OVRPN]
[OVRPN]
Beta Testers
402 posts
21,747 battles

I did the relinking after the first time and nothing happened. It is only 1 free container so not worth dealing with WeeGee's horrendous support. Just pointing out that it is still happening so they can fix the problem.

Share this post


Link to post
Share on other sites
1,432
[CO-OP]
Members
3,306 posts
34,269 battles

Got a response from CS on my ticket about this about an hour ago. They seem to have fixed it, certainly when I logged into my game this morning there were 2 Twitch boxes waiting for me.

Share this post


Link to post
Share on other sites
37
[QTPIE]
[QTPIE]
Members
63 posts
7,436 battles

The steam containers you're supposed to receive every month aren't working either.

Edited by plutia_planeptune

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×