Jump to content
You need to play a total of 20 battles to post in this section.
LunchCutter

Is WoWs the slowest loading game on the market?

52 comments in this topic

Recommended Posts

Members
1,197 posts
3,439 battles

Out of the dozen or so games I play on my pc WoWs is the slowest loading (to startup). I timed it today, 2m 37s from hitting the play button at the launcher to the ship selection screen loading. I have a fast pc but WoWs is installed on a 1tb Barracuda mechanical drive (too big for my SSD). Yet other games on the same drive load in a flash.

A rival game that is made by a Russian dev with the name 'Thunder' in it takes 15 seconds to start.

Assetto Corsa, 9 seconds.

IL2 Battle of Stalingrad, 18 seconds

iRacing, 20-40 seconds, depending on the track. 

 

 Not sure how the intro video can be removed or other changes made, it just seems to take a long time to start for a fairly old game that runs fine on most pcs. 

 

  • Cool 5
  • Haha 1

Share this post


Link to post
Share on other sites
835
[-AFK-]
Members
1,442 posts
17,910 battles
2 minutes ago, LunchCutter said:

Out of the dozen or so games I play on my pc WoWs is the slowest loading (to startup). I timed it today, 2m 37s from hitting the play button at the launcher to the ship selection screen loading. I have a fast pc but WoWs is installed on a 1tb Barracuda mechanical drive (too big for my SSD). Yet other games on the same drive load in a flash.

A rival game that is made by a Russian dev with the name 'Thunder' in it takes 15 seconds to start.

Assetto Corsa, 9 seconds.

IL2 Battle of Stalingrad, 18 seconds

iRacing, 20-40 seconds, depending on the track. 

 

 Not sure how the intro video can be removed or other changes made, it just seems to take a long time to start for a fairly old game that runs fine on most pcs. 

 

I just timed mine with a stop watch, 
1 minute 5 seconds. 
I have it on an NVME M.2 hard drive. 
You provided the answer in your original description "but WoWs is installed on a 1tb Barracuda mechanical drive"
That is why it is slow to load for you. 

If the login process was faster I likely would have loaded around 30 seconds 

  • Meh 1

Share this post


Link to post
Share on other sites
485
[USCG]
Members
941 posts
28,612 battles

I’ve disabled the opening video and that doesn’t seem to help. This last update has really slowed things down.

On the good side, I can get my coffee ready and go to the bathroom while things are loading...

  • Cool 1

Share this post


Link to post
Share on other sites
Members
1,197 posts
3,439 battles
33 minutes ago, Salvo_Creative said:

I just timed mine with a stop watch, 
1 minute 5 seconds. 
I have it on an NVME M.2 hard drive. 
You provided the answer in your original description "but WoWs is installed on a 1tb Barracuda mechanical drive"
That is why it is slow to load for you. 

If the login process was faster I likely would have loaded around 30 seconds 

It's a mechanical drive but as a comparison the other games on it load 10x faster. WoWs just does not feel optimally coded. Some of the updates take a hour to install... The other Russian online ww2 game loads and updates infinitely faster.

 

 

Share this post


Link to post
Share on other sites
190
[-KIA-]
Members
823 posts
11,920 battles

Mine loaded for 50 seconds. My game is installed to Hitachi 1TB HDD but connected to a SATA 3 port.
The only time that my game loaded long like that as you mentioned is I have it connected to a SATA 2 port from my old PC (same drive, just moved it to my new PC).

Spoiler

 

 

Edited by Ayanami_Kai

Share this post


Link to post
Share on other sites
0
[-TRM-]
Members
0 posts

I run it on a stack of 6 Vertex 3 SSD's and it will take a minute or so give or take. I don't waste it hovering over the thing. Other larger games online load extremely fast particularly online maps which was the reason for existing on the computer build back in the day. Load first into map and move first if there was no map start clock for 30 seconds or whatever. My system however is getting long in the tooth so I bypass the loading video.

The pending replacement build has about 14 SSD's on hand which should increase write and read throughput. However there isnt much room to increase the capacity and speeds of the various other components without also requiring more cooling and power draw.

When I tether the smart phone to the computer the associated performance in internet up and down approaches that of fiber optic. The current loading time of game from play button to presentation of port with battle button is about 41 seconds. There is about a 10 sec delay before the clan chat tab comes up.

Edited by xHeavy

Share this post


Link to post
Share on other sites
1,977
[BWC]
Beta Testers
2,882 posts
9,264 battles

Well, unless you have a dedicated SSD for it, a certain space sim game that has been under development for over 8 years can take up to 10 minutes to load.  Sooooo......

 

 

Share this post


Link to post
Share on other sites
2,382
[RAN]
Members
925 posts
11,007 battles
1 hour ago, LunchCutter said:

Out of the dozen or so games I play on my pc WoWs is the slowest loading (to startup). I timed it today, 2m 37s from hitting the play button at the launcher to the ship selection screen loading. I have a fast pc but WoWs is installed on a 1tb Barracuda mechanical drive (too big for my SSD). Yet other games on the same drive load in a flash.

 

perhaps you need to man up and buy a decent computer, vid card and good internet connection. I use the NA server and i live in Australia and it took me 40 seconds to load and thats with the opening video.  What does that tell you .

Edited by DevilD0g
  • Boring 3
  • Meh 1

Share this post


Link to post
Share on other sites
4,246
[O_O]
Members
7,581 posts
20,002 battles

Mine was 38 seconds, from clicking Start on the Game Center to landing in port, even while watching the intro video...now with sound effects!

Remember, this is a server-side game that you have to log into.  If you are playing other games that you can play without another server, they SHOULD load almost immediately (depending on your system).

AMD Ryzen 7 3700X, Radeon RX5700, SU800 1TB SSD.  Once you go SSD or NVMe, you can never go back.

Edited by desmo_2
  • Cool 1

Share this post


Link to post
Share on other sites
2,868
[WDS]
[WDS]
Members
5,022 posts
14,491 battles

Mine took 2:25 seconds but I have an old Acer HDMI all in one I have to play on low settings or it freezes up . When I finally get the last of my 7 kids through college I will upgrade if it doesn't kill me first .

Share this post


Link to post
Share on other sites
0
[-TRM-]
Members
0 posts

Or Civ 5. Some games on it approaching 1000 turns have a even chance of failing to load successfully. When I run Civ 5 the computer is never off until the game is complete. Up to a month in some cases. Its interesting to see it carry the load of those older games.

What does break my computer is pure 4K or even 6K and most all 8K video. I can run some up to 6K a little bit but eventually it breaks and then dumps the load. Once the video cards are replaced and the SSD's replaced with a overclocking applied to the 3930 to about 4.2ish I should be able to run 4K and touch 6K for a time. My biggest problem is storage. I have been working on a 10 Tera thunderbolt array that will be serving my machine locally. There are technical hurdles to over come to get the link running fast enough to make it work.

There are no practical (As in relatively cheap) hardware in the PC class that I can upgrade from this. Im already close to dual CPU and server land as it is. The electrician has a work order to upgrade my current 15 amp wall socket to a ground fault protected 30 amp supply. Just waiting on his work order to be done. Once that is in then I can proceed.

Edited by xHeavy

Share this post


Link to post
Share on other sites
7,036
Members
34,409 posts
10,768 battles
24 minutes ago, clammboy said:

Mine took 2:25 seconds but I have an old Acer HDMI all in one I have to play on low settings or it freezes up . When I finally get the last of my 7 kids through college I will upgrade if it doesn't kill me first .

Depending on how far apart your kids are, maybe the first one will have a killer job and have paid his student loans, and can get you a new PC as a thank you gift! :Smile_veryhappy:

Share this post


Link to post
Share on other sites
80
[TAC-B]
Beta Testers
204 posts
13,519 battles

It's definitely not the slowest loader.  Compared to World of Tanks, WoWS is a game-loading speed demon.

WoT takes more time to 'synchronize' stuff after mostly loading, than WoWS takes to do the whole thing.  

Share this post


Link to post
Share on other sites
535
[CAZA]
Beta Testers, In AlfaTesters
583 posts
8,100 battles

It does feel a bit sluggish to me, not only the loading but also navigating through the menus and stuff. Changing ships, mounting flags, opening the tech tree still feel laggy as hell.

Share this post


Link to post
Share on other sites
6,680
[WPORT]
Members
16,020 posts
19,620 battles
5 hours ago, LunchCutter said:

Out of the dozen or so games I play on my pc WoWs is the slowest loading (to startup). I timed it today, 2m 37s from hitting the play button at the launcher to the ship selection screen loading. I have a fast pc but WoWs is installed on a 1tb Barracuda mechanical drive (too big for my SSD). Yet other games on the same drive load in a flash.

A rival game that is made by a Russian dev with the name 'Thunder' in it takes 15 seconds to start.

Assetto Corsa, 9 seconds.

IL2 Battle of Stalingrad, 18 seconds

iRacing, 20-40 seconds, depending on the track. 

 

 Not sure how the intro video can be removed or other changes made, it just seems to take a long time to start for a fairly old game that runs fine on most pcs. 

 

Switch to an SSD drive.
The improvement will be amazing.

  • Cool 2

Share this post


Link to post
Share on other sites
Members
1,197 posts
3,439 battles
3 hours ago, SgtSpud said:

54 seconds...SSD.

 

That's still a bit slow for SSD.

6 hours ago, DevilD0g said:

perhaps you need to man up and buy a decent computer, vid card and good internet connection. I use the NA server and i live in Australia and it took me 40 seconds to load and thats with the opening video.  What does that tell you .

Man up? Have a ryzen 5 5600x, Nvidia rtx 3070 and 32 GB of DDR3 ram. My SSD is only 256gb so I had to install Wows on the mechanical drive. I also live in Australia..

  • Thanks 1

Share this post


Link to post
Share on other sites
Members
1,870 posts
13 minutes ago, LunchCutter said:

My SSD is only 256gb so I had to install Wows on the mechanical drive. I also live in Australia..

I think for faster storage the limiting factor is probably the login to the server, at least on my end it is. I run it on a NVME SSD and though I haven't timed it, the login process seems longer than the loading process. In game loading a battle is a matter of only a few seconds.

Don't know about SSD prices in Australia, here in the US they are at around 120$ to 200$ for a decent 1TB SSD, depending on whether you want to have regular SATA or NVME, brand etc. Some are 100$ or below, but those seem rather sketchy. Mind you, this was just a 5 minute search on newegg so maybe there are better deals out there. Depending on your financial situation, availability in Australia, etc. it might be worth to consider an upgrade. I will say though that I'd definitely prefer NVME over SATA SSDs nowadays because the speed difference can be observed in some games (Witcher 3 loading times are my favorite example), and I will never go back to spinning drives if I can ever avoid it.

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×