Jump to content
Sign in to follow this  
You need to play a total of 20 battles to post in this section.
Shadow_Wolf7

Can't change key bindings "Hotkey Reserved"?

2 comments in this topic

Recommended Posts

22
[T3I0F]
Members
69 posts
3,100 battles

I had to re-download wows and am trying to set the key bindings back to what I like but can't seem to get a couple to work properly. I want to bind reinforce AA sector to "4", consumable 2 to "5" and consumable 3 to "6". However when I go into settings to reprogram these buttons it won't let me stating "hotkey reserved". I read this as the game telling me that another command used those keys but the only one is "4" is bound to squadron 4 by default which is useless since no carrier has 4 different squadrons (just rockets, bombs, and torpedoes) so I unbound that and it still gave me the same "hotkey reserved" message. It also gives me this message if I try to bind the consumable commands to "5" or "6" which by default aren't bound to anything. Can anyone explain this to me please?

WOWS.JPG

Edited by Shadow_Wolf7

Share this post


Link to post
Share on other sites
22
[T3I0F]
Members
69 posts
3,100 battles

Was able to come up with a solution in case anyone else runs into this issue.

First you go into your game and change the key bindings you want changed to something, anything that it lets you change it to that is not the default key binding (I know this sounds weird but trust me) then apply changes and exit the game.

Second you go into your wows files, my path was: Local Disk (C:) -> Program Files (x86) -> Steam -> SteamApps -> common -> World of Warships but yours will of course vary depending on what launcher you are using etc. In that folder you can find a file titled "preferences.xml" open it using notepad or a similar software you can edit in.

Third toward the bottom you will find something that looks like the image attached. This is where your key binding preferences are saved. Only key bindings that you have changed from default show up here which is why you had to initially change them to something other than the default key in the first step. Now you can change the keybinding to whatever you wish following the format found. In the image below I changed my 3rd consumable to be bound to the "6" key rather than the default "T" key. I first bound it to my numpad 6 key and the fifth line of the highlighted code read "key=KEY_NUMPAD6" and then I edited the code to "key=KEY_6" to make it the "6" key above the keyboard. As far as I can tell this can be done on any key binding to get around the dumb "Hotkey Reserved" statement (although I haven't tried every combination). Hope this helps someone else in the future!

preferences.JPG

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×