Jump to content
You need to play a total of 20 battles to post in this section.
ThisIsClassic

0.10.0 Drops in January

8 comments in this topic

Recommended Posts

1,137
[INTEL]
Members
3,415 posts
18,912 battles

At least that's what the Dev Blog is saying (with the usual disclaimer):

There will be 2 Brawls in 0.10.0:

- 26 of January 2021 - 1 of February 2021 in "7 vs 7" format on Tier VIII ships
- 9 of February 2021 - 1 of February 2021 in "7 vs 7" format on Tier VIII ships

https://blog.worldofwarships.com/blog/101

And a Pan Asian CV?

 

Edited by ClassicLib

Share this post


Link to post
Share on other sites
258
[RAIN]
Members
271 posts
8,716 battles

pan asian CVs?

when a pan american line is made yet?

or italian CVs 

let me guess ap torps

Share this post


Link to post
Share on other sites
50
[-TKS-]
Members
272 posts
9,411 battles
Quote
  • The game is now being loaded while the video is played on the startup loading screen.

OMG a UI update!!! THANK YOU!!!! sometimes during CBs the game will fail to load and you need to reboot the game to get back into the match, which on my pc takes 2ish minutes **game is installed on a HDD not SSD**. This should hopefully save alot of load up time. 

 

WG can you also PLEASE update the UI when LEAVING a game and going to port?? its dreadfully slow getting back to port. First world problems i know, but I'd love to see a couple full update cycles just on game preformance. I know these type of updates don't make money, but it'd make alot of people happier, and allow the game to play on potato computers better which could increase player base.

 

pc stats for those curious:

3.4ghz 8-core

32gb ram

Nvidia 1660 *8gb ram*

250gb SSD for OS

500GB HHD for games **ya i needa upgrade this**

Share this post


Link to post
Share on other sites
1,137
[INTEL]
Members
3,415 posts
18,912 battles
9 minutes ago, Freelancerinc said:

OMG a UI update!!! THANK YOU!!!! sometimes during CBs the game will fail to load and you need to reboot the game to get back into the match, which on my pc takes 2ish minutes **game is installed on a HDD not SSD**. This should hopefully save alot of load up time. 

Good point.  This has only happened to me once but yes, it was very annoying waiting the extra bit of time even knowing that you can click and abort it.

Share this post


Link to post
Share on other sites
50
[-TKS-]
Members
272 posts
9,411 battles
1 minute ago, ClassicLib said:

Good point.  This has only happened to me once but yes, it was very annoying waiting the extra bit of time even knowing that you can click and abort it.

i get it atleast twice per CB season, i have a replay on @NoZoupForYou youtube channel that had a late start but still got me a massive win. I can see how bad this would be for people at higher leagues.

 

I know WG does do bug fixing and some performance fixes, but 1-2 full patch cycles dedicated to it would make massive changes to the first world problems

Share this post


Link to post
Share on other sites
381
[IMP]
Beta Testers, In AlfaTesters
417 posts
6,075 battles
23 minutes ago, Freelancerinc said:

WG can you also PLEASE update the UI when LEAVING a game and going to port?? its dreadfully slow getting back to port. First world problems i know, but I'd love to see a couple full update cycles just on game preformance. I know these type of updates don't make money, but it'd make alot of people happier, and allow the game to play on potato computers better which could increase player base.

WG sucks at UI performance, it has always been bad. I'm running WoWs on a SSD M.2 and sometimes the UI takes forever to load, because it's bloated or something. When I used to run WoWs on my old HDD it was even worse, it took forever to open up things like Naval Battles or the Armory.

Utter nonsense, WG lags behind UI development and performance like no other.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×