Jump to content
You need to play a total of 20 battles to post in this section.
LowSpeed_US

WarGaming Center (two different regional accounts)

7 comments in this topic

Recommended Posts

680
[NSEW]
Members
2,582 posts
12,112 battles

Hello all,

With the implementation of the WarGaming Center (WGC). I know that switching between regional accounts were possible., during the non patch days.

However, this is my question.

Could you initiate the "Pre download" option, and log in with the NA account to install the client for NA region?

Or am I still stuck with the "EU client" for until the following day for the EU servers to update?

Thanks in advance.

 

p.s. If the answer is no to the first question. Perhaps the Wargaming developers could work on this to allow for such methods to log in during the cross over patch days.

 

Share this post


Link to post
Share on other sites
3,187
[WOLF5]
Supertester
5,236 posts
4,354 battles

I believe all servers update at the same time now? I thought that was a requisite for the client merge.

If not, logging in with your NA account should allow you to access the NA server and update your client.

Share this post


Link to post
Share on other sites
680
[NSEW]
Members
2,582 posts
12,112 battles
6 minutes ago, AJTP89 said:

I believe all servers update at the same time now? I thought that was a requisite for the client merge.

If not, logging in with your NA account should allow you to access the NA server and update your client.

Just tried it.  Sadly, I too thought it was the requisite for the client merge.

Not sure how it works, but it seems that we'd still need a separate clients each for each regional servers.

So basically, this 'merge' is really partially working only during the times when the update schedule is not synced.

Annoying really.

 

Share this post


Link to post
Share on other sites
3,187
[WOLF5]
Supertester
5,236 posts
4,354 battles
2 minutes ago, LowSpeed_US said:

Just tried it.  Sadly, I too thought it was the requisite for the client merge.

Not sure how it works, but it seems that we'd still need a separate clients each for each regional servers.

So basically, this 'merge' is really partially working only during the times when the update schedule is not synced.

Annoying really.

 

Hmm, this is the patch it rolled out right? Maybe they still haven't updated the regional servers yet.

The servers are still different, the change is that you only need one client now. You just log in to WGC with the appropriate account and it takes you to the right server.

So EU server hasn't patched yet, but NA has. Can you log in to WGC with your NA account and get the client update through NA?

Share this post


Link to post
Share on other sites
680
[NSEW]
Members
2,582 posts
12,112 battles
1 minute ago, AJTP89 said:

Hmm, this is the patch it rolled out right? Maybe they still haven't updated the regional servers yet.

Yes, 9.10

1 minute ago, AJTP89 said:

The servers are still different, the change is that you only need one client now. You just log in to WGC with the appropriate account and it takes you to the right server.

Not sure, it works like this.  Since, when I do log in with the NA account. It informs me that I need to update.  

1 minute ago, AJTP89 said:

So EU server hasn't patched yet, but NA has. Can you log in to WGC with your NA account and get the client update through NA?

I have logged into WGC with my NA account.  Nothing was downloaded nor any install prompts.

However, I have activated the "Download updates in advance" via options section.  I let it run, then when completed. I exited the WGC, relaunched it, logged in with my NA account. Alas, still no joy.  Even with the predownload already in client. It did not trigger the installation/update process.

 

 

Share this post


Link to post
Share on other sites
3,187
[WOLF5]
Supertester
5,236 posts
4,354 battles
Just now, LowSpeed_US said:

Yes, 9.10

Not sure, it works like this.  Since, when I do log in with the NA account. It informs me that I need to update.  

I have logged into WGC with my NA account.  Nothing was downloaded nor any install prompts.

However, I have activated the "Download updates in advance" via options section.  I let it run, then when completed. I exited the WGC, relaunched it, logged in with my NA account. Alas, still no joy.  Even with the predownload already in client. It did not trigger the installation/update process.

 

 

But you can't play? Like the play button is greyed out? Because it's possible it client already patched.

Might be that with the rollout things are a little messed up, usually there's a few problems to be worked out with most patches. Hopefully next patch will be smoother.

Share this post


Link to post
Share on other sites
680
[NSEW]
Members
2,582 posts
12,112 battles
17 minutes ago, AJTP89 said:

But you can't play? Like the play button is greyed out? Because it's possible it client already patched.

Negative. 

Play button is orange/shade of red.  Next to it it reads: "You are running the latest game version 0.9.9.1.2980670"

 

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×