Jump to content
Sign in to follow this  
You need to play a total of 20 battles to post in this section.
Michael_Fast

Install problem using Game Center

15 comments in this topic

Recommended Posts

Members
17 posts
554 battles

I just wanted to be able to play some of the Beta tests and I'm on Steam so I installed the Game Center, it seems to be in an endless loop of installing and updating until the Game folder now is at 130 Gb. My Steam install isn't that big and when it finally said I could play it was still installing updates, but the game still failed to launch cause it's missing a Steam api. What Gives?

Share this post


Link to post
Share on other sites
6,235
[WORX]
Members
11,357 posts
19,106 battles
18 minutes ago, Michael_Fast said:

I just wanted to be able to play some of the Beta tests and I'm on Steam so I installed the Game Center, it seems to be in an endless loop of installing and updating until the Game folder now is at 130 Gb. My Steam install isn't that big and when it finally said I could play it was still installing updates, but the game still failed to launch cause it's missing a Steam api. What Gives?

If you have steam version of WOWS. you can't play through WGC... STeam accounts are not interchangable with WGC.

If you're going to use WGC, you'll need a new acct.

Share this post


Link to post
Share on other sites
5
[-GSC-]
Members
17 posts
5,196 battles
1 hour ago, Michael_Fast said:

I just wanted to be able to play some of the Beta tests and I'm on Steam so I installed the Game Center, it seems to be in an endless loop of installing and updating until the Game folder now is at 130 Gb. My Steam install isn't that big and when it finally said I could play it was still installing updates, but the game still failed to launch cause it's missing a Steam api. What Gives?

If you have installed two instances in your Games folder, World_of_Warships_NA and World_of_Warships_PT, then the size is close to what I have. Mine are 61.6GB and 58.7GB, respectively.

18 minutes ago, Michael_Fast said:

Why do I need a new account? why cant I sign in under my email like I do for the steam version?

 

 I was looking for the source here, as it sounds familiar that there are/were issues to switching, but am unable to find it so far.

Share this post


Link to post
Share on other sites
2,478
[WOLF5]
Supertester
4,377 posts
4,193 battles

Steam login is different than WGC, and the two aren't linkable (no idea why). If you want to use the WGC you will have to create a new account.

Share this post


Link to post
Share on other sites
Members
17 posts
554 battles
48 minutes ago, AJTP89 said:

Steam login is different than WGC, and the two aren't linkable (no idea why). If you want to use the WGC you will have to create a new account.

This is actually not true, I used my email and logged in after I spent 2 hours repairing the install, TWICE, both times it said I was missing a Steam_api.dll After I replaced it and it worked I was able to sign right into my account. Now I have to install a second instance for the TST server and will probably get done about the time the Sub matches are over

Share this post


Link to post
Share on other sites
1,916
[PVE]
Members
6,892 posts
22,643 battles
31 minutes ago, Michael_Fast said:

This is actually not true, I used my email and logged in after I spent 2 hours repairing the install, TWICE, both times it said I was missing a Steam_api.dll After I replaced it and it worked I was able to sign right into my account.

Interesting

2 hours ago, Navalpride33 said:

If you have steam version of WOWS. you can't play through WGC... STeam accounts are not interchangable with WGC.

If you're going to use WGC, you'll need a new acct.

NP usually knows his stuff..maybe a change your not aware of recently?

Share this post


Link to post
Share on other sites
6,235
[WORX]
Members
11,357 posts
19,106 battles
Just now, IfYouSeeKhaos said:

NP usually knows his stuff..maybe a change your not aware of recently?

From what I know, Steam is run differently then non steam accts. For example

  • Mods are installed differently
  • Troubleshooting issues are not the same as non steam users...
    • I have to ask people who have a WOWS Issue... Are they using steam or not.

I can't use my WGC acct. on steam.. Its not happening.

I haven't seen any info, of the two acct. being able to be interchangeable.

 

Share this post


Link to post
Share on other sites
1,916
[PVE]
Members
6,892 posts
22,643 battles
6 minutes ago, Navalpride33 said:

From what I know, Steam is run differently then non steam accts. For example

  • Mods are installed differently
  • Troubleshooting issues are not the same as non steam users...
    • I have to ask people who have a WOWS Issue... Are they using steam or not.

I can't use my WGC acct. on steam.. Its not happening.

I haven't seen any info, of the two acct. being able to be interchangeable.

Could what he installed (that thing they asked him for...the "Steam_api.dll") have reverted him back to steam & him not actually being on the WGC after all?

Share this post


Link to post
Share on other sites
6,235
[WORX]
Members
11,357 posts
19,106 battles
19 hours ago, IfYouSeeKhaos said:

Could what he installed (that thing they asked him for...the "Steam_api.dll") have reverted him back to steam & him not actually being on the WGC after all?

You know I try not to comment on hypothetical or anything not released by Steam or WOWS. IF you monkey with the under the hood componants without the intervention of a mechanic, you therefor are responsible for the outcome (good or bad).

I would leave the files alone, tampering with any files will create so rather frustrating (or from the observer POV, "I told you so") moments. I do not endorse changing any files, especially if steam or WOWS stated in writing. There was a sure/safe way to interchange both steam and WOWS accts.

Edited by Navalpride33

Share this post


Link to post
Share on other sites
1,916
[PVE]
Members
6,892 posts
22,643 battles
4 minutes ago, Navalpride33 said:

There is a sure/safe way to interchange both steam and WOWS accts.

Oh...I got the idea that there wasn't based on your OP...that you needed to start a new account.

But as for the files...it specifically asked him for that file...not like he just started adding random files. Does that make a difference in your recommendation to not add files?

Share this post


Link to post
Share on other sites
Members
17 posts
554 battles

Okay, I get what you guys are saying but here is what I did (and what may have been the cause). I have an account on Steam which as I understand it is different under the hood as you say I installed the Game Center and logged in under my account email addy and installed WoW. Every time it would get to 97% or so it would go back down to 0 and start over again this as you can imagine was both aggravating and perplexing, eventually it told me it was ready to play but it was downloading "future updates" in the background to save time or something but the game would not start because Steam api dll was missing so after I discovered there was a file troubleshooter I verified and it said I had 31 corrupted files so I repaired it that actually also fixed the 128 Gb file size but still no steam_api dll. went to verify again and after finding nothing tried to play still no steam dll. But wait there's more; I had a trial of.. wait for it, Malwarebytes.
Guess where the steam dll was? now I have a very fast connection but all of this took me 4 hours including the extra instance for the test server, at least I got to play with Submarines for an hour and a half and I can log into my WoW account with the same Email I registered my account under, years ago. I have all my Ships, progress, etc. That's it.

Edited by Michael_Fast

Share this post


Link to post
Share on other sites
Members
17 posts
554 battles

And now I have to eat crow, I decided I didn't need the Steam version so I uninstalled it and now I don't have the same ships or progress, weird. This is a little like getting in your car turning the ignition and having the car next to you start up..:cap_fainting:

Share this post


Link to post
Share on other sites
Members
17 posts
554 battles

I'm not really sure what I did but reinstalling the Steam version didn't change the WGC NA version. In Steam I'm Kurt_Bong,  and that version remains as it was. My WGC version is the same name as here which isn't exactly what I want but I have a bunch of Ships at level VI and a bunch of Cash I guess I can live with it although I have a Mahan DD in Steam that I don't have but I guess I can grind it up again. Still weird that the two installs were somehow dependent on one another. Scratching my head over that one.

 

Share this post


Link to post
Share on other sites
6,235
[WORX]
Members
11,357 posts
19,106 battles
2 hours ago, Michael_Fast said:

I'm not really sure what I did but reinstalling the Steam version didn't change the WGC NA version. In Steam I'm Kurt_Bong,  and that version remains as it was. My WGC version is the same name as here which isn't exactly what I want but I have a bunch of Ships at level VI and a bunch of Cash I guess I can live with it although I have a Mahan DD in Steam that I don't have but I guess I can grind it up again. Still weird that the two installs were somehow dependent on one another. Scratching my head over that one.

 

Just return to normal... If you dont know what you're doing neither would we... But if you need a link help go here for your steam account. ...

Try following these steps to do an integrity check:
https://steamcommunity.com/app/552990/discussions/1/1489992080518658002/

  • Cool 1

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×