Jump to content
Sign in to follow this  
You need to play a total of 20 battles to post in this section.
SEKV

Can't Acces my N/A Account

4 comments in this topic

Recommended Posts

18
[RESP]
Beta Testers
109 posts

I  have both an EU and NA account and can only get into my EU account.

Need some help so I can get into my American because I have over 250 ships on that account.

I have made sure I am set for NA on game client but it keeps defaulting to EU.,

Help, please!

Edited by SEKV

Share this post


Link to post
Share on other sites
2,478
[-KIA-]
SuperTest Coordinator, Volunteer Moderator, Clan Supertest Coordinator, Privateers
6,514 posts
8,485 battles

image.thumb.png.7eea354c579981132ecb05af8a2652f2.png 25acc688f0.pngimage.png.2305ed6eb543d6848587ff844d71995f.png

I'm assuming the region-changer mod you're using isn't working properly. Of course, it isn't ideal - but installing the other client for a 100% solid & supported realm is how you should do it.

Share this post


Link to post
Share on other sites
Members
25 posts
146 battles
19 minutes ago, Czevak said:

but installing the other client for a 100% solid & supported realm is how you should do it

but with this update there shouldn't be any difference anymore?

Share this post


Link to post
Share on other sites
2,478
[-KIA-]
SuperTest Coordinator, Volunteer Moderator, Clan Supertest Coordinator, Privateers
6,514 posts
8,485 battles
6 minutes ago, Klopirat_oops said:

but with this update there shouldn't be any difference anymore?

Micro patches could put the actual clients on different technical versions. This could've happened. 

It's my understanding nothing has changed in terms of globalizing the clients - I could be wrong and missed this.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×