Jump to content
Sign in to follow this  
You need to play a total of 20 battles to post in this section.
MustangGT02

Gone two months now lower FPS

8 comments in this topic

Recommended Posts

Members
5 posts
2,748 battles

Hello, I took about a two month break from wows and decided to fire it back up the other day. I noticed that I have what seems to be low FPS or juttering in port and in a match I can see my FPS go well below 60 down to the 40s in some cases. I had every setting maxed out because it worked great in the past so I started adjusting things down and notice now that the FPS drops drastically when near looking at it near a island. Any suggestions? I ran the check and repair and it's the same. 

 

GPU is a Geforce 1080 

I'm using a 82in tv as a monitor so the drops are very noticeable. 

 

Thank you!   

Share this post


Link to post
Share on other sites
763
[KSC]
Members
840 posts
11,429 battles

Every patch sees an incremental update to the lighting engine, and each patch sees another chunk of frames gone.

It's frustrating, though i understand the need to keep the game updated as time goes on.

Share this post


Link to post
Share on other sites
Members
5 posts
2,748 battles
14 minutes ago, Ahskance said:

Every patch sees an incremental update to the lighting engine, and each patch sees another chunk of frames gone.

It's frustrating, though i understand the need to keep the game updated as time goes on.

Man that's a sad truth then. I now have to make the game look worse to run the same as I did. The crazy thing is WOT runs great on my PC set up and looks better graphics wise. 

Share this post


Link to post
Share on other sites
6,683
[WORX]
Members
11,964 posts
19,495 battles
1 hour ago, MustangGT02 said:

Hello, I took about a two month break from wows and decided to fire it back up the other day. I noticed that I have what seems to be low FPS or juttering in port and in a match I can see my FPS go well below 60 down to the 40s in some cases. I had every setting maxed out because it worked great in the past so I started adjusting things down and notice now that the FPS drops drastically when near looking at it near a island. Any suggestions? I ran the check and repair and it's the same. 

 

GPU is a Geforce 1080 

I'm using a 82in tv as a monitor so the drops are very noticeable. 

 

Thank you!   

For your card, medium high is recommended IMO...

Here is a graphics guide to help you in the settings...

GL

Share this post


Link to post
Share on other sites
2,618
[WOLF5]
Supertester
4,579 posts
4,223 battles
52 minutes ago, Navalpride33 said:

For your card, medium high is recommended IMO...

Here is a graphics guide to help you in the settings...

GL

What? Medium high for a 1080? I have a 1050 and run at Very High at 1440 resolution, a 1080 should be able to do Maximum with plenty of frames to spare. If not, it's a user issue.

2 hours ago, Ahskance said:

Every patch sees an incremental update to the lighting engine, and each patch sees another chunk of frames gone.

It's frustrating, though i understand the need to keep the game updated as time goes on.

The lighting engine hasn't been updated in a few patches, and my frames have been fine. Also, almost all their changes have resulted in lighter graphics load. WG takes good care to ensure every Russian toaster can run the game.

OP, you shouldn't be having many issues, unless you're trying to run the game in 4k, in which case you're probably pushing both the game and the GPU. First make sure you graphics settings are optimized, screen sizing, resolution, etc. If that doesn't help, you may need to reinstall. Sitting without updates and then skipping a few may not be the best idea, a fresh install may clear things up.

Share this post


Link to post
Share on other sites
6,683
[WORX]
Members
11,964 posts
19,495 battles
Just now, AJTP89 said:

What? Medium high for a 1080? I have a 1050 and run at Very High at 1440 resolution, a 1080 should be able to do Maximum with plenty of frames to spare. If not, it's a user issue.

1050 Home version is not the same as 1050 "mobile" version. I am guessing you have the PC edition. 

Only graphics card alone will not give you great results.. Since we dont know the other factors/components. I can only can recommend to look over the guide and GL. 

Share this post


Link to post
Share on other sites
2,618
[WOLF5]
Supertester
4,579 posts
4,223 battles
1 minute ago, Navalpride33 said:

1050 Home version is not the same as 1050 "mobile" version. I am guessing you have the PC edition. 

Only graphics card alone will not give you great results.. Since we dont know the other factors/components. I can only can recommend to look over the guide and GL. 

It's in a laptop. Machine does a good impression of a jet plane taking off while playing, but it runs the game beautifully.

But yeah, there's a lot of factors that we don't know here, chances are things just need to be re-optimized.

  • Thanks 1

Share this post


Link to post
Share on other sites
Members
5 posts
2,748 battles

Thanks for all the replies! I am running it in 4k so I guess I'll reduce the resolution and see how that goes. 

My PC is a iBuypower trace 941 

Intel Core i7 (8th Gen) 8700K / 3.7 GHz

geforce 1080 

16GB of Ram

I was thinking of upgrading my PC but don't know anything to be honest. I'll pry get a 3080 when they hit they market, I can easily get more ram. Is my CPU a bottle neck if I upgrade the ram and GPU?

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×