Jump to content
You need to play a total of 20 battles to post in this section.
SonicAnatidae

Campaign Bug?

4 comments in this topic

Recommended Posts

59
[WOLFB]
[WOLFB]
Members
166 posts
3,589 battles

Had anyone run into this?

I landed 36k on an Izmail and another 11K on an ARP Harguro and somehow only got 22k towards the mission of doing 200k damage to IJN ships?

I was in the T8 IJN CV, which qualifies for this mission. 

 

WowsCampaignBug.thumb.png.5ac670e3a36021fb849a9b94334427a2.png

Edited by SonicAnatidae
TypoTypoTypoTypo

Share this post


Link to post
Share on other sites
1,784
[SOFOP]
Members
2,477 posts
15,297 battles

I think you misread it.  It is damage TO IJN ships, not USING IJN ships.  Izmail is not IJN.

Edited by Old_Baldy_One
  • Cool 1

Share this post


Link to post
Share on other sites
1,260
[UNHLY]
Members
5,030 posts
14,137 battles

It’s cause damage to Japanese ships, not in Japanese ships. Izmail is Russian so that 36k doesn’t count, but the 11k on Haguro does. 

  • Cool 1

Share this post


Link to post
Share on other sites
59
[WOLFB]
[WOLFB]
Members
166 posts
3,589 battles

DOH.. Izmail is Russian..  idiocy solved!

Amusingly, I have the IZMAIL and love it. Was up to 4a last night grinding out Midway and Yamamoto capt. 

Happened to get a Kraken in that last game to get the XP and lost of course. :|

Thanks!

Me, after reading the replies

Edited by SonicAnatidae
  • Funny 1

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×