Jump to content
You need to play a total of 20 battles to post in this section.
comtedumas

Ship XP on port screen is back.

15 comments in this topic

Recommended Posts

8,934
[GWG]
[GWG]
Alpha Tester
28,323 posts
14,923 battles

You have to mouse over the captain so you get nothing if there is no one there.

Share this post


Link to post
Share on other sites
6,107
[FOXEH]
Banned
14,364 posts
20,808 battles
3 hours ago, comtedumas said:

Thanks WG, you listened....

sort of .... sideways .... but not really.

Share this post


Link to post
Share on other sites
5,307
[WOLF9]
Wiki Lead
16,284 posts
4,773 battles

Unacceptable.  Sure, hide it for elite ships, but the Ship XP number is primary in the grind.

  • Cool 1

Share this post


Link to post
Share on other sites
1,521
[WOLFC]
Members
3,200 posts
8 hours ago, comtedumas said:

Thanks WG, you listened....

It's not showing for me either ... but on a positive note, it was displayed on the Public Test Server during the last test.

 

  • Cool 2

Share this post


Link to post
Share on other sites
10,396
[INTEL]
Members
13,459 posts
38,992 battles
3 hours ago, DocWalker said:

It's not showing for me either ... but on a positive note, it was displayed on the Public Test Server during the last test.

 

That's good to hear, thanks.

Share this post


Link to post
Share on other sites
16,612
[ARGSY]
Members
24,393 posts
18,349 battles
6 hours ago, comtedumas said:

I swear, guys, it just showed up today.  

Untitled.jpg

 

5 hours ago, OnociTsalk said:

Are you sure it is not a mod? Coz mine does not.

image.thumb.png.bfe9b16fa0d3437ba248218125f834eb.png

Most odd.

Share this post


Link to post
Share on other sites
Members
616 posts
4,409 battles

I just checked and it is  not showing up for me either, and here I was getting my hopes up.  Oh well if it is showing up on the test server, maybe we will see the change someday on the live server.

Share this post


Link to post
Share on other sites
5,307
[WOLF9]
Wiki Lead
16,284 posts
4,773 battles

I have three accounts on NA and one on EU.  Three different client instances.  None show Ship XP on the Port screen.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×