Jump to content
You need to play a total of 20 battles to post in this section.
_LordVoldemort_

"You have been disconnected from the server

3 comments in this topic

Recommended Posts

Members
12 posts
12 battles

Hey! I'm in Europe, so I usually play on EU server. But, if I enter the game, I see this:

What the heck is this error? My WiFi network is good and the EU server isn't far from me. I did a WGCheck, but nothing...

WoWS connection error.png

Share this post


Link to post
Share on other sites
2,630
[PVE]
Members
8,500 posts
24,586 battles
44 minutes ago, _LordVoldemort_ said:

Hey! I'm in Europe, so I usually play on EU server. But, if I enter the game, I see this:

What the heck is this error? My WiFi network is good and the EU server isn't far from me. I did a WGCheck, but nothing...

WoWS connection error.png

This isn't the EU server forum it's the NA server forum.

If this is an alt NA account your distance to the EU server doesn't matter if you are trying to get on the NA server.

Other than that I'm no techie so can't give you any knowledgeable advice.

Share this post


Link to post
Share on other sites
7,345
[WORX]
Members
13,230 posts
20,094 battles

According to Jingles... Europe connectivity sucks at times...

I strongly recommend a 5 min cold restart (that means without power) on your

  • PC
  • Modem
    • AND
  • Router.

After that procedure, do a check and repair in WGC...

This process usually fixes the problem.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×