Jump to content
You need to play a total of 20 battles to post in this section.
Rear_Admiral_Lower_Half

THIS PROBLEM IS RUINING MY WORLD OF WARSHIPS EXPERIENCE

12 comments in this topic

Recommended Posts

Members
35 posts
2,756 battles

So recently in the past few weeks I've been experiencing some problems with my game. 50% of the time my guns or torpedoes will have a 1 or 2 second delay from when I click my mouse to them actually firing. This makes playing ships with longer reload times and cvs especially painful because I will line up a good shot and click my mouse only for the guns to remain silent and then fire shells at where the enemy was 2 seconds before. Playing CVs is essentially impossible as my rockets or bombs will not drop where I want them to. Because this only happens randomly, I can't even compensate for this because I don't know when my shot will be delayed. I play World of Warships on a laptop which gets around 32 fps and 50 ping. My internet is fast, I average around 45-50 mbps. I've used this laptop for 2 years now and I've never had a problem until now. I've tried reinstalling the game and restarting the computer but the problem still remains. I've been playing less as a result, which could be a good thing actually. But does anyone know how to fix this problem or do you think my laptop cannot handle the game anymore. 

Share this post


Link to post
Share on other sites
684
[WOLF7]
Members
904 posts

As I have discovered, 32 FPS is a playble experience for a single-player offline game, but is much too slow for an MMO-style game. Try lowering your graphics settings and consider obtaining a desktop PC with a discrete graphics card.  

Share this post


Link to post
Share on other sites
Members
35 posts
2,756 battles

I agree. However, I have my graphics settings at low and it's worked fine for the past two years. The game itself still works fine, just my shots will randomly be delayed. Is there any way to troubleshoot something like this?

Share this post


Link to post
Share on other sites
684
[WOLF7]
Members
904 posts
6 minutes ago, Rear_Admiral_Lower_Half said:

I agree. However, I have my graphics settings at low and it's worked fine for the past two years. The game itself still works fine, just my shots will randomly be delayed. Is there any way to troubleshoot something like this?

The modstation has the ability to cap your framerate at 60 or 30 FPS (your choice) and also to compress the game's textures in order to get more performance. There's other things you can tweak there that might help you as well. All of the mods are certified and approved by WG. I use it and it improves my overall experience very much. Check it out:

https://worldofwarships.com/en/content/modstation/

Share this post


Link to post
Share on other sites
Members
35 posts
2,756 battles

 

2 minutes ago, HamAndCheez said:

The modstation has the ability to cap your framerate at 60 or 30 FPS (your choice) and also to compress the game's textures in order to get more performance. There's other things you can tweak there that might help you as well. All of the mods are certified and approved by WG. I use it and it improves my overall experience very much. Check it out:

https://worldofwarships.com/en/content/modstation/

I will try it out. Thank you!

Share this post


Link to post
Share on other sites
8,945
[GWG]
[GWG]
Alpha Tester
28,341 posts
14,924 battles
20 minutes ago, HamAndCheez said:

As I have discovered, 32 FPS is a playble experience for a single-player offline game, but is much too slow for an MMO-style game. Try lowering your graphics settings and consider obtaining a desktop PC with a discrete graphics card.  

Even 25 is fine as long as it isn't a FPS twitch game as long as the frame rate is steady.

12 minutes ago, Rear_Admiral_Lower_Half said:

I agree. However, I have my graphics settings at low and it's worked fine for the past two years. The game itself still works fine, just my shots will randomly be delayed. Is there any way to troubleshoot something like this?

They tweaked the graphics in the last patch which your machine apparently can't handle. Time to consider getting another machine.

Share this post


Link to post
Share on other sites
7,382
[WORX]
Members
13,334 posts
20,173 battles
45 minutes ago, Rear_Admiral_Lower_Half said:

I agree. However, I have my graphics settings at low and it's worked fine for the past two years. The game itself still works fine, just my shots will randomly be delayed. Is there any way to troubleshoot something like this?

Whatever you got away with last patch, doesn't mean it will carry over to this patch.

If you have a graphics card that is being overwhelmed, then sooner or later its going to be time to replace it.

It sounds to me it can be a combination of components that is contributing to the problem. For example, its Summer, the excess heat causes computers to over heat... The over heating causes a decrease in performance.

Last patch, I played on very high graphics setting.. Recently, my system had to go to the repair shop... Now I toned it down to HIGH setting..

Without knowing your situation.. Keep in mind, in every patch. Your PC performance will decline... If you're on the borderline, you're going to fear is the next patch can be your last...


It can also mean your ISP, is taking to long to route your response to the WOWS servers. The only way to find out is to test it with playing on a VPN.

Edited by Navalpride33

Share this post


Link to post
Share on other sites
Members
35 posts
2,756 battles
13 minutes ago, Navalpride33 said:

Whatever you got away with last patch, doesn't mean it will carry over to this patch.

If you have a graphics card that is being overwhelmed, then sooner or later its going to be time to replace it.

It sounds to me it can be a combination of components that is contributing to the problem. For example, its Summer, the excess heat causes computers to over heat... The over heating causes a decrease in performance.

Last patch, I played on very high graphics setting.. Recently, my system had to go to the repair shop... Now I toned it down to HIGH setting..

Without knowing your situation.. Keep in mind, in every patch. Your PC performance will decline... If you're on the borderline, your fear is the next patch can be your last...


It can also mean your ISP, is taking to long to route your response to the WOWS servers. The only way to find out is to test it with playing on a VPN.

Thank you for your input, I think it may be time for me to get a better pc.

Share this post


Link to post
Share on other sites
684
[WOLF7]
Members
904 posts
7 minutes ago, Rear_Admiral_Lower_Half said:

Thank you for your input, I think it may be time for me to get a better pc.

PM me if you are on a tight budget like I am and need some suggestions. 

Share this post


Link to post
Share on other sites
4,734
[WOLFG]
Members
12,695 posts
11,804 battles
2 hours ago, BrushWolf said:

Even 25 is fine as long as it isn't a FPS twitch game as long as the frame rate is steady.

They tweaked the graphics in the last patch which your machine apparently can't handle. Time to consider getting another machine.

I didn't even notice it till yesterday that the fire and flooding effects were back on.

Share this post


Link to post
Share on other sites
Members
12,615 posts
14,320 battles
4 hours ago, Rear_Admiral_Lower_Half said:

So recently in the past few weeks I've been experiencing some problems with my game. 50% of the time my guns or torpedoes will have a 1 or 2 second delay from when I click my mouse to them actually firing. This makes playing ships with longer reload times and cvs especially painful because I will line up a good shot and click my mouse only for the guns to remain silent and then fire shells at where the enemy was 2 seconds before. Playing CVs is essentially impossible as my rockets or bombs will not drop where I want them to. Because this only happens randomly, I can't even compensate for this because I don't know when my shot will be delayed. I play World of Warships on a laptop which gets around 32 fps and 50 ping. My internet is fast, I average around 45-50 mbps. I've used this laptop for 2 years now and I've never had a problem until now. I've tried reinstalling the game and restarting the computer but the problem still remains. I've been playing less as a result, which could be a good thing actually. But does anyone know how to fix this problem or do you think my laptop cannot handle the game anymore. 

 

4 hours ago, HamAndCheez said:

As I have discovered, 32 FPS is a playble experience for a single-player offline game, but is much too slow for an MMO-style game. Try lowering your graphics settings and consider obtaining a desktop PC with a discrete graphics card.  

In addition to this^ try having hardwired internet connection instead of WiFi, as that can easily account for a second or 2 of lag time sometimes.

Share this post


Link to post
Share on other sites
387
[NWOC]
[NWOC]
Members
1,063 posts
14,884 battles
6 hours ago, Rear_Admiral_Lower_Half said:

So recently in the past few weeks I've been experiencing some problems with my game. 50% of the time my guns or torpedoes will have a 1 or 2 second delay from when I click my mouse to them actually firing.

Also been having this problem, tho only about 20% of the time, since last patch. My desktop and monitor are plenty powerful enough to handle WOW's.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×