Jump to content
Sign in to follow this  
You need to play a total of 20 battles to post in this section.
FatalAsylym

Bismarck Camo's no longer showing

4 comments in this topic

Recommended Posts

Members
2 posts
456 battles

I had access to both permanent Bismarck skins when completing the missions for them earlier last month. Now, when I have them equipped, they no longer show up on her. It says Display of Imitation Camos disabled. Is there a way to get these skins back on my ship or am I screwed?

  • Boring 2

Share this post


Link to post
Share on other sites
3,068
[UNHLY]
Members
3,253 posts
25,318 battles

Yeah just hit on enabled and it should go to enabled. 

Edited by tm63au

Share this post


Link to post
Share on other sites
329
[LANCE]
Members
897 posts
6,834 battles

Bottom right hand corner of port (little cog) there’s an option to turn off different camos. Make sure one of those isn’t affecting the display of the camo on your ship. I have anime and space/Halloween camp’s turned off so it maybe an option in there

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×