Jump to content
You need to play a total of 20 battles to post in this section.
WolfCmnders

Login Issues

2 comments in this topic

Recommended Posts

Members
2 posts
674 battles

having an issue, saying unable to connect, the server is out of date 

"The Current Version of the Game Is Older than that of the server. Please Update the client"

Share this post


Link to post
Share on other sites
132
[WG]
WG Staff
360 posts
9,828 battles

Please make sure that you have the latest version of the game installed. That's the only reason why you can get that message

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×