Jump to content
Sign in to follow this  
You need to play a total of 20 battles to post in this section.
ZARDOZ_II

World of Disconnects

4 comments in this topic

Recommended Posts

1,128
[4HIM]
Members
3,287 posts
15,596 battles

Getting DC'd about every 4th or 5th game now.  Earlier, I played for hours no problem.  Started playing the Makarov for the bonus missions.  Every Makarov game was a DC.  Play other ships, no problem.  Load up the Mak,  DC mid game.  4 for 4 on DC's.  This is getting old. 

  • Boring 1

Share this post


Link to post
Share on other sites
3,480
[O_O]
Members
7,038 posts
17,376 battles

I honestly don't think this is a WG problem.  I think it is likely a problem either on your hardware or with your internet provider. 

I have two homes...one with my new PC and best internet, and one with my old PC and an internet provider I am not pleased with.  With my best internet and best PC, I have zero problems with the WoWS servers.  At my second place I have also struggled with frequent disconnects...even when I brought my new PC down here.  So, I blame my internet provider's inconsistent service for gaming needs.

WoWS gets more resource intensive as time goes on.  What may have been adequate in the past may not be adequate with the next patch.  If your PC is solid, I would look at your internet provider.  We can stream movies and internet just fine, but for some reason my second internet just can't seem to reliably sustain internet gaming without disconnects.

Edited by desmo_2

Share this post


Link to post
Share on other sites
1,128
[4HIM]
Members
3,287 posts
15,596 battles

Just found it odd.  More DC's yesterday than the past 6 months combined.  Need to keep looking and see if I can find the issue.  

Sure was frustrating.

Share this post


Link to post
Share on other sites
7,346
[WORX]
Members
13,240 posts
20,094 battles
4 minutes ago, ZARDOZ_II said:

Just found it odd.  More DC's yesterday than the past 6 months combined.  Need to keep looking and see if I can find the issue.  

Sure was frustrating.

Disconnects, it could be time to update your (CPU/GPU) Drivers.

Start there First.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×