Jump to content
You need to play a total of 20 battles to post in this section.
SchrodingersPanda

"Could not load system resources"

6 comments in this topic

Recommended Posts

Beta Testers
119 posts
11,408 battles

Hi guys

Due to the current circumstances many of us are experiencing I'm stuck with only my old laptop, my trusty desktop one lockdown away from my desperate self. I remember installing WoWS at some point last year in my laptop, and other than playing at min settings the game ran just fine.

But now I've reinstalled and shortly after launching the game, I have at most one minute interacting with the UI before the game freezes/crashes with the message "Could not load system resources", as the same message suggests, I run a check and repair of the game client with no problems, but the issue persists. Also tried clean reinstall, and deleting preferences.xml as other forum posts suggests to no avail.

I'm really out of ideas regarding what to do, my system specs are as follows:

(It's an OLD laptop, remember that)

Laptop Model: Dell Latitude E6320

  • CPU: i5 2520M
  • RAM: 8 GB DDR3 single channel
  • Graphics: Intel HD 3000
  • Storage: 256 GB SSD (Samsung PM810)

I would really appreciate any help regarding this problem, cheers.

Share this post


Link to post
Share on other sites
132
[WG]
WG Staff
360 posts
9,828 battles

@SchrodingersPandaI'm sad to be a bearer of sad new but according to the currently posted minimum requirements, your Graphics adapter is below minimum requirements. Intel HD Graphics 3000 is internal videocard that was decent for some gaming back in 2011 when it was first introduced but in the modern world it's outdated.

Share this post


Link to post
Share on other sites
2,462
[USRUS]
[USRUS]
Members
1,681 posts
21,698 battles

Your laptop no longer meets the minimum requirements to run the game. 

Share this post


Link to post
Share on other sites
0
[CTTDS]
Members
4 posts
12,381 battles

I just started with the same issue. The game ran fine Sunday, yesterday I go to open the game and a little window pops up saying "the Wargaming.net Game Center is required. I cannot download it, I cannot uninstall the game to see if reinstalling it will cure the issue. All I have gotten from the help center is it's not their fault. I give up.

Share this post


Link to post
Share on other sites
[JSG]
Members
1 post
5,043 battles

So is a pretty middle finger to old graphics now? 

I love how Wargaming treats their player base/customers. 

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×