Jump to content
Sign in to follow this  
You need to play a total of 20 battles to post in this section.
Skyfaller

Armory for several patches now takes forever to load

13 comments in this topic

Recommended Posts

1,277
[ALL41]
Beta Testers
2,172 posts
9,416 battles

...and most of the times it just doesn't load. 

Strange that only this particular menu/shop gets mired while all others load quickly. 

  • Cool 1

Share this post


Link to post
Share on other sites
1,706
[WDS]
[WDS]
Members
3,563 posts
11,141 battles

There all slow now pretty much but the armory was the first one I noticed it on .

That was last patch or maybe even 2 patches ago .

Share this post


Link to post
Share on other sites
287
[SACH]
[SACH]
Members
989 posts

Mine used to load, now it just sits there while loading icons twirl in the wind in an endless load screen .

Outstanding. !!!!

  • Cool 2

Share this post


Link to post
Share on other sites
353
[PVE]
Members
1,441 posts
39,232 battles
2 minutes ago, Versili said:

Mine used to load, now it just sits there while loading icons twirl in the wind in an endless load screen .

Outstanding. !!!!

THIS

  • Cool 1

Share this post


Link to post
Share on other sites
1,706
[WDS]
[WDS]
Members
3,563 posts
11,141 battles
7 minutes ago, Versili said:

Mine used to load, now it just sits there while loading icons twirl in the wind in an endless load screen .

Outstanding. !!!!

Wait like 20 seconds while it's spinning and then move you mouse around on the screen and it will open found this out by accident.

  • Cool 1

Share this post


Link to post
Share on other sites
3,352
[WOLFG]
Members
9,556 posts
8,489 battles
1 hour ago, clammboy said:

Wait like 20 seconds while it's spinning and then move you mouse around on the screen and it will open found this out by accident.

That's what I do.

Share this post


Link to post
Share on other sites
287
[SACH]
[SACH]
Members
989 posts
4 hours ago, clammboy said:

Wait like 20 seconds while it's spinning and then move you mouse around on the screen and it will open found this out by accident.

I'll try it tonight but I think is a sinking ship ....ohh I mean a dead horse . .lol

Share this post


Link to post
Share on other sites
287
[SACH]
[SACH]
Members
989 posts
10 hours ago, clammboy said:

Wait like 20 seconds while it's spinning and then move you mouse around on the screen and it will open found this out by accident.

25 min later yawwwn .....:cap_old:

 

2020-06-11 23.55.53.jpg

Share this post


Link to post
Share on other sites
1,706
[WDS]
[WDS]
Members
3,563 posts
11,141 battles
4 hours ago, Versili said:

25 min later yawwwn .....:cap_old:

 

2020-06-11 23.55.53.jpg

Yea sorry but everting at the moment is taking a long time to load it’s quite annoying  .  Even the game is taking so long to load each time now . 

Share this post


Link to post
Share on other sites
Members
93 posts
13,692 battles

I haven't been able to load the ships in the Armory since the last update, please..?

image.thumb.png.9694e13012e56e3841464e8d584a94a3.png

Share this post


Link to post
Share on other sites
47
[JHF]
Members
373 posts
8,067 battles

whoever thought this change was a good idea needs to be fired.
Everything load except the ships....

Edited by Hydra_360ci

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×