Jump to content
You need to play a total of 20 battles to post in this section.
TadpoleFishTaco

Game performance declines with every patch/update

8 comments in this topic

Recommended Posts

44
[GGWP]
Members
67 posts
2,765 battles

My computer could run the game perfectly fine for the longest time. Then the Hayate patch came and it went from loading me into games 20 seconds before they began to me being lucky if I loaded in 5 seconds after they started. My FPS became very inconsistent. When I pre-downloaded update 9.5 my performance got even worse. I could barely load anything, in port, in the armory, etc. It took me 30 seconds to a minute to load into all of the games I played last night. This morning, the problem persisted and I couldn't even load the Dockyard. I closed it and booted up the 32 bit version and now its back to the performance that I got after the Hayate patch, but I used to be able to run it so much more smoothly.

I'm aware that my computer is not an optimal gaming one, it's just an ASUS laptop that's a few years old. My audio and graphics settings are turned to the minimum.

 

Can someone help me? Is there something I can do or do I just need to save up and buy a new computer if I want the performance I used to get?

Share this post


Link to post
Share on other sites
5,792
[WORX]
Members
10,631 posts
18,519 battles
1 minute ago, TadpoleFishTaco said:

 

Can someone help me? Is there something I can do or do I just need to save up and buy a new computer if I want the performance I used to get?

Unfortunately, WG is bent on improving their graphics engine capabilities... That means more resource  toll on your machine... I recommend using the training room and use custom graphics to see what works...

If you dont like the results, then I recommend its time for a upgrade on your PC...

Depending on market place of your area... A decent 2 to 4 year WOWS dedicated machine will set you back a $1,000 to $1,500.

Maximum $2,000.

IF you need PC advice dont hesitate to ask me or @Snargfargle When he returns from mourning.

GL

 

Share this post


Link to post
Share on other sites
Beta Testers
84 posts
777 battles
1 hour ago, Navalpride33 said:

Unfortunately, WG is bent on improving their graphics engine capabilities... That means more resource  toll on your machine... I recommend using the training room and use custom graphics to see what works...

If you dont like the results, then I recommend its time for a upgrade on your PC...

Depending on market place of your area... A decent 2 to 4 year WOWS dedicated machine will set you back a $1,000 to $1,500.

Maximum $2,000.

IF you need PC advice dont hesitate to ask me or @Snargfargle When he returns from mourning.

GL

 

2000$? are you advertising for alienware?

Share this post


Link to post
Share on other sites
15
[BRSI]
Members
76 posts
3,036 battles

I have the same issue. I take a performance hit every update. I keep my FPS locked at 50, and I got 50 pre-update, now I get 25. Nothing else on my system has changed.

Edited by MollyGodiva
More details.

Share this post


Link to post
Share on other sites
5,792
[WORX]
Members
10,631 posts
18,519 battles
8 minutes ago, Battlecruiser said:

2000$$2,000? are you advertising for alienware?

No, I am being realistic to the possibilities based on his local market prices for PC parts... Prices may vary  depending on location.

The final price will depend on his choices AND the prices locally... $1,000 was being generous... I calculate $1,200 minimum...

Depending in where you are and the current pandemic situation... You can reach $2,000 easy...

Now, if you want a short term junk solution, Their are $500 to $900 options... Then in 6 to 9 months from now, he will start looking for replacement again...

 

Edited by Navalpride33

Share this post


Link to post
Share on other sites
114
[WG]
Developers
344 posts
9,697 battles

I'd recommend submitting a ticket to CS. Normally they focus on resolving technical issues but they can also provide recommendations on how you can boost the performance of your machine. 

The key here is the spec of your PC. You've mentioned that it's "an ASUS laptop that's a few years old" but many laptops were not designed for gaming in the first place. While they may have decent CPU and RAM, very often they have internal GPU onboard that is designed normally for HD video playback and some light gaming. 

So, submit a ticket, attach WGCheck report and ask them to help.  That's the best advice I can give right now.

Share this post


Link to post
Share on other sites
260
[APES]
Members
985 posts
6,295 battles

I'm having the same problems. Longer loading screen, more crashed, more system resource usage. Nowadays if I use software to limit the resources that the game uses, it even crashes on me.

Share this post


Link to post
Share on other sites
334
[OGRES]
[OGRES]
Beta Testers
681 posts
17,688 battles

Something has been left un-optimized.  I have noticed some less than smooth game play lately and last night I happened to bring up my afterburner overlay and my 1070ti was running at 80c. 

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×