Jump to content
You need to play a total of 20 battles to post in this section.
Skyspartan

Game stuck in loading screen

4 comments in this topic

Recommended Posts

265
[RAIN]
Members
284 posts
9,659 battles

this suddenly happened when i updated my mods for 9.5

Share this post


Link to post
Share on other sites
7,382
[WORX]
Members
13,334 posts
20,173 battles
7 minutes ago, Skyspartan said:

this suddenly happened when i updated my mods for 9.5

Do a 5 min cold restart of

  • Modem *dont reset it* just turn off the power
  • Router  *same*
  • PC...

From there, do a "check and repair" and restart again...

This process usually clears up about %90 of the turning circle or stuck at loading screen situations.

Share this post


Link to post
Share on other sites
247
[TFLT]
[TFLT]
Beta Testers, In AlfaTesters
815 posts
26 minutes ago, Skyspartan said:

this suddenly happened when i updated my mods for 9.5

MODS Loaded?  Try Safe Mode...

Share this post


Link to post
Share on other sites
265
[RAIN]
Members
284 posts
9,659 battles
20 minutes ago, Navalpride33 said:

Do a 5 min cold restart of

  • Modem *dont reset it* just turn off the power
  • Router  *same*
  • PC...

From there, do a "check and repair" and restart again...

This process usually clears up about %90 of the turning circle or stuck at loading screen situations.

thanks  but the restarted didnt help

i need to re download the updated mods for some reason but problem solved! 

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×