Jump to content
Sign in to follow this  
You need to play a total of 20 battles to post in this section.
Prof_Fate

Why did I bother pre-install

7 comments in this topic

Recommended Posts

41
[TBB]
Beta Testers
184 posts
10,636 battles

Two days ago I did the pre-install for todays patch...took awhile to complete.  Now, the game is wanting to download and install it all over again.

I'm so glad I was forced to install the game center *sarcasm*

  • Cool 2

Share this post


Link to post
Share on other sites
4,457
[PVE]
Members
11,072 posts
19,193 battles
51 minutes ago, Prof_Fate said:

Two days ago I did the pre-install for todays patch...took awhile to complete.  Now, the game is wanting to download and install it all over again.

I'm so glad I was forced to install the game center *sarcasm*

WGC pre-downloads most of the update so it doesn't take as long to get the rest and install on the release day. It's mostly for people with slow internet and slow computers. It took me less than 5 minutes to pre-download and then about 2 minutes for it to finalize the download and install today. If it is that slow for you you can check your settings and make sure you are downloading at a decent pace.

 

Share this post


Link to post
Share on other sites
1,007
[NSC]
Members
2,347 posts
11 minutes ago, Sovereigndawg said:

WGC pre-downloads most of the update so it doesn't take as long to get the rest and install on the release day. It's mostly for people with slow internet and slow computers. It took me less than 5 minutes to pre-download and then about 2 minutes for it to finalize the download and install today. If it is that slow for you you can check your settings and make sure you are downloading at a decent pace.

RE: settings

@Prof_Fate Did you check "Use all computer resources during installation" and set "Download speed" to "Unlimited"?

image.thumb.png.a2cc978aa75f28d59ce22ff1e244b13f.png

Edited by henrychenhenry

Share this post


Link to post
Share on other sites
41
[TBB]
Beta Testers
184 posts
10,636 battles
1 hour ago, henrychenhenry said:

RE: settings

@Prof_Fate Did you check "Use all computer resources during installation" and set "Download speed" to "Unlimited"?

image.thumb.png.a2cc978aa75f28d59ce22ff1e244b13f.png

Its set to unlimited and the box is checked

Share this post


Link to post
Share on other sites
17
[AKN]
Members
30 posts
8,306 battles

its nice that it took you less then 10 min to download and install the update....every update it takes mine over 4 hours to just install and most of the time for over an hour it stays at 39% and slows everything down...its just not this update its every update

Share this post


Link to post
Share on other sites
132
[WG]
WG Staff
360 posts
9,828 battles
4 hours ago, WoWShoea said:

it takes mine over 4 hours to just install and most of the time for over an hour it stays at 39% and slows everything down

That doesn't sound right. I hope a friendly CS agent can help you with that. All you need is to submit a ticket. 

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×