Jump to content
d_gladkov

WoWS Mac Wrapper Bugs and Feedback Thread

73 comments in this topic

Recommended Posts

Administrator
293 posts
10 battles

Hello Captains!

We hope that you are excited to get into the Mac Wrapper, enabling you to play World of Warships on your Mac system. 

First, we would like to remind you that the Mac Wrapper is still in its testing phase. This means that there is a very limited amount of support we can offer for the Wrapper and client within.

Do not alter or remove files from the Wrapper itself. These files that you see when you "View Package Contents" are reference files only. They are used to call to the actual files that are updated properly.

To download the Wrapper, follow this link: LINK (download is for the Mac WGC)

Wrapper 3.3.6 finally released and ready for download
 


DOWNLOADING WORLD OF WARSHIPS:

When you have finished downloading the Wrapper and launch it for the first time, the World of Warships Launcher will pop up and begin to download the game. Currently this the only way to install World of Warships onto your Mac. Files are being placed in a specific file system and currently cannot be dropped in.

Once the game client is downloaded, you can log in and play just like Windows World of Warships. You are on the same servers and using the same ships and controls as the Windows client users.
 


In order to install World of Warships Public Test client you have to click on the World of Warships tab in the WGC, click the Game Settings button, click the "Install Addition Instance" checkbox - this will bring up a dialog that allo ws an additional instance. Then select Public Test from the drop-down in the upper left corner of the dialog, ensure the path you want to install to is clear (the default works nicely), then click "Install" to finish.


 

How to fully uninstall the game and WGC:

Spoiler

 

STEP 1: 

Click on this link. For the access code, type in "oem". Unzip it and click on the application. You should get an immediate notification on the top left of your screen saying all Wargaming files have been moved to the trash.   

  On 12/27/2019 at 10:19 PM, kishan99 said:

https://www.codeweavers.com/xfer/uninstaller-oem/Wargaming-Center-delete-script.zip  using the access code 'oem'. Unzip it if that doesn’t happen automatically. Your computer will most likely block the script from running the first time you try to open it. If this does happen, you can get around that by opening System Preferences > Security and Privacy and clicking on the Open Anyway button near the bottom of the window.

Step 2: Go to your trash and empty it. 

Step 3: Click on your desktop make sure on the top of the screen, it says "Finder".   On the top of your screen, select "Go".   Then, "Go to Folder".   In the blank space, type in "~/Library".    Then hit enter.  Click on the Application Support Folder.  Then find the World of Warships Folder and drag that into the trash. On the same screen, find the Wargaming.net Game Center folder and drag that into the trash.  

Step 4: Go to the Applications folder and if you see the WarGaming Application, drag that to the trash. MAKE SURE YOU DON'T OPEN IT, OTHERWISE, YOU NEED TO RESTART THIS WHOLE PROCESS AGAIN

Step 5: Empty the trash

Step 6: Restart computer

Step 7: Make sure you are running MAC OS CATALINA. Yes, the game does run on it fine. If it isn't on Catalina, I am sure this fix still works but better be safe than sorry.

Step 8: Go to Wargaming Website and install client and install Wows. When download and in game, change the graphic settings to "Very Low"

Step 9: Destroy them ships Captain!

 


"Is there a way to play a replay on the Mac?"

Spoiler

There is a way but not so easy one. You need to use Terminal application and know where are your replays and client are stored. There is an example how to run the replay on NA client:

/Applications/Wargaming.net\ Game\ Center.app/Contents/SharedSupport/wargaminggamecenter/Wargaming.net\ Game\ Center/wine ~/Documents/Wargaming.net\ Games/World_of_Warships_NA/WorldOfWarships.exe ~/Documents/Wargaming.net\ Games/World_of_Warships_NA/replays/20191209_100928_PASC510-Alaska_42_Neighbors.wowsreplay


Where:

/Applications/Wargaming.net\ Game\ Center.app/Contents/SharedSupport/wargaminggamecenter/Wargaming.net\ Game\ Center/wine - WGC wrapper

~/Documents/Wargaming.net\ Games/World_of_Warships_NA/WorldOfWarships.exe - path to WorldOfWarships.exe of your game client

~/Documents/Wargaming.net\ Games/World_of_Warships_NA/replays/20191209_100928_PASC510-Alaska_42_Neighbors.wowsreplay - path to you replay file that you want to run on the client above

Previous topic locked and left here not to lose any useful information [archive] WoWS Mac Wrapper Bugs and Feedback Thread

Support is already fully engaged in working with users' issues on this topic. You may use both options to find the answer.
 

Share this post


Link to post
Share on other sites
219
[OVRPN]
Members
730 posts

Since this thread is being started anew please post again the instructions to perform a full delete of the software.

Share this post


Link to post
Share on other sites
Administrator
293 posts
10 battles
7 hours ago, fourteenfour said:

Since this thread is being started anew please post again the instructions to perform a full delete of the software.

Done :)

  • Cool 1

Share this post


Link to post
Share on other sites
251
[SLDS]
Members
801 posts
6,072 battles

@d_gladkov - Dmitri, did we archive the old thread?  There was some useful information in there still.  E.g. how to run a replay on a Mac.  Maybe we could create a new thread with useful 'How-tos' for Macs.


Thank you, the answer about "how to run replay on Mac" was added to the topic.
turbo07

  • Cool 1

Share this post


Link to post
Share on other sites
Community Department
3,296 posts
1,296 battles
18 hours ago, JAKeller said:

@d_gladkov - Dmitri, did we archive the old thread?  There was some useful information in there still.  E.g. how to run a replay on a Mac.  Maybe we could create a new thread with useful 'How-tos' for Macs.

I've moved the topic back to the subforum so one may easily find all the info there and we may continue working with reports and posting how-tos here. 
Thank you for your reply and feedback.

Share this post


Link to post
Share on other sites
Members
1 post
337 battles

Hi! 

Recently downloaded the game on a mid 2015 MacBook Pro and the game launches fine except for these weird graphic texture glitches  which pop up mid game that make it impossible to play. Haven't had one match since I've downloaded the game that did not suffer from one of these glitches one way or another. I have all the settings and low and turned off graphics switching in system preferences. My Mac is running on Mojave (10.14.6) and with a AMD Radeon R9 M370X 2 GB GPU. Is this a hardware issue?

 

Thanks!

Screen Shot 2020-05-02 at 01.33.00.png

Share this post


Link to post
Share on other sites
366
[DUD]
Members
706 posts
2,460 battles

Looks like today is the day it failed..   I will try my fix on completely deleting everything and starting over

719192543_ScreenShot2020-05-02at9_38_42PM.thumb.png.36bd68df221eeb0ad3b12c7044a5c14d.png

Share this post


Link to post
Share on other sites
366
[DUD]
Members
706 posts
2,460 battles

For those suffering from the current desync issues, please do the following and sent the info to WG support:

 

We need a PingPlotter report to have a look at what may cause the desync problem:
- please install the following program: https://www.pingplotter.com/download/macos
- close all the applications, including messengers, browser, mail client and so on;
- Launch the application and maximize the dialog window.
- Type the following address into the field "Address to Trace":
login1.worldofwarships.com
- Set 1 second in the field "Trace Interval."
- Press the "Trace" button or the "Enter" button.
- Let the Trace run for at least 30 minutes.
- Share the results by pressing File > Share > Create Share Page.

-Make a WG support Ticket
- Copy the link to this page into your reply.

Share this post


Link to post
Share on other sites
Administrator
293 posts
10 battles
On 5/2/2020 at 9:55 AM, CalvinF14 said:

Hi! 

Recently downloaded the game on a mid 2015 MacBook Pro and the game launches fine except for these weird graphic texture glitches  which pop up mid game that make it impossible to play. Haven't had one match since I've downloaded the game that did not suffer from one of these glitches one way or another. I have all the settings and low and turned off graphics switching in system preferences. My Mac is running on Mojave (10.14.6) and with a AMD Radeon R9 M370X 2 GB GPU. Is this a hardware issue?

 

Thanks!

Could you please check have you disabled these options?

1. Dynamic lighting -> OFF

2. Shadow Quality -> OFF

Share this post


Link to post
Share on other sites
19
[FE]
Members
61 posts
2,249 battles

Is any progress occurring on the bug that occasionally sees the game crash at the end of the battle just as the victory/defeat splash screen and info comes up?  If that bug could be squashed, then I wouldn't have anything to complain about.  Oh, I guess I could complain about the dynamic lighting and shadows not being usable, but I don't really miss those.

Thanks for any info you can provide

 

 

Edited by _SeaDoug_
typos

Share this post


Link to post
Share on other sites
Administrator
293 posts
10 battles
12 hours ago, _SeaDoug_ said:

Is any progress occurring on the bug that occasionally sees the game crash at the end of the battle just as the victory/defeat splash screen and info comes up?  If that bug could be squashed, then I wouldn't have anything to complain about.  Oh, I guess I could complain about the dynamic lighting and shadows not being usable, but I don't really miss those.

Thanks for any info you can provide

Yes, it should be fixed in 0.9.5 that will be released in 4 weeks. I hope it will be fixed there =)

Share this post


Link to post
Share on other sites
Administrator
293 posts
10 battles

Please check crash issues on Public Test client. It is 0.9.5 version with crash fix (I hope) =)

Share this post


Link to post
Share on other sites
219
[OVRPN]
Members
730 posts
On 5/21/2020 at 4:17 AM, d_gladkov said:

Please check crash issues on Public Test client. It is 0.9.5 version with crash fix (I hope) =)

Nope. Went boom at end of match,  worse is I had to force quit as Terminate/Restart from dialog box did not function. Will try again

WorldOfWarships64-2020-05-22_09-17-09.crash

Edited by fourteenfour

Share this post


Link to post
Share on other sites
Administrator
293 posts
10 battles
On 5/22/2020 at 4:19 PM, fourteenfour said:

Nope. Went boom at end of match,  worse is I had to force quit as Terminate/Restart from dialog box did not function. Will try again

WorldOfWarships64-2020-05-22_09-17-09.crash

We have added more logs. Hope it will help us understand where the issue is =)

Logs will be added in the second version of PT 0.9.5

Share this post


Link to post
Share on other sites
3
[BWN]
Members
60 posts
3,401 battles

For me I do follow instruction's. even when building a XXX model ship with brass and people that need to be in a model display. but when I follow the rules in the WOWS. you dont get times that you are ok and feel you been had, but I play becuase of the love to the subject and the only way to take a break form idiots that dont give you fair chance in working as a artist,

 

Για μένα κάνω ακολουθήσει τις οδηγίες. ακόμη και κατά την κατασκευή ενός xxx σκάφους μοντέλο με ορείχαλκο και τους ανθρώπους που πρέπει να είναι σε μια οθόνη μοντέλο. αλλά όταν ακολουθώ τους κανόνες στο WOWS. δεν παίρνετε φορές που είστε εντάξει και αισθάνονται ότι είχε, αλλά παίζω λόγω της αγάπης για το θέμα και ο μόνος τρόπος για να λάβει ένα διάλειμμα ηλίθιοι μορφή που δεν σας δίνουν δίκαιη ευκαιρία να εργάζονται ως καλλιτέχνης,

 

Für mich folge ich dem Anweisungen. auch beim Bau eines XXX-Modellschiffs mit Messing und Personen, die in einer Modellanzeige sein müssen. aber wenn ich die Regeln in der WOWS befolge. Sie bekommen keine Zeiten, die Sie in Ordnung sind und das Gefühl, Sie hatten, aber ich spiele wegen der Liebe zum Thema und der einzige Weg, um eine Pause Form Idioten, die nicht geben Ihnen faire Chance in der Arbeit als Künstler,

 

Для меня я следовать инструкции. даже при создании XXX модель корабля с латуни и людей, которые должны быть в модели дисплея. но когда я следую правилам в WOWS. Вы не получите раз, что вы в порядке и чувствую, что вы были, но я играю из-за любви к этому вопросу и единственный способ взять перерыв форме идиотов, которые не дают вам шанс в работе в качестве художника,

 

私のために私は指示に従います。真鍮とモデルディスプレイにする必要がある人々とXXXモデル船を構築する場合でも。しかし、私はWOWSのルールに従うとき。あなたは大丈夫で、あなたが持っていたと感じる時間を得ることはありませんが、私は主題への愛とアーティストとして働く公正な機会を与えない休憩フォームのバカを取る唯一の方法のために遊びます。

 

ok??

 

 

 

 

Share this post


Link to post
Share on other sites
19
[FE]
Members
61 posts
2,249 battles

What is the latest on using Replay on a Mac?  Is this possible now?  If so, could someone provide some instructions?

 

Thanks!

Share this post


Link to post
Share on other sites
Administrator
293 posts
10 battles
12 hours ago, _SeaDoug_ said:

What is the latest on using Replay on a Mac?  Is this possible now?  If so, could someone provide some instructions?

 

Thanks!

Instruction is in the first message under:

"Is there a way to play a replay on the Mac?"

Share this post


Link to post
Share on other sites
19
[FE]
Members
61 posts
2,249 battles

Hi Gladkov,

I think I found the instructions you referenced, but that's a pretty complicated process.  Are there any plans to provide similar replay functionality to what PC user's have in the foreseeable future?

 

Thanks!

Share this post


Link to post
Share on other sites
Members
69 posts
7,487 battles

Has anyone else had problems getting the dockyard gui to load? I've been able to get the dockyard itself to load, but never the interface no matter how long I wait. it just seems to get stuck like this.

Screen Shot 2020-06-10 at 10.22.52 AM.png

Share this post


Link to post
Share on other sites
219
[OVRPN]
Members
730 posts

Same here, stuck in dock yard and it took it a long time to load.

 

First time in I had to kill the game through Activity Monitor, second time in and while I have a nice looking dock there is nothing to click but I was able to Escape out .. well mostly.

 

oddly I can see the purchase pop up only after pressing Escape... and of course its gone just as quick

 

now it just is random what happens but never an option to purchase, random as in sometimes the dock loads, some times it does not, some times it loads with a permanent WG update icon, and sometimes it loads but I have to kill the process.

 

However eventually and I do mean quite a bit of waiting it finally arrived at the purchase option. I am assuming it was loading resources but not telling me as mu

Edited by fourteenfour

Share this post


Link to post
Share on other sites
Members
69 posts
7,487 battles

I may have found a temporary work around, although it's still pretty inconsistent. If you go up to the top right corner where the escape icon normally is, you can move around until it brings up the information for the escape icon ("click to exit" or something like that). If you *right* click it seems to bring up the gui at least some of the time.

Share this post


Link to post
Share on other sites
0
[YIFFY]
Members
1 post
2,000 battles

I found a post on the EU forum indicating the dockyard not loading was an issue in general. The patch requires running a bat file that had incorrect syntax for a Mac though and after attempting to manually do the steps in the file it did not appear to work. 

Share this post


Link to post
Share on other sites
219
[OVRPN]
Members
730 posts

FWIW - I can get the dock yard controls to display if I tab/swap back to my desktop and swap back, just for safety sake when I do I bring something new up like browsing a web page before tabbing back

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×