Jump to content
Sign in to follow this  
You need to play a total of 20 battles to post in this section.
Sabot_100

Seconds count!

5 comments in this topic

Recommended Posts

1,465
[CVA16]
Members
6,468 posts
20,080 battles

In Mogador, swinging around to bring my port tubes to bear on an Amalfi at point blank range. I see I will pass in front of him but will  likely get rammed. The more I turn, the more definite the collision becomes. I fire my forward tubes at near minimum arming range as soon as I have the shot. All three torps hit, killing the ship. As I pass the now dead Amalfi still rams into my port side for no damage. Glad I didn't need a tick or so of flooding to kill him. 

Strange game mechanics that a live ship collision will kill you but a hitting (being hit by) the same ships wreck only bounces you a bit.

Share this post


Link to post
Share on other sites
1,465
[CVA16]
Members
6,468 posts
20,080 battles

Of course, lucky for me running aground doesn't do damage either. Otherwise I'd sink myself some games.

 

Share this post


Link to post
Share on other sites
314
[ICOP]
Members
455 posts
18,430 battles
On 4/19/2020 at 11:47 AM, Sabot_100 said:

In Mogador, swinging around to bring my port tubes to bear on an Amalfi at point blank range. I see I will pass in front of him but will  likely get rammed. The more I turn, the more definite the collision becomes. I fire my forward tubes at near minimum arming range as soon as I have the shot. All three torps hit, killing the ship. As I pass the now dead Amalfi still rams into my port side for no damage. Glad I didn't need a tick or so of flooding to kill him. 

Strange game mechanics that a live ship collision will kill you but a hitting (being hit by) the same ships wreck only bounces you a bit.

I had one just about like this today, but different ending.  I shoot at near minimum arming range, still in the green, and the torps don't arm and I'm dead.  So if this is lag, it's not "seconds" that count, it's "milliseconds" (about 35ms latency is what I average).

Share this post


Link to post
Share on other sites
1,465
[CVA16]
Members
6,468 posts
20,080 battles
5 minutes ago, Thunder_Feet said:

I had one just about like this today, but different ending.  I shoot at near minimum arming range, still in the green, and the torps don't arm and I'm dead.  So if this is lag, it's not "seconds" that count, it's "milliseconds" (about 35ms latency is what I average).

Had the same worry in the above mentioned encounter. Worried that by the time I got the port tubes to bear I would be too close.  I was 1-2 seconds from that when I fired and fortunately the torps were fast enough to get there before I did and sink him. So if I had waited (or been lagged) by a second the torps would not have armed and I would have been rammed and the Amalfi would have sailed by a bit worse for the wear.

 

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×