Jump to content
Sign in to follow this  
You need to play a total of 20 battles to post in this section.
Zkyzytuz

CRITICAL ERROR solved!

5 comments in this topic

Recommended Posts

225
[TRETA]
Beta Testers
954 posts
15,272 battles

 

UPDATE: The Nvidia hotfix solved the problem ! (see next post by turbo07)

 

   Hi guys. First of all, excuse me for grammatical errors or "estrange" phrases, i'm not a english native speaker. :cap_book:

  The purpose of this post is to help those who are having this same problem that occurred with me.

 

   After updating the Nvidia driver of my Geforce 2080 TI video card to the latest available, version 445.75, I was unable to enter the game, ALWAYS gave Critical Error at the entrance.

   I tried several things, in this sequence:

   1) I reinstalled the video card driver a second time;

   2) I ran the game in safe mode;

   3) I uninstalled the game and installed a new  game (without installing any mod).

 

   When I made option 3, the game went back to work! So i reconfigured the setups for my preference (including full screen), played it many times and left the game, thinking it was resolved.

   But when I tried to load the game again, it gave me the same problem: Critical Error at the entrance!

   I was suspicious  the graphics options I used (note that I had not yet installed any mods, that is, it had nothing to do with mods)

   So, deleted the preferences.xml file and ... Bingo! The game returned to normal loading!

   So, I reconfigured the setups  gain, but this time, I did NOT put the full screen. So, I left the game and loaded it again ... Bingo! It worked!

   That is: Setup for full screen mode causes the problem in the next game load. 

 

   But then we have another problem: Leaving in window mode is kind of boring because:

   1) The graphics card is ALWAYS rendering the game, so even if you leave the game, and even if you open another window and leave the game window behind or out of focus, the card will continue to be 100% in use, consuming a lot of energy and heating up. In full screen mode, this does not happen. And I often leave the game to do something else, or leave the PC for a while. And the 2080 TI eat a lot of energy...

   2) The behavior of the mouse when the game is in window mode is a bit boring, sometimes it leaves the game screen.

   3) On some graphics cards, window mode may lose performance.

 

What is the solution, then? Well, my suggestions:

1) Delete preferences.xml if the error occurs while loading the game. The annoying thing about this is that you will have to reconfigure all your preferences for graphics, sound, interface, keyboard, crosshairs and etc. And if you change a lot, it can be VERY BORING!

2) Before leaving the game, put it in window mode. When entering again, put full screen mode.

3) If you forget to change the mode before leaving the game, calm down! You don't need to delete preferences.xml. Before entering the game again, edit the preferences.xml file with notepad and find a line that starts with <windowMode>:

 <windowMode> 2 <windowMode>

The value 2 indicates full screen, so change it to 0 or 1, which is windowed:

 <windowMode> 0 <windowMode>

Save the file, load the game again and switch to full screen.

 

And finally, keep a backup copy of preferences.xml with all your usual options, whatever you need.

 

 

 

Edited by Zkyzytuz
  • Cool 1

Share this post


Link to post
Share on other sites
Community Department
3,314 posts
1,300 battles
1 hour ago, Zkyzytuz said:
Spoiler

 

   Hi guys. First of all, excuse me for grammatical errors or "estrange" phrases, i'm not a english native speaker. :cap_book:

  The purpose of this post is to help those who are having this same problem that occurred with me.

 

   After updating the Nvidia driver of my Geforce 2080 TI video card to the latest available, version 445.75, I was unable to enter the game, ALWAYS gave Critical Error at the entrance.

   I tried several things, in this sequence:

   1) I reinstalled the video card driver a second time;

   2) I ran the game in safe mode;

   3) I uninstalled the game and installed a new  game (without installing any mod).

 

   When I made option 3, the game went back to work! So i reconfigured the setups for my preference (including full screen), played it many times and left the game, thinking it was resolved.

   But when I tried to load the game again, it gave me the same problem: Critical Error at the entrance!

   I was suspicious  the graphics options I used (note that I had not yet installed any mods, that is, it had nothing to do with mods)

   So, deleted the preferences.xml file and ... Bingo! The game returned to normal loading!

   So, I reconfigured the setups  gain, but this time, I did NOT put the full screen. So, I left the game and loaded it again ... Bingo! It worked!

   That is: Setup for full screen mode causes the problem in the next game load. 

 

   But then we have another problem: Leaving in window mode is kind of boring because:

   1) The graphics card is ALWAYS rendering the game, so even if you leave the game, and even if you open another window and leave the game window behind or out of focus, the card will continue to be 100% in use, consuming a lot of energy and heating up. In full screen mode, this does not happen. And I often leave the game to do something else, or leave the PC for a while. And the 2080 TI eat a lot of energy...

   2) The behavior of the mouse when the game is in window mode is a bit boring, sometimes it leaves the game screen.

   3) On some graphics cards, window mode may lose performance.

 

What is the solution, then? Well, my suggestions:

1) Delete preferences.xml if the error occurs while loading the game. The annoying thing about this is that you will have to reconfigure all your preferences for graphics, sound, interface, keyboard, crosshairs and etc. And if you change a lot, it can be VERY BORING!

2) Before leaving the game, put it in window mode. When entering again, put full screen mode.

3) If you forget to change the mode before leaving the game, calm down! You don't need to delete preferences.xml. Before entering the game again, edit the preferences.xml file with notepad and find a line that starts with <windowMode>:

 <windowMode> 2 <windowMode>

The value 2 indicates full screen, so change it to 0 or 1, which is windowed:

 <windowMode> 0 <windowMode>

Save the file, load the game again and switch to full screen.

 

And finally, keep a backup copy of preferences.xml with all your usual options, whatever you need.

 

 

Thank you for your feedback. 
Did you try to download the fix for the driver here?

What were the results?

  • Cool 1

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×