Jump to content
Sign in to follow this  
You need to play a total of 20 battles to post in this section.
Timo_Greenwold

Stopping Microsoft windows updates

6 comments in this topic

Recommended Posts

50
[TASC]
Members
325 posts
11,378 battles

Any one know of a good way of stopping of these Windows downloads and updates. It makes my game play shutter. When the update installs, it crashes the computer and the windows goes back to earlier version. Using the setting options, does not work.

Share this post


Link to post
Share on other sites
240
Beta Testers, In AlfaTesters
1,063 posts

disable the update services?

Windows Update:  Enables the detection, download, and installation of updates for Windows and other programs. If this service is disabled, users of this computer will not be able to use Windows Update or its automatic updating feature, and programs will not be able to use the Windows Update Agent (WUA) API.

Update Orchestrator Service:  Manages Windows Updates. If stopped, your devices will not be able download and install latest udpates.

 

but really should just set active hours so it doesn't interfere while gaming.

as LTSC user my updates are practically nil :)

 

Share this post


Link to post
Share on other sites
50
[TASC]
Members
325 posts
11,378 battles

My Windows update does not have the set hours option. I turn it off, but Windows, turns itself on and starts downloading. I have the active hour option, but that is for restarting.

 

Edited by Timo_Greenwold

Share this post


Link to post
Share on other sites
240
Beta Testers, In AlfaTesters
1,063 posts

active hours won't stop it from DL but will from patching/restart

Share this post


Link to post
Share on other sites
297
[LANCE]
Members
793 posts
5,889 battles

Is it a company/work computer you’re using? If so it may have a group policy stopping you from disabling it. Otherwise what Ozium is suggesting will resolve the issue.

To stop fully with services, open up your services (you’ll find that under admin options), find the windows update service, right click it and select disabled. Then select stop service. It won’t restart then if your pc reboots.

Share this post


Link to post
Share on other sites
Members
2,858 posts
36,638 battles

Do what Ozium suggests.

You don't want to skip or ignore updates.  The majority of the updates could be security and that is serious.

Set the restart time and you are good.

As a rule, I check manually for updates to windows and security software every Tuesday on a non game time hour just to be thorough. Then I restart.

I also check WG game center under settings to run a launcher integrity check. This checks with the server if your version of the game is the same.

Occasionally, a mini patch comes down and you might miss it.

Lastly, if you are like me and run something similar to a game card program, then you run that to optimize for game mode.

Windows under settings has a game mode that when toggled will shut down non-essential programs to free up the ram and processor.

You only have to toggle to on and you are set.

If you still have issues, then try Microsoft customer support for driver updates to direct X.

Your graphics card probably does this on its own, but if it doesn't, then look in to this.

  • Cool 1

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×