Jump to content
Sign in to follow this  
You need to play a total of 20 battles to post in this section.
str1ngth3ory

Montana's legendary module Personal Assignment not activated upon acquiring of the ship

5 comments in this topic

Recommended Posts

3
[CLANS]
Members
8 posts
2,925 battles

Hi WOWS. I got my Montana three days ago, I have played it couple of times by now. However, the personal combat mission for Montana Legendary Module doesn't show up. Can WOWS look into my issue? Thanks

Share this post


Link to post
Share on other sites
992
[NSC]
Members
2,333 posts
2 minutes ago, str1ngth3ory said:

Hi WOWS. I got my Montana three days ago, I have played it couple of times by now. However, the personal combat mission for Montana Legendary Module doesn't show up. Can WOWS look into my issue? Thanks

This is a feature and not a bug.

WoWS is moving Unique Upgrades to the Research Bureau.

As of Update 0.9.1, players could no longer earn the missions for these Upgrades. Players have until end of year to finish existing missions.

Share this post


Link to post
Share on other sites
3
[CLANS]
Members
8 posts
2,925 battles
1 minute ago, henrychenhenry said:

This is a feature and not a bug.

WoWS is moving Unique Upgrades to the Research Bureau.

As of Update 0.9.1, players could no longer earn the missions for these Upgrades. Players have until end of year to finish existing missions.

Got it. Thanks for clarifying.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×