Jump to content
Sign in to follow this  
You need to play a total of 20 battles to post in this section.
Slayer_Jesse

Am I missing something with the Collector's Club?

7 comments in this topic

Recommended Posts

102
[CMFRT]
Beta Testers
282 posts
6,733 battles

QwzXQMk.png

 

idmhe5S.png

So can anyone tell me why this isn't awarding? Are there certain ships that don't count, like clan rentals?

Share this post


Link to post
Share on other sites
102
[CMFRT]
Beta Testers
282 posts
6,733 battles
Just now, HazeGrayUnderway said:

Tried exiting and going back into the game?  I don't think Rentals count, but I am not 100% on that.

yeah I've relogged a few times. I do have 3 clan rentals in port?

Share this post


Link to post
Share on other sites
5,796
[WORX]
Members
10,635 posts
18,550 battles
1 minute ago, Slayer_Jesse said:

yeah I've relogged a few times. I do have 3 clan rentals in port?

One way to find out... go to  110.. IF it triggers then yes it was the rentals fault..

Edited by Navalpride33

Share this post


Link to post
Share on other sites
102
[CMFRT]
Beta Testers
282 posts
6,733 battles
Just now, Navalpride33 said:

One way to find out... Have 110.. IF it triggers then yes it was the rentals fault..

Only problem with that is I've only got 1 port slot left, and I'm not buying more just for a badge. All my port slots have come from free missions, and normally I don't come close to filling them.

Share this post


Link to post
Share on other sites
102
[CMFRT]
Beta Testers
282 posts
6,733 battles

Ok, I played a battle, and then it counted. *shrug* Guess I should have tried that first, ha ha.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×