Jump to content
Sign in to follow this  
You need to play a total of 20 battles to post in this section.
Banished_Privateer

Geforce NOW automatically chooses server

5 comments in this topic

Recommended Posts

Community Department
3,323 posts
1,300 battles
3 hours ago, Banished_Privateer said:

I've just tried WoWs on Geforce NOW, but running into the issue that it downloads European client for me without an option to change that. Any ideas?

I don't see the issue among our bugs. How does it look like, could you please provide some additional info about it? What have you tried by now?
Did you try to enter Game Setting in the WGC and to try to install additional game instance?

Share this post


Link to post
Share on other sites
54
[SSBN]
Members
165 posts
6,410 battles

That's a GeForce thing, WG probably can't help you with anything here. Best you can do is hit the settings (gear symbol) on your GeForce launcher and check or change which server you're logging into on there. Last night I used my normal GeForce server (US NE) but the game wasn't updated, I switched to US E and game is updated, have to jump around like that sometimes.

 

I did have an issue in the past of after GeForce updated the client, it was stuck on WOW Asia instead of WOWS NA. All you can do there is put in feedback on the GeForce app, and post on the GeForce forums. Took Nvidia 3 days to fix it during this issue but at least it got fixed I guess lol

Edited by Sic_44

Share this post


Link to post
Share on other sites
54
[SSBN]
Members
165 posts
6,410 battles
5 minutes ago, turbo07 said:

I don't see the issue among our bugs. How does it look like, could you please provide some additional info about it? What have you tried by now?
Did you try to enter Game Setting in the WGC and to try to install additional game instance?

Just an FYI; GeForceNOW doesn't make the WGC available to us anymore, we launch WOWS or WOT from their client/launcher and it goes straight to the game login screen.

Edited by Sic_44
  • Cool 1

Share this post


Link to post
Share on other sites
110
[-AHOY]
Members
256 posts
7,716 battles
4 hours ago, turbo07 said:

I don't see the issue among our bugs. How does it look like, could you please provide some additional info about it? What have you tried by now?
Did you try to enter Game Setting in the WGC and to try to install additional game instance?

As posted above, I'm stuck with the EU Client, can't change anything. I tried changing Geforce NOW server to NA, but it didn't work. There should be a better option to change servers in client... it's literally minor difference, but who are stuck with different launchers or need to use mods, edit/replace files etc. 

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×