Jump to content
Sign in to follow this  
You need to play a total of 20 battles to post in this section.
Retnav54

"Rewards for Veterans" Offer Bugged?

6 comments in this topic

Recommended Posts

556
[SFBBW]
Beta Testers
1,321 posts
10,872 battles

Don't know if this is something just on my end, but -

When the WoWS launcher comes up, the main article being featured is the "Rewards for Veterans" offer - but the background is completely black. And when you click on the "Details" link, or the article link on the left hand side, when that link loads, it's again a black screen.

Only link to said article that works is the in-game news. But when you click on the link in the article to try to take advantage of the offer, once again, only a black screen loads up.

 

Share this post


Link to post
Share on other sites
1,114
Members
5,789 posts
11,631 battles

No problem for me either from the game itself or the WGC.  What browser it is opening up on your end?

Share this post


Link to post
Share on other sites
806
[XG]
Members
458 posts

Worked fine for me, and I run a locked-down Firefox browser. Sounds like it could be a M$ .NET or Visual Basic version conflict.

In game center, run "check for additional softeware" and see if that helps.

Share this post


Link to post
Share on other sites
Members
492 posts
15 minutes ago, S7CentNickel said:

Is it just me that I finds it strange that a Russian company (sorry WG NA) is trying to identify US veterans?

Cold war was over in 92. Get over it.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×