Jump to content
Sign in to follow this  
You need to play a total of 5 battles to post in this section.
GrandNetuno

I can't get into battle to play

11 comments in this topic

Recommended Posts

4
[BB_59]
Members
32 posts
1,443 battles

 

I don't know what is going on, but when I click on "battle" to play, it keeps loading and doesn't start the game. I think there is some technical problem occurring in the server of Brazil

  • Boring 1

Share this post


Link to post
Share on other sites
5
[CS7]
Beta Testers
18 posts
15,615 battles

Nope, I'm in the U.S. and it's down here, as well. The are multiple threads and comments in the forums regarding this issue.

Share this post


Link to post
Share on other sites
649
[WGA]
Administrator
206 posts
284 battles

Captains, there is a confirmed issue on NA server.

We are restarting them, please give it another 15-30 minutes until the issue is resolved.

  • Cool 1

Share this post


Link to post
Share on other sites
564
[NSC]
Members
1,745 posts
1 minute ago, Boyarsky said:

Captains, there is a confirmed issue on NA server.

We are restarting them, please give it another 15-30 minutes until the issue is resolved.

Thanks for the quick response!

Nice seeing you around!

  • Cool 1

Share this post


Link to post
Share on other sites
Members
2,897 posts
10,699 battles
1 minute ago, neptunes_wrath said:

ITS SUNDAY!!!
Go watch Football or something...

Wisconsin beat Michigan

Packers beat Broncos

All is right in the world.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×