Jump to content
Sign in to follow this  
You need to play a total of 20 battles to post in this section.
CoolBreeze66

Servers are Down

21 comments in this topic

Recommended Posts

Beta Testers
3 posts
6,517 battles

think that it being a weekend they'de be on top of fixing this

i was trying to play and it won't let me in either.  off to watch football i guess

Share this post


Link to post
Share on other sites
97
[PRDEF]
Members
155 posts
10,883 battles

Working fine for me.  Just getting into a full player team in Co-op at Tier VII.  Obviously, I'm not discounting others' experiences, just saying it doesn't appear to affect all players.

Edited by rufus374

Share this post


Link to post
Share on other sites
77
[TAC-B]
Beta Testers
200 posts
12,826 battles

Training room working fine.  Co-op battles don't load - the little circle animation spins for 5 seconds and then back to port.

Share this post


Link to post
Share on other sites
1
[IHW]
Members
3 posts

Still not working here on NA server. They gave me premium for 24 hours last night  guess I don't get to use it!

Stopped about 30 seconds from ending a game on Random. Got no credit for that game.

Edited by smithkeywest
addition

Share this post


Link to post
Share on other sites
32
[SOTA]
[SOTA]
Beta Testers
33 posts
5,945 battles
1 minute ago, neonsigns said:

Not working on Co-op, Random or Ops here.

Same, training room only

Share this post


Link to post
Share on other sites
Members
3 posts
4,267 battles
3 minutes ago, smithkeywest said:

Still not working here on NA server. They gave me premium for 24 hours last night  guess I don't get to use it!

 

Just added premium time and that worked fine :-) looks like the "take my money" part of the game is working fine. Its only the "give me the services for the money you took" part that is broken.

Share this post


Link to post
Share on other sites
Members
1,739 posts
10,757 battles
Just now, AXELGREASE said:

Game still not loading into battle.  Spins for a few seconds and kicks me back to port. 

1:32 pm EST. 9/22/19

Don't worry. Some chud in another thread says everything is fine.

Share this post


Link to post
Share on other sites
2,198
[GWG]
Members
7,449 posts
14,256 battles

And I got booted from my training room..  darned.. and I was Losing too!!  lol

ServerDown.jpg

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×