Jump to content
You need to play a total of 5 battles to post in this section.
MaddogGT

Basic Lag/FPS fix and Windows Timer set 0.5ms.

1 comment in this topic

Recommended Posts

23
[EXP]
Members
58 posts
7,121 battles

After suffering some lower FPS and lag/high ping, I found a 10-20% increase in FPS and less lag spikes by setting Maximum pre-rendered frames in the NVIDIA control panel for WOWS to 1. Then this thing called HPET in bios. Make it Disabled. Then in Windows, cmd prompt (Admin) enter 

bcdedit /deletevalue useplatformclock

press enter

bcdedit /set disabledynamictick yes

press enter

then goto device manager, and find High Precision Event Time under System Devices and disable it there to make sure its completely disabled.

Reboot.

You should see somewhat of a better game performance.  I was getting 90-120 FPS and now 130-155 and less lag.

AND this is for Windows 10 and try at your own risk and know what you are doing before hand. Some MOBOs dont have the HPET option listed to disable so you need to disable it in windows anyways. Some systems dont even use it and its not active anyways, but many do.

To re-enable it:

bcdedit /set useplatformclock true

bcdedit /set disabledynamictick no

No guarantee everyone will have same effect doing this, but be interesting to see.

ALSO, I forgot to mention, you can try this neat tool to deduce the system timer. https://github.com/tebjan/TimerTool 

Set to 0.5ms, and see how your FPS increases. Windows 10 has default higher of anywhere between 1ms and 14-15ms and can cause lag spikes, slower fps. Set with this little app and keep app running to make sure timer stays as you set.

image.png.c3b2f1568e1e52fa50394568654ae89a.png

Edited by MaddogGT
  • Cool 1

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×