Jump to content
Sign in to follow this  
You need to play a total of 20 battles to post in this section.
StarShip_Enterprize

Disk Manager 100% constantly freezes game after update

6 comments in this topic

Recommended Posts

Members
7 posts
9,431 battles

Hi everyone

After the last update, my WOW keep freezing and I have to restart the game and or the pc.  I run BitDefender on my PC (just incase this might be the issue).

I use windows 10.  Game worked previously without any such issues.  Does anyone know what I can do to fix this.  I now keep getting penalties for leaving the game early, because I have to restart literally every game I try to play after trying to change settings here and there. Disk percentage on Task manager is now under 10%, but the moment I senter a game it goes to (( or 100% and freezes.

Thank you in advance for your support.

 

 

Share this post


Link to post
Share on other sites
Beta Testers, In AlfaTesters
4,191 posts
12,721 battles
14 minutes ago, StarShip_Enterprize said:

Hi everyone

After the last update, my WOW keep freezing and I have to restart the game and or the pc.  I run BitDefender on my PC (just incase this might be the issue).

I use windows 10.  Game worked previously without any such issues.  Does anyone know what I can do to fix this.  I now keep getting penalties for leaving the game early, because I have to restart literally every game I try to play after trying to change settings here and there. Disk percentage on Task manager is now under 10%, but the moment I senter a game it goes to (( or 100% and freezes.

Thank you in advance for your support.

 

 

 You can try this :  bring the launcher up , instead of play click settings at the top . Next click support , there I click 'ADD' just to be sure then click the 'CHECK' box . this takes awhile as it will inform you . After it finishes ; if it does not tell you different try the game again . If that fails you will have to try Customer Support or hope someone more savvy comes along .

:Smile_honoring:

I guess it says 'Player Support instead of customer . Never noticed that before .

 

Share this post


Link to post
Share on other sites
Members
7 posts
9,431 battles

Hi Chien_Lu

Thank you for the suggestion.  Tried it but as soon as I played the game froze up again. Guess I'm stuck with this problem and not playing WOW's anymore. So frustrated.  I don't want to install that app thingy of WOWs that tests/reports. I am paranoid when it comes to my security.

Thanks again, I appreciate your help.

 

Share this post


Link to post
Share on other sites
3,984
[V_KNG]
Beta Testers
13,198 posts

If you are using the "new" launcher, you can eliminate it as a source of issues by going into your WoWS folders, finding (example: D:\Games\World_of_Warships_NA\WorldOfWarships.exe) the exe file and creating a shortcut to it on your desktop. 

Then launch the game using the shortcut to the exe above, see if things work okay. if they do, then your computer has an issue with the launcher. 

If it still persists with the same shenanigans, you can check Windows 10 updates, see if everything is current. Check for updates to video driver, etc... 

Me, myself and I - we would probably wipe the game off the drive, load up ccleaner, run it to ensure everything was cleaned up in the registry. 

Sometimes too - although it's rare - such behavior can indicate potential issues with a disk drive. You may want to check the drive for errors IF it is not a SSD. 

GL! 

Share this post


Link to post
Share on other sites
Members
7 posts
9,431 battles

Thank you for all the advice.  I tried and still nothing.  Now standing at 22 op games I have to play lol.

Submitted a ticket to wows, with report.  Hopefully they can assist.

Have a good day everyone, I appreciate your response.

Share this post


Link to post
Share on other sites
1
[WREKR]
Members
12 posts
14,356 battles

Only thing that worked for me is going to intel for the newest driver for my video. Then had to manually install it because it kept telling me to download the old driver from hp. Only time I usually crash and have to reload now is if I have firefox open , even the res music folder is working right without being an issue :) I would Start with video Drivers and remove mods if you use them. Hope this helps.

Edited by QSubzero

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×