Jump to content
You need to play a total of 20 battles to post in this section.
pppanic

Can't login to WoWS account on Steam after update

14 comments in this topic

Recommended Posts

Members
3 posts
667 battles

I have repeatedly tried the "2steam_api.dll" fix but it is still prompting me to create a username when I launch the game. Any help is appreciated, thanks.

  • Cool 1

Share this post


Link to post
Share on other sites
7,515
[HINON]
Members
14,340 posts

You likely need to change the 64 bit api file instead now that warships is 64 bit. It has 64 in the file name. 

Share this post


Link to post
Share on other sites
Members
3 posts
667 battles
1 minute ago, RipNuN2 said:

You likely need to change the 64 bit api file instead now that warships is 64 bit. It has 64 in the file name. 

Where can I find the 64-bit file? Is it going to have a different name than steam_api.dll?

Share this post


Link to post
Share on other sites
7,515
[HINON]
Members
14,340 posts
1 minute ago, pppanic said:

Where can I find the 64-bit file? Is it going to have a different name than steam_api.dll?

2steam_64api.dll or something similar. I think its in the same location. 

Share this post


Link to post
Share on other sites
Members
3 posts
667 battles
2 minutes ago, RipNuN2 said:

2steam_64api.dll or something similar. I think its in the same location. 

Same location is not showing anything 64-bit. 

wows.PNG

Share this post


Link to post
Share on other sites
7,515
[HINON]
Members
14,340 posts
32 minutes ago, pppanic said:

Same location is not showing anything 64-bit. 

I found this on the steam forums. You might try there in the future as they are more knowledgeable usually about this stuff.

 

  1. Right-click World of Warships in your Steam Library
  2. Properties
  3. Local files
  4. Browse local files
  5. If your PC has 6 Gbs of RAM or more:
    • open \bin\1491147\bin64\
    • rename steam_api64.dll to anything like steam_api64_bak.dll
  6. If you have below 6 Gbs or just in case:
    • open \bin\1491147\bin32\
    • rename steam_api.dll to anything like steam_api_bak.dll
  7. Now launch the game as usual
Edited by RipNuN2

Share this post


Link to post
Share on other sites
1
[FOOLZ]
Members
4 posts
9,328 battles

Strange: when I install the Steam WOWS client, it creates two numbered folders in the Common/Worldof Warships/bin subdirectory, apparently duplicates, in which both have the steam_api64.dll. Any idea why it needs two? I've deleted the WOWS installation and reinstalled and again, with the duplicate bins. If I edit the dlls as suggested in this thread, launching WOWS hangs before the splash screen.

Two Bins.png

Share this post


Link to post
Share on other sites
2
[CYPHR]
Members
2 posts
6,965 battles

So I have just updated but when i change my steam_api64.dll to another name it tells me i need that folder to even larch the game, anyone got any ideas?

(btw, i did this for all three folders: client, 64, and 32 on 1942147)

2019-10-17.png

2019-10-17 (1).png

Edited by RasMaster

Share this post


Link to post
Share on other sites
Members
152 posts
4,104 battles

Looks like the Steam_api work around doesnt work now. I've used it every update until now, but if I change all the file names, the game doesnt open at all, if I leave them unchanged it tells me my name is already taken and to create a new account.

 

Looks like they're still trying to force this Game Center trash.

Share this post


Link to post
Share on other sites
Members
1 post
2,230 battles

It's really frustrating because I literally cannot install or update the game through the Wargaming Game Center. This steam workaround was the only way I could play, and now I can't access my account with all my progress. Hope they fix this soon.

Edited by Ninja_Platypus

Share this post


Link to post
Share on other sites
361
[TARK]
Members
736 posts
5,201 battles
20 hours ago, Springfield_Fats said:

Looks like the Steam_api work around doesnt work now. I've used it every update until now, but if I change all the file names, the game doesnt open at all, if I leave them unchanged it tells me my name is already taken and to create a new account.

 

Looks like they're still trying to force this Game Center trash.

Lol... got a "come back and play our game" email from them.  Thought I'd give it a try...  

NOPE.  Can't use WG account through steam anymore.

Game Center is spyware... so I guess I'll remain in other games.

Edited by turdjelly

Share this post


Link to post
Share on other sites
0
[ARMAS]
[ARMAS]
Members
1 post
2,736 battles

Hello, is there any solution to this? i accidentlally unlink steam from wargaming, and now i cant enter the game, have to pick a new name and create account. I want to force a login screen to enter my credentials...

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×