Jump to content
Sign in to follow this  
You need to play a total of 5 battles to post in this section.
kgh52

after update tech issues

3 comments in this topic

Recommended Posts

937
[TDRB]
Members
2,982 posts
8,958 battles

It is normal to have a hiccup or 2 after an update. 8.3 was not smooth to begin with. It was postponed for 24hrs then the start time was moved back another 2.5 hrs. So I expected to see a few rough spots. But it seems I'm seeing a few more hiccups than what I expected. Of course this is my view which isn't supported by a in dept study. My question is does it seem worse with this update? Hopefully tomorrow the game will run smoother.

BTW my system is far above the recommended specs & my ISP is working fine.

Share this post


Link to post
Share on other sites
1,360
[A-D-F]
Beta Testers, In AlfaTesters
3,660 posts
5 minutes ago, kgh52 said:

BTW my system is far above the recommended specs & my ISP is working fine.

Sure that is still the case?

The system requirements changed with this patch. The new game client is 64 bit (it was 32 bit until this morning) and DX9 is no longer supported. 

Share this post


Link to post
Share on other sites
937
[TDRB]
Members
2,982 posts
8,958 battles
8 minutes ago, Burnsy said:

Sure that is still the case?

The system requirements changed with this patch. The new game client is 64 bit (it was 32 bit until this morning) and DX9 is no longer supported. 

Yes, I'm positive.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×