Jump to content
You need to play a total of 10 battles to post in this section.
hr9275

8.3 won't launch on a Mac

36 comments in this topic

Recommended Posts

Members
23 posts
5,046 battles

 

Playing on a Mac mini (2014). After installing 8.3 I hit the "Play" button and the application quits. Anyone else having this problem?

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites
350
[ICOP]
[ICOP]
Members
942 posts
14,325 battles

I remember reading in the patch notes that graphics cards unable to run anything beyond DirectX 9 will not be able to launch. Could that be the issue, brother? Hoping you are able to rejoin the game soon.

Respects,

Am

Share this post


Link to post
Share on other sites
Members
821 posts
6,988 battles

It opened five yesterday but this morning it does what you’re seeing - hit play, vanishes, then nothing.

Share this post


Link to post
Share on other sites
4,236
[PVE]
[PVE]
Members
8,138 posts
21,301 battles

I can get it to launch and play but there are so many problems that the game is now unplayable. Lag is not just in port, it is now in the game. Water is so dark I can not longer see anything, torpedo reticle is gone, unable to open Armory, News, Clan, etc although I can open Inventory. Also game locks up a the end of a match and have to Force Quit. It is a mess, guess I am done. 

Edited by Taylor3006

Share this post


Link to post
Share on other sites
4,236
[PVE]
[PVE]
Members
8,138 posts
21,301 battles

Did a quick Google search and the problem is going to be with Wine and DirectX 11. They don't work together so you will need Boot Camp or similar program to run Windows and then run the program. However there are issues using DirectX 11 there as well although there may be a fix, did not read much further since I just got disgusted and lost interest. If you are using the Wine Wrapper, you are pretty well boned. 

Share this post


Link to post
Share on other sites
1,427
[WGA]
Administrator, Developers
1,375 posts
7,826 battles

Ahoy, there's some good information for Mac players here:

#anchorsaweigh

Share this post


Link to post
Share on other sites
Members
45 posts
2,271 battles
9 minutes ago, Gneisenau013 said:

Ahoy, there's some good information for Mac players here:

#anchorsaweigh

"Good information"?

Did you not see the follow up to THAT posting was that Mac users found your information useless?

  • Cool 1

Share this post


Link to post
Share on other sites
19
[COOLI]
Members
24 posts
5,650 battles
1 hour ago, Taylor3006 said:

I can get it to launch and play but there are so many problems that the game is now unplayable. Lag is not just in port, it is now in the game. Water is so dark I can not longer see anything, torpedo reticle is gone, unable to open Armory, News, Clan, etc although I can open Inventory. Also game locks up a the end of a match and have to Force Quit. It is a mess, guess I am done. 

Similar problems here. This is my list so far:

Black Ocean

No Torpedo aiming reticle

No aiming reticle for planes

Can't open Armory,

4 additional insistences of "Wargaming game client64" running in Activity Monitor (If I force-quit the duplicates, they come back)

20 instances of "WargamingErrirMonitor.exe" running in Activity Monitor

4 instances of "com.audio.SandboxHelper" running in Activity Monitor (not 100% sure if its related, but it's mighty suspicious)

Very low FPS in-game (10-15 vs 30-40 yesterday)

I can see the fires on burning friendlies through islands when I use the binoculars

Sluggish response in port.

Have to force quit after most battles

 

 

I did the integrity check/fix thing out of the WG Client to no avail.

Edited by El_Guapo_Guerilla
  • Cool 1

Share this post


Link to post
Share on other sites
4,236
[PVE]
[PVE]
Members
8,138 posts
21,301 battles
14 minutes ago, Gneisenau013 said:

Ahoy, there's some good information for Mac players here:

#anchorsaweigh

Did the Wargaming WoWS team find a way to make Wine function with DirectX 11? 

The only way to get the game to function now for Mac users is to use BootCamp or similar programs because requiring DirectX 11 pretty much killed the wrapper. I fiddled with settings and just barely got the game to work but it is such a buggy mess that I would call it unplayable.  

 

Share this post


Link to post
Share on other sites
0
[F13BD]
Members
4 posts
16,403 battles
6 minutes ago, Gunslinger8 said:

"Good information"?

Did you not see the follow up to THAT posting was that Mac users found your information useless?

Ya mine won't launch either.

Share this post


Link to post
Share on other sites
Members
45 posts
2,271 battles
6 minutes ago, d_gladkov said:

Current wrapper is not stable at all. But we will release the new one very soon. Till then please use this beta wrapper:

http://www.mediafire.com/file/xm5lp05859y2cnh/wargaminggamecenter-3.1.0_beta4.dmg/file

Not a chance buddy.
You want me to upload a wrap that was put together hastily in Russia for the purpose of patching a problem that you guys have known about for a year and a half?
Nothing could go wrong with THAT scenario, right?

  • Cool 1

Share this post


Link to post
Share on other sites
4,236
[PVE]
[PVE]
Members
8,138 posts
21,301 battles
2 minutes ago, Gunslinger8 said:

Not a chance buddy.
You want me to upload a wrap that was put together hastily in Russia for the purpose of patching a problem that you guys have known about for a year and a half?
Nothing could go wrong with THAT scenario, right?

Yeah, not sure what they have done with this. Do a Google search for getting Wine to work with DirectX 11+ and read what is there. Apparently they don't work together, some say it is a hardware issue with Apple and DirectX and that is probably the case since there are tens of thousands of hits on the problem. I seriously doubt Wargaming has the talent to overcome a problem of that magnitude, especially a Mac related issue. Guessing the "workaround" somehow disables the need to use the newer version of DirectX but don't see much good coming of it. 

Share this post


Link to post
Share on other sites
19
[COOLI]
Members
24 posts
5,650 battles
32 minutes ago, d_gladkov said:

Current wrapper is not stable at all. But we will release the new one very soon. Till then please use this beta wrapper:

http://www.mediafire.com/file/xm5lp05859y2cnh/wargaminggamecenter-3.1.0_beta4.dmg/file

The bad news is that this seems to have worked.

 

There goes my productivity again.

Share this post


Link to post
Share on other sites
0
[REG]
Members
6 posts
2,068 battles

Also had a very nice stable battle using the shifty Russian beta wrapper!

Share this post


Link to post
Share on other sites
1,427
[WGA]
Administrator, Developers
1,375 posts
7,826 battles
1 hour ago, Gunslinger8 said:

Not a chance buddy.
You want me to upload a wrap that was put together hastily in Russia for the purpose of patching a problem that you guys have known about for a year and a half?
Nothing could go wrong with THAT scenario, right?

The file was uploaded from our dev studio in St. Petersburg to a site accessible for our players.

Please give it a try to see if this version is more stable for you to launch and play World of Warships.

 

Share this post


Link to post
Share on other sites
Members
23 posts
5,046 battles

I tried the beta wrapper and it worked. It installs the wargaming center and you launch from there. You will need to redo all your settings. One glitch is that I need to force quit to close the game.

Share this post


Link to post
Share on other sites
Members
1 post
5,439 battles
4 hours ago, hr9275 said:

 

Playing on a Mac mini (2014). After installing 8.3 I hit the "Play" button and the application quits. Anyone else having this problem?

 

 

 

 

 

 

 

 

 

 

I'M having same exact problem. j

1 minute ago, hr9275 said:

I tried the beta wrapper and it worked. It installs the wargaming center and you launch from there. You will need to redo all your settings. One glitch is that I need to force quit to close the game.

 

 

where do i get the wrapper?

 

 

 

 

Share this post


Link to post
Share on other sites
0
[REG]
Members
6 posts
2,068 battles
12 minutes ago, vtr_3 said:

 

Use the mediafire link in the posts above

Share this post


Link to post
Share on other sites
163
[FFG33]
Members
419 posts
13,427 battles

Like everyone else I downloaded the Mac client and it utterly fails to launch.

wrt the magical wrapper.... I am busy this week. Maybe I will go through the gymnastics of mediafire-whatever-wrapper next week.

But truthfully.... why bother?

A lot of work for an uncertain payoff. Maybe a client that crashes mid-game as before.

For a game that is supposed to be "fun and engaging", WoWs has become a lot of work.

I paid WG money for a game so they can hire devs and address these issues.

Share this post


Link to post
Share on other sites
11
[OB1]
Members
104 posts
2,015 battles
4 hours ago, hr9275 said:

 

Playing on a Mac mini (2014). After installing 8.3 I hit the "Play" button and the application quits. Anyone else having this problem?

 

 

Tried the temp "wrapper" and still no luck loading.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites
19
[COOLI]
Members
24 posts
5,650 battles
34 minutes ago, awesomeartichokes said:

Like everyone else I downloaded the Mac client and it utterly fails to launch.

wrt the magical wrapper.... I am busy this week. Maybe I will go through the gymnastics of mediafire-whatever-wrapper next week.

But truthfully.... why bother?

A lot of work for an uncertain payoff. Maybe a client that crashes mid-game as before.

For a game that is supposed to be "fun and engaging", WoWs has become a lot of work.

I paid WG money for a game so they can hire devs and address these issues.

I hear you. For what it's worth, my experience was that it took about 5 minutes to install the Wargaming Center from the link, and it seems to have solved the problems I've been having.

If you give it a try, I hope it works as well for you.

Share this post


Link to post
Share on other sites
163
[FFG33]
Members
419 posts
13,427 battles
13 minutes ago, El_Guapo_Guerilla said:

I hear you. For what it's worth, my experience was that it took about 5 minutes to install the Wargaming Center from the link, and it seems to have solved the problems I've been having.

If you give it a try, I hope it works as well for you.

It might... but I have had:

  • too many games ruined by crashes.
  • AFK penalties because of the crashes
  • WG support refusing any and all assistance

The trigger for me was a few months ago when Mr_Conway claimed the client was excellent and that client crashes were an excuse. 

That was the moment when I realized that I was investing way too much time and money!

It was an unhealthy abusive relationship.

At this point, I am o.k. with occasionally checking to see if the game play experience has gotten any better. It feels weird to not play WoWs - but I am sure that will pass.

If WG actually fixes things, well I might come back. Either way it has been demonstrated that WG doesn't care.... so why should I.

(in fact, being on this forum is probably a sign that I am still caring too much)... logging off now!

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×