Jump to content
Sign in to follow this  
MVital

Fix the NA servers plz

17 comments in this topic

Recommended Posts

17
[45ACP]
Members
19 posts

I as well as many other players in battles today have been experiencing serious lag spikes, 3 to 7 second spikes, and it makes trying to play all but impossible.  Please fix this issue.

  • Angry 1

Share this post


Link to post
Share on other sites
20
[_-X-_]
[_-X-_]
Members
206 posts
7,515 battles

Ditto.  Hit key........................................................................................................................... Fire.  Don't hit key.....................................................................Fire. LOL.  Someone even dinged my Karma. :)

 

Share this post


Link to post
Share on other sites
0
[UFEF]
Members
1 post
5,170 battles

I just played a game and it was taking 10 sec before clicks would register. The game crashed before the end as well..

Share this post


Link to post
Share on other sites
0
[CSF-1]
[CSF-1]
Beta Testers
1 post
4,005 battles

Gods help us i had camos an everything on thrown away becuase the players from the EU server are on the NA server to avoid the Russian players and their pings are fine. ;(

 

Share this post


Link to post
Share on other sites
16
[SOUS]
[SOUS]
Members
32 posts
1,224 battles

Same.  Went to engage a target *click* 5 seconds pass and FIRE.  Go to evade torps....rudder hard over................................................still no movement and blasted by torps...then it appeared to crash.

Fix plox

Share this post


Link to post
Share on other sites
0
[S4LTY]
Beta Testers
10 posts
3,850 battles

I had logged on but never joined a match, all the discussion in both chats was about nothing other then game breaking lag. I was really looking forward to playing, is this being addressed?

Share this post


Link to post
Share on other sites
0
[WOLF8]
Members
3 posts
4,253 battles

that's alright, got 3 pink games for never loading into a match. was in que for 25 mins then disconnected, came back pink. Oh and forget it if you get in a match, aim is off, lag is horrendous, etc..

Edited by Dramm_destroyer

Share this post


Link to post
Share on other sites
Members
3 posts
14 battles

The way I understand there is a blizzard or some kind of storm messing with the server. I guess play in EU and hope you don't run into the russians

 

Share this post


Link to post
Share on other sites
46
[ABCD3]
Members
381 posts
9,508 battles

Noticed some "freeze" frame while in a couple of matches last night.  Guess it got worse today.   Hope it gets fixed. 

Share this post


Link to post
Share on other sites
Members
817 posts
9,071 battles
46 minutes ago, 5O_Shades_of_Steel said:

Sorry guys, It's my fault. I was microwaving a slice of pizza and had the microwave too close to my computer. FIXED

 

....you never microwave a pizza.....jesus, what have we become....?.... ;-)

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×