Jump to content
Sign in to follow this  
You need to play a total of 5 battles to post in this section.
XpliCT_

Was Last Stand Nerfed Recently?

14 comments in this topic

Recommended Posts

385
[OO7]
Members
1,051 posts
4,639 battles

I've been playing a few ranked games over the past few days, and I've been using mostly Kita.  I'm not sure if it's just conjecture, confirmation bias or just me seeing things but I feel like Last Stand has been nerfed in 8.0.  I just got out of a game where I had my engine knocked out while I was moving at 1/4 throttle, and pushed it up to full.  My ship quite literally wouldn't accelerate past 1/4 speed.  I get that your engine will not operate like it isn't broken, but I feel like something's been changed.  This isn't the first time I've felt this recently either.  Anyone else notice something odd about it?

Share this post


Link to post
Share on other sites
6,375
[ARGSY]
Members
13,990 posts
9,049 battles

Yeah, I also got the feeling I was crawling away a fair bit more slowly and turning a bit more sluggishly than I might previously have been doing, but it hasn't happened to me enough yet to draw firm conclusions.

Share this post


Link to post
Share on other sites
387
[INR]
Members
1,224 posts
4,060 battles

I noticed something similar in Aoba and Zao when my rudders were knocked out. I thought it was because I'm used to LS in Akizuki and Harugumo, but if other people are noticing it...

I might need to look further into it.

Share this post


Link to post
Share on other sites
1,372
[CAST]
Members
4,756 posts

Doesn't help that Last Stand *still* doesn't give a proper tooltip telling you how it exactly affects your engines and rudder.

Share this post


Link to post
Share on other sites
0
[S_C]
Members
27 posts
15,802 battles

Yep, I was here to see if anyone else noticed this. I noticed I had almost no engine despite having Last Stand. 

Share this post


Link to post
Share on other sites
1,296
[C-CA]
[C-CA]
Beta Testers, In AlfaTesters
3,903 posts
5,750 battles

Haven't noticed anything in my Jutland, though Kitakaze does feel a bit more sluggish to me overall post-rework.

Share this post


Link to post
Share on other sites
5,431
[PVE]
Members
9,676 posts
17,264 battles

Thought it was just me so I didn't post to be told so. Yes, it does feel like LS has been nerfed. Rudder control and engine speed while damaged is not as responsive. 

  • Cool 1

Share this post


Link to post
Share on other sites
209
[OIL-1]
Members
388 posts

I noticed it as well.

Share this post


Link to post
Share on other sites
173
[--O--]
Members
280 posts

Ok so not just me, Hara and Z-52 both seemed to have issues but just thought it was frustration from being rocketed 50 seconds in to the game

 

Share this post


Link to post
Share on other sites
Beta Testers
135 posts
1,392 battles

Count me in. I thought it was a bug on my end. BB stopped moving completely while in close-mid range battle. No damage icon, no stack smoke showing engine hit. Just stopped moving entirely as if frozen but I could move my turrets fire guns and shift my rudder back and forth. I ended up sinking but thought lag on my end. Very strange. Never happened since.

Share this post


Link to post
Share on other sites
Members
473 posts
3,700 battles

I've noticed this in a few DD games also, so another stealth nerf bat for DDs?  Where did I put that popcorn?  Ah, here it is.  :Smile_popcorn:

I tend to have this on my DDs as a standard item, the trouble is I don't play the individual ships often enough to be sure something has changed.  I tend to play them in groups when I am in the mood for DD style play, so I don't get enough time in each ship, yesterday I spent some time playing them, Gnevny, Geade, and JainWei (along with the Valkyrie and Acasta, yuck I miss speed boost more than I thought I would), and noticed something off a few times.  It seems I'm less able to change direction or speed now than what I think I could do in the previous patch.  I thought it was just me, being a potato in my DDs.

Share this post


Link to post
Share on other sites
320
Members
1,164 posts
8,337 battles

I've felt a difference as well but I'm not sure if it's real or not.

Share this post


Link to post
Share on other sites
307
[-S-R-]
Beta Testers
531 posts
3,301 battles

I concur, before the patch it felt like it reduced your max maneuverability by 20% or so, now it feels like it's reduced TO 20% or so.  Even with speed boost, if the engine is knocked out it's painfully slow to even nudge forward to 1/4 speed from a dead stop with LS.

 

I have no scientific way to prove this now though given we don't have evidence of previous patch mechanics in a repeatable format.

Share this post


Link to post
Share on other sites
34
[WHS]
[WHS]
Members
301 posts
9,741 battles

I haven't had enough free time to play the new patch much, so I can't comment on how it is now. What I can contribute, however, is that as far as I can remember in this game you always struggled with LS if you wanted to accelerate from dead stop or 1/4 to full speed. You only ever got to keep your movement with the engine broken because you were already moving at full speed when it broke

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×