Jump to content
Sign in to follow this  
Reymu

Crashing at start

9 comments in this topic

Recommended Posts

1,289
[NG-NL]
Members
5,921 posts
9,565 battles

Just submitted ticket to WG, but repeating my issue here in hopes someone else has encountered and fixed it.

Used to run WOWS on my casual gaming rig. 8GB memory, GTX 645, i7 CPU w/ 3.3Ghz. WOWS is installed on my 250 GB SSD, and yesterday brother came by as planned and swapped my drives to his gaming rig he built himself. It has 16GB DDR4 memory, AMD Ryzen 5 1600 CPU rated 3.2GHz, AMD ATOMBIOS graphics card.

I've already tried integrity check from Wargaming client, uninstall and reinstall, and updating graphics drivers. WOWS still crashes 2-5 seconds after launching. Not running any mods atm since did total uninstall.

Given how this was supposed to be an upgrade, I kinda got buyer's remorse.

Share this post


Link to post
Share on other sites
86
[S0L0]
Members
293 posts
6,953 battles

Same thing happened to me tonight, however I was able to log in on my 2nd try without doing anything. I didn't play any games out of the fear it'll crash durning play.

 

I dont know what might be causing it.

 

Share this post


Link to post
Share on other sites
401
[-TKS-]
[-TKS-]
Members
967 posts
7,291 battles

multiple threads about clients crashing and bugs.... happens to me too. use to happen at the start of the game, but now it happens randomly. 

also, ive been fighting with the communication boxes in port. the struggle is real. 

 

Share this post


Link to post
Share on other sites
1,289
[NG-NL]
Members
5,921 posts
9,565 battles

Well, WG's reply is run their WGCheck, so I'm doing that now. The page w/ instructions: https://na.wargaming.net/support/en/products/wows/article/19401/

Seems like it should help. It digs thru the files and does network diagnostics, and will generate crash reports you can send to WG Support.

Share this post


Link to post
Share on other sites
1,289
[NG-NL]
Members
5,921 posts
9,565 battles

Ok, after testing out this AMD stuff w/ so many other games I own on Steam, can say, AMD brand is weak at games, so just gonna swap the drives back into the proven Intel/NVIDIA combination and forget AMD exists. Thank God for free market!

Share this post


Link to post
Share on other sites
212
[WOLF5]
Members
817 posts
9,071 battles
30 minutes ago, Reymu said:

Ok, after testing out this AMD stuff w/ so many other games I own on Steam, can say, AMD brand is weak at games, so just gonna swap the drives back into the proven Intel/NVIDIA combination and forget AMD exists. Thank God for free market!

What is AMD atombios?? Integrated graphics ? Your old rig was more than capable to run this game,,,with dedicated card. Do not blame AMD,,you can not possibly compare dedicated video card to some onboard graphics...You can always take the card out from the old system,,and try it in the new..

 

Share this post


Link to post
Share on other sites
1,289
[NG-NL]
Members
5,921 posts
9,565 battles

Update:

Turned out brother had forgotten to check the drivers are fully updated. AMD brand doesn't cope well with any game without it, apparently. All of them, including WOWS, are running noticeably smoother.

Share this post


Link to post
Share on other sites
Members
4,821 posts
7,993 battles
6 hours ago, Reymu said:

Update:

Turned out brother had forgotten to check the drivers are fully updated. AMD brand doesn't cope well with any game without it, apparently. All of them, including WOWS, are running noticeably smoother.

What drivers?  I have built many a AMD and a couple Intel machines and drivers by the selves are rarely an issue.   But if I understand what you guys did, you switched the drive in an Intel machine (with the OS I assume) to an AMD machine.  That would need the motherboard drivers (chipset drivers) to be reinstalled since AMD and Intel are not compatible with each other.  Generally better off reinstalling the OS completely when switching between AMD/Intel CPU and motherboard.  There are some ways around it but it is 50/50 as to if they work.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×